aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-02-19 05:13:02 +0800
committerdinoex <dinoex@FreeBSD.org>2013-02-19 05:13:02 +0800
commita69af0eb7aa0e2adb4c41ab4d6405385397f3eea (patch)
tree6c12a9e824cf39ccd0922fe8c2e9a8017ad5fc34 /net-mgmt
parentbe1d59b55171e62bfdf033d7120d3419cad24f73 (diff)
downloadfreebsd-ports-graphics-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.tar.gz
freebsd-ports-graphics-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.tar.zst
freebsd-ports-graphics-a69af0eb7aa0e2adb4c41ab4d6405385397f3eea.zip
- update libnet to 1.1.6
- build shared lib - fix dependend ports when libnet.so.8 was linked in - fix dependend ports when includes where missing
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ettercap/Makefile6
-rw-r--r--net-mgmt/isic/Makefile4
-rw-r--r--net-mgmt/isic/files/patch-isic.h18
-rw-r--r--net-mgmt/packit/Makefile4
-rw-r--r--net-mgmt/pixilate/Makefile4
5 files changed, 27 insertions, 9 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 8d019e6d826..73e9c667c3b 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ettercap
PORTVERSION= 0.7.4.1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net-mgmt security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}-Lazarus \
@@ -12,7 +12,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}-Lazarus \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
# GTK -> GTK2, ICONV -> UTF8
OPTIONS_DEFINE= DOCS GTK2 PCRE PLUGINS SSL UTF8
@@ -43,7 +43,7 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
-PKGNAMESUFFIX+= -gtk2
+PKGNAMESUFFIX?= -gtk2
CONFIGURE_ARGS+=--enable-gtk
USE_GNOME= atk glib20 gtk20 pango
.else
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 4c2aa318b08..354588719da 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -7,7 +7,7 @@
PORTNAME= isic
PORTVERSION= 0.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ISIC%20v${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= IP Stack Integrity Checker
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/net-mgmt/isic/files/patch-isic.h b/net-mgmt/isic/files/patch-isic.h
new file mode 100644
index 00000000000..356c6831a37
--- /dev/null
+++ b/net-mgmt/isic/files/patch-isic.h
@@ -0,0 +1,18 @@
+--- isic.h.orig 2006-12-16 01:08:44.000000000 +0100
++++ isic.h 2013-02-18 07:36:38.000000000 +0100
+@@ -5,11 +5,15 @@
+ #endif
+
+ #include <libnet.h>
++#include <libnet/libnet-headers.h>
+
++#include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+ #include <netinet/icmp6.h>
+ #include <netinet/ip6.h>
+ #include <netinet/if_ether.h>
++#include <netinet/udp.h>
++#include <netinet/tcp.h>
+
+ #ifndef ETHER_FRAME_SIZE
+ #define ETHER_FRAME_SIZE 1500
diff --git a/net-mgmt/packit/Makefile b/net-mgmt/packit/Makefile
index 293d10c32e8..a659dd3baa7 100644
--- a/net-mgmt/packit/Makefile
+++ b/net-mgmt/packit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= packit
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://packit.sourceforge.net/downloads/
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Network auditing tool
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
CPPFLAGS+= `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`
diff --git a/net-mgmt/pixilate/Makefile b/net-mgmt/pixilate/Makefile
index c92b3c33845..81b6e744633 100644
--- a/net-mgmt/pixilate/Makefile
+++ b/net-mgmt/pixilate/Makefile
@@ -6,14 +6,14 @@
PORTNAME= pixilate
PORTVERSION= 0.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/winfingerprint/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates packets to match a list of Cisco PIX access lists
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
WRKSRC= ${WRKDIR}/pixilate