aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2007-02-15 20:29:33 +0800
committermux <mux@FreeBSD.org>2007-02-15 20:29:33 +0800
commitb4a766881141de704cd522330e5c64661f898d30 (patch)
tree56c5dcac93da75502e2636131ed24085f8600b54 /net-mgmt
parentca2d5b83ed1648ca02b8d3ccd24f977fb1bb14e9 (diff)
downloadfreebsd-ports-graphics-b4a766881141de704cd522330e5c64661f898d30.tar.gz
freebsd-ports-graphics-b4a766881141de704cd522330e5c64661f898d30.tar.zst
freebsd-ports-graphics-b4a766881141de704cd522330e5c64661f898d30.zip
Add a patch taken from CVS to fix huge memory leaks in the code for
embedded Perl agents, and bump PORTREVISION. Reviewed by: pav Approved by: maintainer timeout
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile2
-rw-r--r--net-mgmt/net-snmp-devel/files/patch-agent.xs36
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent.xs36
-rw-r--r--net-mgmt/net-snmp53/Makefile2
-rw-r--r--net-mgmt/net-snmp53/files/patch-agent.xs36
6 files changed, 111 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index 11aaceda9c2..798559723bc 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp-devel/files/patch-agent.xs b/net-mgmt/net-snmp-devel/files/patch-agent.xs
new file mode 100644
index 00000000000..15862d39d7c
--- /dev/null
+++ b/net-mgmt/net-snmp-devel/files/patch-agent.xs
@@ -0,0 +1,36 @@
+--- perl/agent/agent.xs.old 2006/09/01 21:05:50 5.15.2.3
++++ perl/agent/agent.xs 2007/01/06 00:35:12 5.15.2.4
+@@ -569,7 +569,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -608,7 +608,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -997,11 +997,13 @@
+ rarg = newSViv(0);
+ arg = newSVrv(rarg, "NetSNMP::agent::netsnmp_request_infoPtr");
+ sv_setiv(arg, (IV) request);
+- ST(0) = rarg;
++ RETVAL = rarg;
+ } else {
+- ST(0) = &sv_undef;
++ RETVAL = &sv_undef;
+ }
+ }
++ OUTPUT:
++ RETVAL
+
+ MODULE = NetSNMP::agent PACKAGE = NetSNMP::agent::netsnmp_agent_request_info PREFIX = narqi_
+
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 11aaceda9c2..798559723bc 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp/files/patch-agent.xs b/net-mgmt/net-snmp/files/patch-agent.xs
new file mode 100644
index 00000000000..15862d39d7c
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent.xs
@@ -0,0 +1,36 @@
+--- perl/agent/agent.xs.old 2006/09/01 21:05:50 5.15.2.3
++++ perl/agent/agent.xs 2007/01/06 00:35:12 5.15.2.4
+@@ -569,7 +569,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -608,7 +608,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -997,11 +997,13 @@
+ rarg = newSViv(0);
+ arg = newSVrv(rarg, "NetSNMP::agent::netsnmp_request_infoPtr");
+ sv_setiv(arg, (IV) request);
+- ST(0) = rarg;
++ RETVAL = rarg;
+ } else {
+- ST(0) = &sv_undef;
++ RETVAL = &sv_undef;
+ }
+ }
++ OUTPUT:
++ RETVAL
+
+ MODULE = NetSNMP::agent PACKAGE = NetSNMP::agent::netsnmp_agent_request_info PREFIX = narqi_
+
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index 11aaceda9c2..798559723bc 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp53/files/patch-agent.xs b/net-mgmt/net-snmp53/files/patch-agent.xs
new file mode 100644
index 00000000000..15862d39d7c
--- /dev/null
+++ b/net-mgmt/net-snmp53/files/patch-agent.xs
@@ -0,0 +1,36 @@
+--- perl/agent/agent.xs.old 2006/09/01 21:05:50 5.15.2.3
++++ perl/agent/agent.xs 2007/01/06 00:35:12 5.15.2.4
+@@ -569,7 +569,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -608,7 +608,7 @@
+ arg = newSVrv(rarg, "netsnmp_oidPtr");
+ sv_setiv(arg, (IV) o);
+
+- XPUSHs(rarg);
++ XPUSHs(sv_2mortal(rarg));
+
+ PUTBACK;
+ i = perl_call_pv("NetSNMP::OID::newwithptr", G_SCALAR);
+@@ -997,11 +997,13 @@
+ rarg = newSViv(0);
+ arg = newSVrv(rarg, "NetSNMP::agent::netsnmp_request_infoPtr");
+ sv_setiv(arg, (IV) request);
+- ST(0) = rarg;
++ RETVAL = rarg;
+ } else {
+- ST(0) = &sv_undef;
++ RETVAL = &sv_undef;
+ }
+ }
++ OUTPUT:
++ RETVAL
+
+ MODULE = NetSNMP::agent PACKAGE = NetSNMP::agent::netsnmp_agent_request_info PREFIX = narqi_
+