aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
committergirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
commitca9d0e2291f677879c1b36a416eb2ad271850cbc (patch)
tree339f4530a6f0b38252173ddc8ba47c21226501d3 /net-mgmt
parentcbe074a01a678ad3149123153f48962b4b035576 (diff)
downloadfreebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.gz
freebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.zst
freebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios/Makefile2
-rw-r--r--net-mgmt/nagios12/Makefile2
-rw-r--r--net-mgmt/nagios2/Makefile2
-rw-r--r--net-mgmt/netsaint/Makefile3
-rw-r--r--net-mgmt/pmacct/Makefile2
-rw-r--r--net-mgmt/zabbix/Makefile2
-rw-r--r--net-mgmt/zabbix2/Makefile2
8 files changed, 8 insertions, 10 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 7419791fcb1..4c1663f1fbf 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -81,8 +81,7 @@ PLIST_SUB+= SUB_MYSQL="@comment "
.endif
.if defined(WITH_PGSQL)
-POSTGRESQL_PORT?=databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
PLIST_SUB+= SUB_PGSQL=""
.else
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 58d5af39282..9c89111ae5b 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/nagios12/Makefile b/net-mgmt/nagios12/Makefile
index 58d5af39282..9c89111ae5b 100644
--- a/net-mgmt/nagios12/Makefile
+++ b/net-mgmt/nagios12/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index 58d5af39282..9c89111ae5b 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--with-file-perfdata
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-inc=${LOCALBASE}/pgsql \
--with-pgsql-xdata
diff --git a/net-mgmt/netsaint/Makefile b/net-mgmt/netsaint/Makefile
index 9328db12de7..c998c3c98de 100644
--- a/net-mgmt/netsaint/Makefile
+++ b/net-mgmt/netsaint/Makefile
@@ -46,8 +46,7 @@ CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
.endif
.if defined(WITH_POSTGRES)
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/lib \
--with-pgsql-inc=${LOCALBASE}/include \
--with-pgsql-xdata
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index d33e30b2ec2..bb35d9eef90 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -23,7 +23,7 @@ PLIST_SUB+= WITH_MYSQL="@comment "
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+=--enable-pgsql
PLIST_SUB+= WITH_PGSQL=""
.else
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 347cfd271cf..c5b62da6c94 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -45,8 +45,8 @@ IGNORE= You should configure to use either a MySQL or PostgreSQL backend
.endif
.ifdef(WITH_PGSQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
.endif
.ifndef(WITHOUT_MYSQL)
USE_MYSQL= yes
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 347cfd271cf..c5b62da6c94 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -45,8 +45,8 @@ IGNORE= You should configure to use either a MySQL or PostgreSQL backend
.endif
.ifdef(WITH_PGSQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
.endif
.ifndef(WITHOUT_MYSQL)
USE_MYSQL= yes