aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/azureus/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-10-24 09:08:00 +0800
committerhq <hq@FreeBSD.org>2004-10-24 09:08:00 +0800
commit235a3e6979b1288579bfacefa36767e7787f01ab (patch)
tree7f46972f4487ab5e0e90bf461df9c443f4c1f495 /net-p2p/azureus/Makefile
parent828f762c147de06058ec1a7d1cc43885dbda3e0b (diff)
downloadfreebsd-ports-graphics-235a3e6979b1288579bfacefa36767e7787f01ab.tar.gz
freebsd-ports-graphics-235a3e6979b1288579bfacefa36767e7787f01ab.tar.zst
freebsd-ports-graphics-235a3e6979b1288579bfacefa36767e7787f01ab.zip
Azureus is a java bittorrent client. Azureus offers multiple
torrent downloads, queuing/priority systems (on torrents and files), start/stop seeding options and instant access to numerous pieces of information about your torrents. Azureus now features an embedded tracker easily setup and ready to use. WWW: http://azureus.sourceforge.com/ PR: 72682 Submitted by: Jeremy Faulkner <gldisater@gldis.ca> Reviewed by: glewis
Diffstat (limited to 'net-p2p/azureus/Makefile')
-rw-r--r--net-p2p/azureus/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/azureus/Makefile b/net-p2p/azureus/Makefile
new file mode 100644
index 00000000000..9492eb7bca7
--- /dev/null
+++ b/net-p2p/azureus/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: Azureus
+# Date created: October 6, 2004
+# Whom: Jeremy Faulkner <gldisater@gldis.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= azureus
+PORTVERSION= 2.1.0.4
+CATEGORIES= net java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Azureus${PORTVERSION}.jar
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= gldisater@gldis.ca
+COMMENT= A BitTorrent client written in Java
+
+RUN_DEPENDS= ${LOCALBASE}/eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+JAVA_RUN= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+JARFILE= Azureus2.jar
+
+PLIST_FILES= %%DATADIR%%/${JARFILE} bin/${PORTNAME}
+
+do-configure:
+ ${SED} -e "s+%%PREFIX%%+${PREFIX}+" -e "s+%%LOCALBASE%%+${LOCALBASE}+" \
+ -e "s+%%JAVA%%+${JAVA}+" -e "s+%%DATADIR%%+${DATADIR}+" \
+ ${FILESDIR}/${PORTNAME} > ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${DATADIR}/${JARFILE}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>