aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/eiskaltdcpp-qt
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-12-21 12:05:15 +0800
committergerald <gerald@FreeBSD.org>2012-12-21 12:05:15 +0800
commit72681b41d0745d82f8e55cf2924a1694dba1891b (patch)
tree1b2348cce1d747f00a050132edbbba3e549f7de8 /net-p2p/eiskaltdcpp-qt
parent9ae8cca5220a835036f02850fec8097e5f61d821 (diff)
downloadfreebsd-ports-graphics-72681b41d0745d82f8e55cf2924a1694dba1891b.tar.gz
freebsd-ports-graphics-72681b41d0745d82f8e55cf2924a1694dba1891b.tar.zst
freebsd-ports-graphics-72681b41d0745d82f8e55cf2924a1694dba1891b.zip
Replace the use of _GCC_BUILD_DEPENDS (which was never meant to be
used outside of Mk/bsd.gcc.mk) by _GCC_RUNTIME. This is still not ideal, but at least a documented stopgap, and it avoids the manual construction of the directory to be added to rpath. As a side effect, the Makefiles become a tad simpler. On the way, update to USE_GCC=4.6+ per pending work of linimon and myself. Approved by: maintainer
Diffstat (limited to 'net-p2p/eiskaltdcpp-qt')
-rw-r--r--net-p2p/eiskaltdcpp-qt/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net-p2p/eiskaltdcpp-qt/Makefile b/net-p2p/eiskaltdcpp-qt/Makefile
index c37850f0d63..86ed3abbb86 100644
--- a/net-p2p/eiskaltdcpp-qt/Makefile
+++ b/net-p2p/eiskaltdcpp-qt/Makefile
@@ -28,7 +28,7 @@ CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.4+
+USE_GCC= 4.6+
USE_GETTEXT= yes
USE_CMAKE= yes
USE_OPENSSL= yes
@@ -116,9 +116,7 @@ CMAKE_ARGS+= -DUSE_MINIUPNP:BOOL=OFF
USE_OPENSSL_PORT=yes
.endif
-GCC_LIBS= "${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}"
-
post-build:
- ${LOCALBASE}/bin/chrpath -r "${GCC_LIBS}" "${WRKSRC}/${PORTNAME}/${PORTNAME}"
+ ${LOCALBASE}/bin/chrpath -r "${_GCC_RUNTIME}" "${WRKSRC}/${PORTNAME}/${PORTNAME}"
.include <bsd.port.post.mk>