aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gift-openft/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-06 19:32:43 +0800
committeredwin <edwin@FreeBSD.org>2003-10-06 19:32:43 +0800
commit542afd2937b0495552913fcaf29c47a6136fb667 (patch)
tree777fc47c55bd4ea93e5b4eede8360fed8c39d17e /net-p2p/gift-openft/Makefile
parent53b3cc0f997579974374e2ea075e18cfecae6e7e (diff)
downloadfreebsd-ports-graphics-542afd2937b0495552913fcaf29c47a6136fb667.tar.gz
freebsd-ports-graphics-542afd2937b0495552913fcaf29c47a6136fb667.tar.zst
freebsd-ports-graphics-542afd2937b0495552913fcaf29c47a6136fb667.zip
new port: net/gift-openft
add new port: net/gift-openft - An OpenFT plugin for gift This is the first of three available gift plugins (at the moment). As soon as gift gets commited I'll send PRs for gift-gnutella and gift-fasttrack. PR: ports/56485 Submitted by: Stefan Ehmann <shoesoft@gmx.net>
Diffstat (limited to 'net-p2p/gift-openft/Makefile')
-rw-r--r--net-p2p/gift-openft/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/gift-openft/Makefile b/net-p2p/gift-openft/Makefile
new file mode 100644
index 00000000000..6b9a4ba4aa9
--- /dev/null
+++ b/net-p2p/gift-openft/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: giFT-OpenFT
+# Date created: 2003-09-04
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFT-OpenFT
+PORTVERSION= 0.2.1.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gift
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= An OpenFT plugin for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift \
+ db3.3:${PORTSDIR}/databases/db3
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+DOC_FILES= AUTHORS COPYING ChangeLog \
+ INSTALL NEWS README TODO
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>