aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/hrktorrent
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-20 07:18:50 +0800
committermiwi <miwi@FreeBSD.org>2008-07-20 07:18:50 +0800
commitccb4a0faf9a505f76d5b2db69b3799f0914660d7 (patch)
treea4e0d06aa32da008dc0ec2582247d9ae67450508 /net-p2p/hrktorrent
parentb8f25a52af99557564408f2b42e001fc821d0228 (diff)
downloadfreebsd-ports-graphics-ccb4a0faf9a505f76d5b2db69b3799f0914660d7.tar.gz
freebsd-ports-graphics-ccb4a0faf9a505f76d5b2db69b3799f0914660d7.tar.zst
freebsd-ports-graphics-ccb4a0faf9a505f76d5b2db69b3799f0914660d7.zip
hrktorrent is a light console torrent client using rasterbar's libtorrent.
It supports the IPFilter and DHT implementation of libtorrent. It is aimed to be light and fast. WWW: http://henrik.unit5.ca/hrktorrent/ PR: ports/125102 Submitted by: hrkfrd at gmail.com
Diffstat (limited to 'net-p2p/hrktorrent')
-rw-r--r--net-p2p/hrktorrent/Makefile33
-rw-r--r--net-p2p/hrktorrent/distinfo3
-rw-r--r--net-p2p/hrktorrent/files/patch-vars.mk9
-rw-r--r--net-p2p/hrktorrent/pkg-descr5
-rw-r--r--net-p2p/hrktorrent/pkg-message7
5 files changed, 57 insertions, 0 deletions
diff --git a/net-p2p/hrktorrent/Makefile b/net-p2p/hrktorrent/Makefile
new file mode 100644
index 00000000000..7487bdeca64
--- /dev/null
+++ b/net-p2p/hrktorrent/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: hrktorrent
+# Date created: Jun 29, 2008
+# Whom: hrkfrd@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= hrktorrent
+PORTVERSION= 0.3.2
+CATEGORIES= net-p2p
+MASTER_SITES= http://henrik.unit5.ca/hrktorrent/
+
+MAINTAINER= hrkfrd@gmail.com
+COMMENT= A light console torrent client using rasterbar's libtorrent
+
+LIB_DEPENDS= torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
+
+USE_GNOME= pkgconfig
+USE_BZIP2= yes
+
+PLIST_FILES= bin/hrktorrent \
+ share/examples/hrktorrent/hrktorrent.rc
+PLIST_DIRS= share/examples/hrktorrent
+
+MAN1= hrktorrent.1
+MANCOMPRESSED= no
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/hrktorrent
+ @${CAT} ${PKGMESSAGE} | ${SED} "s|PREFIX|${PREFIX}|g" \
+ ${PKGDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/net-p2p/hrktorrent/distinfo b/net-p2p/hrktorrent/distinfo
new file mode 100644
index 00000000000..25c2b2f968e
--- /dev/null
+++ b/net-p2p/hrktorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (hrktorrent-0.3.2.tar.bz2) = 17809a039c8dead47d65dd8b029f052a
+SHA256 (hrktorrent-0.3.2.tar.bz2) = 2de5ab866edfa0eb4b819b05f5be0ab7fc79ea5fbd5b266e40ded1c11f1fedf8
+SIZE (hrktorrent-0.3.2.tar.bz2) = 7637
diff --git a/net-p2p/hrktorrent/files/patch-vars.mk b/net-p2p/hrktorrent/files/patch-vars.mk
new file mode 100644
index 00000000000..5c17c64688c
--- /dev/null
+++ b/net-p2p/hrktorrent/files/patch-vars.mk
@@ -0,0 +1,9 @@
+--- vars.mk.orig 2008-06-29 16:18:44.000000000 +0200
++++ vars.mk 2008-06-29 16:18:52.000000000 +0200
+@@ -4,5 +4,5 @@
+ OBJ = main.o core.o settings.o utils.o ipfilter.o
+ OUT = hrktorrent
+ CXXFLAGS += `pkg-config --cflags libtorrent`
+-LIBS = `pkg-config --libs libtorrent` -lpthread
++LIBS = `pkg-config --libs libtorrent` -pthread
+
diff --git a/net-p2p/hrktorrent/pkg-descr b/net-p2p/hrktorrent/pkg-descr
new file mode 100644
index 00000000000..5c72fbf8045
--- /dev/null
+++ b/net-p2p/hrktorrent/pkg-descr
@@ -0,0 +1,5 @@
+hrktorrent is a light console torrent client using rasterbar's libtorrent.
+It supports the IPFilter and DHT implementation of libtorrent.
+It is aimed to be light and fast.
+
+WWW: http://henrik.unit5.ca/hrktorrent/
diff --git a/net-p2p/hrktorrent/pkg-message b/net-p2p/hrktorrent/pkg-message
new file mode 100644
index 00000000000..f81a0184ed8
--- /dev/null
+++ b/net-p2p/hrktorrent/pkg-message
@@ -0,0 +1,7 @@
+-----------------------------------------------------------------
+A default hrktorrent.rc config has been installed to:
+ PREFIX/share/examples/hrktorrent.rc
+Copy it to ~/.hrktorrent/ and modify it.
+To use the IPFilter, move the rulefile the same dir and name it:
+ ipfilter.dat.
+-----------------------------------------------------------------