aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/torrent_swapper
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-05-03 00:25:46 +0800
committeralepulver <alepulver@FreeBSD.org>2007-05-03 00:25:46 +0800
commit60eddfa91b275c0b1542de3f35c5780c81ec0418 (patch)
tree77962178393ebec207143305af89e1fe93c265d3 /net-p2p/torrent_swapper
parentd47dc116b7bf4b7e219b0193331b60acc2fddcb1 (diff)
downloadfreebsd-ports-graphics-60eddfa91b275c0b1542de3f35c5780c81ec0418.tar.gz
freebsd-ports-graphics-60eddfa91b275c0b1542de3f35c5780c81ec0418.tar.zst
freebsd-ports-graphics-60eddfa91b275c0b1542de3f35c5780c81ec0418.zip
Torrent Swapper is an open sourced sociable peer to peer file-sharing client
based on the Bittorrent protocol that is ideal for high-speed distribution of large files that has a basic understanding of human friendships, of user tastes in content, and of Internet connectivity between users. Torrent Swapper supports simultaneous downloads, download queue, selected downloads in torrent package, fast-resume, disk cache, speed limits, port mapping, proxy, ip-filter, etc. Features include: * Amazon-like recommendations to get interesting files. * Doubling the download speed by using the upload capacity of friends. * Real-time P2P file sharing with P2P video streaming. * Showing the locations of seeders / leechers of the same content with city-level accuracy on a world map. * Multiple downloads in a single window. * Queueing system with priority. * Supporing pause, stop, resume, queue, remove operations. * Supporting global setting such as upload and download limiting. * Supporting local setting for each torrent as well. WWW: http://bit-torrent.sourceforge.net/
Diffstat (limited to 'net-p2p/torrent_swapper')
-rw-r--r--net-p2p/torrent_swapper/Makefile56
-rw-r--r--net-p2p/torrent_swapper/distinfo3
-rw-r--r--net-p2p/torrent_swapper/pkg-descr22
-rw-r--r--net-p2p/torrent_swapper/pkg-plist442
4 files changed, 523 insertions, 0 deletions
diff --git a/net-p2p/torrent_swapper/Makefile b/net-p2p/torrent_swapper/Makefile
new file mode 100644
index 00000000000..4ef27acdde6
--- /dev/null
+++ b/net-p2p/torrent_swapper/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: torrent_swapper
+# Date created: 2007-04-17
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrent_swapper
+PORTVERSION= 1.0
+CATEGORIES= net-p2p
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= bit-torrent
+DISTNAME= swapper
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Sociable P2P network client based on Bittorrent
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/M2Crypto/__init__.py:${PORTSDIR}/security/py-m2crypto \
+ ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+
+USE_PYTHON= 2.4+
+USE_WX= 2.6+
+WX_COMPS= python
+WX_UNICODE= yes
+NO_WRKSUBDIR= yes
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f -name "*.pyc" -print0 | ${XARGS} -0 ${RM} -f
+ @cd ${WRKSRC} && \
+ ${RM} -rf *.bat *.exe.* *.nsi *.sh LICENSE.txt debian mac && \
+ ${MKDIR} _extras && \
+ ${MV} how_to_compile.txt lastest_version.txt protocol_v3.txt \
+ readme.txt swapper.xpm _extras
+
+do-build:
+ @(${ECHO_CMD} "#!${SH}"; ${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
+ ${ECHO_CMD} 'exec ${PYTHON_CMD} abc.py "$$@"') > \
+ ${WRKSRC}/_extras/${PORTNAME}
+ @${PYTHON_CMD} -Oc 'import compileall; \
+ compileall.compile_dir("${WRKSRC}", force=1)'
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/_extras/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/[^_]* ${DATADIR}
+ @${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/_extras/swapper.xpm \
+ ${PREFIX}/share/pixmaps
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/_extras/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-p2p/torrent_swapper/distinfo b/net-p2p/torrent_swapper/distinfo
new file mode 100644
index 00000000000..cb15c72a608
--- /dev/null
+++ b/net-p2p/torrent_swapper/distinfo
@@ -0,0 +1,3 @@
+MD5 (swapper.tar.gz) = 22460c3fdebc3f116f06d03fca3422f7
+SHA256 (swapper.tar.gz) = 7afa9a62f65595cdc973476ad8cbb5afd90c2a471740c77ef9c60372247aaf66
+SIZE (swapper.tar.gz) = 634196
diff --git a/net-p2p/torrent_swapper/pkg-descr b/net-p2p/torrent_swapper/pkg-descr
new file mode 100644
index 00000000000..a413b6f198d
--- /dev/null
+++ b/net-p2p/torrent_swapper/pkg-descr
@@ -0,0 +1,22 @@
+Torrent Swapper is an open sourced sociable peer to peer file-sharing client
+based on the Bittorrent protocol that is ideal for high-speed distribution of
+large files that has a basic understanding of human friendships, of user
+tastes in content, and of Internet connectivity between users. Torrent Swapper
+supports simultaneous downloads, download queue, selected downloads in torrent
+package, fast-resume, disk cache, speed limits, port mapping, proxy,
+ip-filter, etc.
+
+Features include:
+
+* Amazon-like recommendations to get interesting files.
+* Doubling the download speed by using the upload capacity of friends.
+* Real-time P2P file sharing with P2P video streaming.
+* Showing the locations of seeders / leechers of the same content with
+ city-level accuracy on a world map.
+* Multiple downloads in a single window.
+* Queueing system with priority.
+* Supporing pause, stop, resume, queue, remove operations.
+* Supporting global setting such as upload and download limiting.
+* Supporting local setting for each torrent as well.
+
+WWW: http://bit-torrent.sourceforge.net/
diff --git a/net-p2p/torrent_swapper/pkg-plist b/net-p2p/torrent_swapper/pkg-plist
new file mode 100644
index 00000000000..354535668f0
--- /dev/null
+++ b/net-p2p/torrent_swapper/pkg-plist
@@ -0,0 +1,442 @@
+bin/torrent_swapper
+%%PORTDOCS%%%%DOCSDIR%%/how_to_compile.txt
+%%PORTDOCS%%%%DOCSDIR%%/lastest_version.txt
+%%PORTDOCS%%%%DOCSDIR%%/protocol_v3.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+share/pixmaps/swapper.xpm
+%%DATADIR%%/ABC/Actions/__init__.py
+%%DATADIR%%/ABC/Actions/__init__.pyo
+%%DATADIR%%/ABC/Actions/actionbase.py
+%%DATADIR%%/ABC/Actions/actionbase.pyo
+%%DATADIR%%/ABC/Actions/actions.py
+%%DATADIR%%/ABC/Actions/actions.pyo
+%%DATADIR%%/ABC/Actions/menus.py
+%%DATADIR%%/ABC/Actions/menus.pyo
+%%DATADIR%%/ABC/Actions/move.py
+%%DATADIR%%/ABC/Actions/move.pyo
+%%DATADIR%%/ABC/Actions/other.py
+%%DATADIR%%/ABC/Actions/other.pyo
+%%DATADIR%%/ABC/Actions/status.py
+%%DATADIR%%/ABC/Actions/status.pyo
+%%DATADIR%%/ABC/GUI/__init__.py
+%%DATADIR%%/ABC/GUI/__init__.pyo
+%%DATADIR%%/ABC/GUI/list.py
+%%DATADIR%%/ABC/GUI/list.pyo
+%%DATADIR%%/ABC/GUI/menu.py
+%%DATADIR%%/ABC/GUI/menu.pyo
+%%DATADIR%%/ABC/GUI/spinner.py
+%%DATADIR%%/ABC/GUI/spinner.pyo
+%%DATADIR%%/ABC/GUI/toolbar.py
+%%DATADIR%%/ABC/GUI/toolbar.pyo
+%%DATADIR%%/ABC/Scheduler/__init__.py
+%%DATADIR%%/ABC/Scheduler/__init__.pyo
+%%DATADIR%%/ABC/Scheduler/action.py
+%%DATADIR%%/ABC/Scheduler/action.pyo
+%%DATADIR%%/ABC/Scheduler/addtorrents.py
+%%DATADIR%%/ABC/Scheduler/addtorrents.pyo
+%%DATADIR%%/ABC/Scheduler/ratemanager.py
+%%DATADIR%%/ABC/Scheduler/ratemanager.pyo
+%%DATADIR%%/ABC/Scheduler/scheduler.py
+%%DATADIR%%/ABC/Scheduler/scheduler.pyo
+%%DATADIR%%/ABC/Toolbars/__init__.py
+%%DATADIR%%/ABC/Toolbars/__init__.pyo
+%%DATADIR%%/ABC/Toolbars/spinners.py
+%%DATADIR%%/ABC/Toolbars/spinners.pyo
+%%DATADIR%%/ABC/Toolbars/toolbars.py
+%%DATADIR%%/ABC/Toolbars/toolbars.pyo
+%%DATADIR%%/ABC/Torrent/__init__.py
+%%DATADIR%%/ABC/Torrent/__init__.pyo
+%%DATADIR%%/ABC/Torrent/abctorrent.py
+%%DATADIR%%/ABC/Torrent/abctorrent.pyo
+%%DATADIR%%/ABC/Torrent/actions.py
+%%DATADIR%%/ABC/Torrent/actions.pyo
+%%DATADIR%%/ABC/Torrent/config.py
+%%DATADIR%%/ABC/Torrent/config.pyo
+%%DATADIR%%/ABC/Torrent/connectmanager.py
+%%DATADIR%%/ABC/Torrent/connectmanager.pyo
+%%DATADIR%%/ABC/Torrent/dialogs.py
+%%DATADIR%%/ABC/Torrent/dialogs.pyo
+%%DATADIR%%/ABC/Torrent/files.py
+%%DATADIR%%/ABC/Torrent/files.pyo
+%%DATADIR%%/ABC/Torrent/status.py
+%%DATADIR%%/ABC/Torrent/status.pyo
+%%DATADIR%%/ABC/__init__.py
+%%DATADIR%%/ABC/__init__.pyo
+%%DATADIR%%/BitTornado/BT1/Choker.py
+%%DATADIR%%/BitTornado/BT1/Choker.pyo
+%%DATADIR%%/BitTornado/BT1/Connecter.py
+%%DATADIR%%/BitTornado/BT1/Connecter.pyo
+%%DATADIR%%/BitTornado/BT1/Downloader.py
+%%DATADIR%%/BitTornado/BT1/Downloader.pyo
+%%DATADIR%%/BitTornado/BT1/DownloaderFeedback.py
+%%DATADIR%%/BitTornado/BT1/DownloaderFeedback.pyo
+%%DATADIR%%/BitTornado/BT1/Encrypter.py
+%%DATADIR%%/BitTornado/BT1/Encrypter.pyo
+%%DATADIR%%/BitTornado/BT1/FileSelector.py
+%%DATADIR%%/BitTornado/BT1/FileSelector.pyo
+%%DATADIR%%/BitTornado/BT1/Filter.py
+%%DATADIR%%/BitTornado/BT1/Filter.pyo
+%%DATADIR%%/BitTornado/BT1/HTTPDownloader.py
+%%DATADIR%%/BitTornado/BT1/HTTPDownloader.pyo
+%%DATADIR%%/BitTornado/BT1/MessageID.py
+%%DATADIR%%/BitTornado/BT1/MessageID.pyo
+%%DATADIR%%/BitTornado/BT1/NatCheck.py
+%%DATADIR%%/BitTornado/BT1/NatCheck.pyo
+%%DATADIR%%/BitTornado/BT1/PiecePicker.py
+%%DATADIR%%/BitTornado/BT1/PiecePicker.pyo
+%%DATADIR%%/BitTornado/BT1/Rerequester.py
+%%DATADIR%%/BitTornado/BT1/Rerequester.pyo
+%%DATADIR%%/BitTornado/BT1/Statistics.py
+%%DATADIR%%/BitTornado/BT1/Statistics.pyo
+%%DATADIR%%/BitTornado/BT1/Storage.py
+%%DATADIR%%/BitTornado/BT1/Storage.pyo
+%%DATADIR%%/BitTornado/BT1/StorageWrapper.py
+%%DATADIR%%/BitTornado/BT1/StorageWrapper.pyo
+%%DATADIR%%/BitTornado/BT1/StreamCheck.py
+%%DATADIR%%/BitTornado/BT1/StreamCheck.pyo
+%%DATADIR%%/BitTornado/BT1/T2T.py
+%%DATADIR%%/BitTornado/BT1/T2T.pyo
+%%DATADIR%%/BitTornado/BT1/Uploader.py
+%%DATADIR%%/BitTornado/BT1/Uploader.pyo
+%%DATADIR%%/BitTornado/BT1/__init__.py
+%%DATADIR%%/BitTornado/BT1/__init__.pyo
+%%DATADIR%%/BitTornado/BT1/btformats.py
+%%DATADIR%%/BitTornado/BT1/btformats.pyo
+%%DATADIR%%/BitTornado/BT1/fakeopen.py
+%%DATADIR%%/BitTornado/BT1/fakeopen.pyo
+%%DATADIR%%/BitTornado/BT1/track.py
+%%DATADIR%%/BitTornado/BT1/track.pyo
+%%DATADIR%%/BitTornado/ConfigDir.py
+%%DATADIR%%/BitTornado/ConfigDir.pyo
+%%DATADIR%%/BitTornado/ConfigReader.py
+%%DATADIR%%/BitTornado/ConfigReader.pyo
+%%DATADIR%%/BitTornado/ConnChoice.py
+%%DATADIR%%/BitTornado/ConnChoice.pyo
+%%DATADIR%%/BitTornado/CreateIcons.py
+%%DATADIR%%/BitTornado/CreateIcons.pyo
+%%DATADIR%%/BitTornado/CurrentRateMeasure.py
+%%DATADIR%%/BitTornado/CurrentRateMeasure.pyo
+%%DATADIR%%/BitTornado/HTTPHandler.py
+%%DATADIR%%/BitTornado/HTTPHandler.pyo
+%%DATADIR%%/BitTornado/PSYCO.py
+%%DATADIR%%/BitTornado/PSYCO.pyo
+%%DATADIR%%/BitTornado/RateLimiter.py
+%%DATADIR%%/BitTornado/RateLimiter.pyo
+%%DATADIR%%/BitTornado/RateMeasure.py
+%%DATADIR%%/BitTornado/RateMeasure.pyo
+%%DATADIR%%/BitTornado/RawServer.py
+%%DATADIR%%/BitTornado/RawServer.pyo
+%%DATADIR%%/BitTornado/ServerPortHandler.py
+%%DATADIR%%/BitTornado/ServerPortHandler.pyo
+%%DATADIR%%/BitTornado/SocketHandler.py
+%%DATADIR%%/BitTornado/SocketHandler.pyo
+%%DATADIR%%/BitTornado/__init__.py
+%%DATADIR%%/BitTornado/__init__.pyo
+%%DATADIR%%/BitTornado/bencode.py
+%%DATADIR%%/BitTornado/bencode.pyo
+%%DATADIR%%/BitTornado/bitfield.py
+%%DATADIR%%/BitTornado/bitfield.pyo
+%%DATADIR%%/BitTornado/clock.py
+%%DATADIR%%/BitTornado/clock.pyo
+%%DATADIR%%/BitTornado/download_bt1.py
+%%DATADIR%%/BitTornado/download_bt1.pyo
+%%DATADIR%%/BitTornado/inifile.py
+%%DATADIR%%/BitTornado/inifile.pyo
+%%DATADIR%%/BitTornado/iprangeparse.py
+%%DATADIR%%/BitTornado/iprangeparse.pyo
+%%DATADIR%%/BitTornado/launchmanycore.py
+%%DATADIR%%/BitTornado/launchmanycore.pyo
+%%DATADIR%%/BitTornado/natpunch.py
+%%DATADIR%%/BitTornado/natpunch.pyo
+%%DATADIR%%/BitTornado/parseargs.py
+%%DATADIR%%/BitTornado/parseargs.pyo
+%%DATADIR%%/BitTornado/parsedir.py
+%%DATADIR%%/BitTornado/parsedir.pyo
+%%DATADIR%%/BitTornado/piecebuffer.py
+%%DATADIR%%/BitTornado/piecebuffer.pyo
+%%DATADIR%%/BitTornado/selectpoll.py
+%%DATADIR%%/BitTornado/selectpoll.pyo
+%%DATADIR%%/BitTornado/subnetparse.py
+%%DATADIR%%/BitTornado/subnetparse.pyo
+%%DATADIR%%/BitTornado/torrentlistparse.py
+%%DATADIR%%/BitTornado/torrentlistparse.pyo
+%%DATADIR%%/BitTornado/zurllib.py
+%%DATADIR%%/BitTornado/zurllib.pyo
+%%DATADIR%%/Dialogs/__init__.py
+%%DATADIR%%/Dialogs/__init__.pyo
+%%DATADIR%%/Dialogs/abcdetailframe.py
+%%DATADIR%%/Dialogs/abcdetailframe.pyo
+%%DATADIR%%/Dialogs/abcoption.py
+%%DATADIR%%/Dialogs/abcoption.pyo
+%%DATADIR%%/Dialogs/aboutme.py
+%%DATADIR%%/Dialogs/aboutme.pyo
+%%DATADIR%%/Dialogs/closedialog.py
+%%DATADIR%%/Dialogs/closedialog.pyo
+%%DATADIR%%/Dialogs/dupfiledialog.py
+%%DATADIR%%/Dialogs/dupfiledialog.pyo
+%%DATADIR%%/Dialogs/localupload.py
+%%DATADIR%%/Dialogs/localupload.pyo
+%%DATADIR%%/Dialogs/portdialog.py
+%%DATADIR%%/Dialogs/portdialog.pyo
+%%DATADIR%%/Dialogs/regdialog.py
+%%DATADIR%%/Dialogs/regdialog.pyo
+%%DATADIR%%/Dialogs/setdestdlg.py
+%%DATADIR%%/Dialogs/setdestdlg.pyo
+%%DATADIR%%/Lang/__init__.py
+%%DATADIR%%/Lang/__init__.pyo
+%%DATADIR%%/Lang/english.lang
+%%DATADIR%%/Lang/lang.py
+%%DATADIR%%/Lang/lang.pyo
+%%DATADIR%%/Swapper/BuddyCast/TorrentCollecting.py
+%%DATADIR%%/Swapper/BuddyCast/TorrentCollecting.pyo
+%%DATADIR%%/Swapper/BuddyCast/__init__.py
+%%DATADIR%%/Swapper/BuddyCast/__init__.pyo
+%%DATADIR%%/Swapper/BuddyCast/buddycast.py
+%%DATADIR%%/Swapper/BuddyCast/buddycast.pyo
+%%DATADIR%%/Swapper/BuddyCast/similarity.py
+%%DATADIR%%/Swapper/BuddyCast/similarity.pyo
+%%DATADIR%%/Swapper/CacheDB/CacheDBHandler.py
+%%DATADIR%%/Swapper/CacheDB/CacheDBHandler.pyo
+%%DATADIR%%/Swapper/CacheDB/__init__.py
+%%DATADIR%%/Swapper/CacheDB/__init__.pyo
+%%DATADIR%%/Swapper/CacheDB/cachedb.py
+%%DATADIR%%/Swapper/CacheDB/cachedb.pyo
+%%DATADIR%%/Swapper/CacheDB/friends.py
+%%DATADIR%%/Swapper/CacheDB/friends.pyo
+%%DATADIR%%/Swapper/CacheDB/superpeer.py
+%%DATADIR%%/Swapper/CacheDB/superpeer.pyo
+%%DATADIR%%/Swapper/Dialogs/__init__.py
+%%DATADIR%%/Swapper/Dialogs/__init__.pyo
+%%DATADIR%%/Swapper/Dialogs/abcbuddyframe.py
+%%DATADIR%%/Swapper/Dialogs/abcbuddyframe.pyo
+%%DATADIR%%/Swapper/Dialogs/abcfileframe.py
+%%DATADIR%%/Swapper/Dialogs/abcfileframe.pyo
+%%DATADIR%%/Swapper/Dialogs/common.py
+%%DATADIR%%/Swapper/Dialogs/common.pyo
+%%DATADIR%%/Swapper/Dialogs/dlhelperframe.py
+%%DATADIR%%/Swapper/Dialogs/dlhelperframe.pyo
+%%DATADIR%%/Swapper/Dialogs/makefriends.py
+%%DATADIR%%/Swapper/Dialogs/makefriends.pyo
+%%DATADIR%%/Swapper/Dialogs/managefriends.py
+%%DATADIR%%/Swapper/Dialogs/managefriends.pyo
+%%DATADIR%%/Swapper/Merkle/__init__.py
+%%DATADIR%%/Swapper/Merkle/__init__.pyo
+%%DATADIR%%/Swapper/Merkle/merkle.py
+%%DATADIR%%/Swapper/Merkle/merkle.pyo
+%%DATADIR%%/Swapper/Overlay/MetadataHandler.py
+%%DATADIR%%/Swapper/Overlay/MetadataHandler.pyo
+%%DATADIR%%/Swapper/Overlay/OverlayApps.py
+%%DATADIR%%/Swapper/Overlay/OverlayApps.pyo
+%%DATADIR%%/Swapper/Overlay/OverlayConnecter.py
+%%DATADIR%%/Swapper/Overlay/OverlayConnecter.pyo
+%%DATADIR%%/Swapper/Overlay/OverlayEncrypter.py
+%%DATADIR%%/Swapper/Overlay/OverlayEncrypter.pyo
+%%DATADIR%%/Swapper/Overlay/OverlaySwarm.py
+%%DATADIR%%/Swapper/Overlay/OverlaySwarm.pyo
+%%DATADIR%%/Swapper/Overlay/SecureOverlay.py
+%%DATADIR%%/Swapper/Overlay/SecureOverlay.pyo
+%%DATADIR%%/Swapper/Overlay/__init__.py
+%%DATADIR%%/Swapper/Overlay/__init__.pyo
+%%DATADIR%%/Swapper/Overlay/permid.py
+%%DATADIR%%/Swapper/Overlay/permid.pyo
+%%DATADIR%%/Swapper/Statistics/Logger.py
+%%DATADIR%%/Swapper/Statistics/Logger.pyo
+%%DATADIR%%/Swapper/Statistics/__init__.py
+%%DATADIR%%/Swapper/Statistics/__init__.pyo
+%%DATADIR%%/Swapper/Worldmap/__init__.py
+%%DATADIR%%/Swapper/Worldmap/__init__.pyo
+%%DATADIR%%/Swapper/Worldmap/ipinfo.py
+%%DATADIR%%/Swapper/Worldmap/ipinfo.pyo
+%%DATADIR%%/Swapper/Worldmap/peer.py
+%%DATADIR%%/Swapper/Worldmap/peer.pyo
+%%DATADIR%%/Swapper/__init__.py
+%%DATADIR%%/Swapper/__init__.pyo
+%%DATADIR%%/Swapper/guessip.py
+%%DATADIR%%/Swapper/guessip.pyo
+%%DATADIR%%/Swapper/toofastbt/Coordinator.py
+%%DATADIR%%/Swapper/toofastbt/Coordinator.pyo
+%%DATADIR%%/Swapper/toofastbt/CoordinatorMessageHandler.py
+%%DATADIR%%/Swapper/toofastbt/CoordinatorMessageHandler.pyo
+%%DATADIR%%/Swapper/toofastbt/Helper.py
+%%DATADIR%%/Swapper/toofastbt/Helper.pyo
+%%DATADIR%%/Swapper/toofastbt/HelperMessageHandler.py
+%%DATADIR%%/Swapper/toofastbt/HelperMessageHandler.pyo
+%%DATADIR%%/Swapper/toofastbt/Logger.py
+%%DATADIR%%/Swapper/toofastbt/Logger.pyo
+%%DATADIR%%/Swapper/toofastbt/RatePredictor.py
+%%DATADIR%%/Swapper/toofastbt/RatePredictor.pyo
+%%DATADIR%%/Swapper/toofastbt/__init__.py
+%%DATADIR%%/Swapper/toofastbt/__init__.pyo
+%%DATADIR%%/Swapper/unicode.py
+%%DATADIR%%/Swapper/unicode.pyo
+%%DATADIR%%/Swapper/utilities.py
+%%DATADIR%%/Swapper/utilities.pyo
+%%DATADIR%%/TorrentMaker/__init__.py
+%%DATADIR%%/TorrentMaker/__init__.pyo
+%%DATADIR%%/TorrentMaker/btmakemetafile.py
+%%DATADIR%%/TorrentMaker/btmakemetafile.pyo
+%%DATADIR%%/TorrentMaker/btmaketorrentgui.py
+%%DATADIR%%/TorrentMaker/btmaketorrentgui.pyo
+%%DATADIR%%/Utility/__init__.py
+%%DATADIR%%/Utility/__init__.pyo
+%%DATADIR%%/Utility/compat.py
+%%DATADIR%%/Utility/compat.pyo
+%%DATADIR%%/Utility/configreader.py
+%%DATADIR%%/Utility/configreader.pyo
+%%DATADIR%%/Utility/constants.py
+%%DATADIR%%/Utility/constants.pyo
+%%DATADIR%%/Utility/getscrapedata.py
+%%DATADIR%%/Utility/getscrapedata.pyo
+%%DATADIR%%/Utility/guimanager.py
+%%DATADIR%%/Utility/guimanager.pyo
+%%DATADIR%%/Utility/helpers.py
+%%DATADIR%%/Utility/helpers.pyo
+%%DATADIR%%/Utility/regchecker.py
+%%DATADIR%%/Utility/regchecker.pyo
+%%DATADIR%%/Utility/utility.py
+%%DATADIR%%/Utility/utility.pyo
+%%DATADIR%%/abc.py
+%%DATADIR%%/abc.pyo
+%%DATADIR%%/abcengine.py
+%%DATADIR%%/abcengine.pyo
+%%DATADIR%%/btdownloadheadless.py
+%%DATADIR%%/btdownloadheadless.pyo
+%%DATADIR%%/btlaunchmany.py
+%%DATADIR%%/btlaunchmany.pyo
+%%DATADIR%%/btshowmetainfo.py
+%%DATADIR%%/btshowmetainfo.pyo
+%%DATADIR%%/bttrack.py
+%%DATADIR%%/bttrack.pyo
+%%DATADIR%%/cities.txt
+%%DATADIR%%/heading.bmp
+%%DATADIR%%/helpers.txt
+%%DATADIR%%/icons/Thumbs.db
+%%DATADIR%%/icons/active.bmp
+%%DATADIR%%/icons/addtorrent.bmp
+%%DATADIR%%/icons/addtorrentnondefault.bmp
+%%DATADIR%%/icons/addtorrenturl.bmp
+%%DATADIR%%/icons/advdetail.bmp
+%%DATADIR%%/icons/clearcompleted.bmp
+%%DATADIR%%/icons/currentseedpeer.bmp
+%%DATADIR%%/icons/delete.bmp
+%%DATADIR%%/icons/earth_map.jpg
+%%DATADIR%%/icons/friends.bmp
+%%DATADIR%%/icons/inactive.bmp
+%%DATADIR%%/icons/joe24.bmp
+%%DATADIR%%/icons/joe32.bmp
+%%DATADIR%%/icons/movebottom.bmp
+%%DATADIR%%/icons/movedown.bmp
+%%DATADIR%%/icons/movetop.bmp
+%%DATADIR%%/icons/moveup.bmp
+%%DATADIR%%/icons/mugshots/Arno.bmp
+%%DATADIR%%/icons/mugshots/Jie.bmp
+%%DATADIR%%/icons/mugshots/Johan.bmp
+%%DATADIR%%/icons/mugshots/Pawel.bmp
+%%DATADIR%%/icons/mugshots/Thumbs.db
+%%DATADIR%%/icons/myinfo.bmp
+%%DATADIR%%/icons/options.bmp
+%%DATADIR%%/icons/pause.bmp
+%%DATADIR%%/icons/pauseall.bmp
+%%DATADIR%%/icons/queue.bmp
+%%DATADIR%%/icons/recommend.bmp
+%%DATADIR%%/icons/reseedresume.bmp
+%%DATADIR%%/icons/resume.bmp
+%%DATADIR%%/icons/search.bmp
+%%DATADIR%%/icons/separator.bmp
+%%DATADIR%%/icons/smallglobe.bmp
+%%DATADIR%%/icons/stop.bmp
+%%DATADIR%%/icons/stopall.bmp
+%%DATADIR%%/icons/torrentdetail.bmp
+%%DATADIR%%/icons/unstopall.bmp
+%%DATADIR%%/icons/webservice.bmp
+%%DATADIR%%/icons/webservoff.bmp
+%%DATADIR%%/icons/webservon.bmp
+%%DATADIR%%/interconn.py
+%%DATADIR%%/interconn.pyo
+%%DATADIR%%/launchmanycore.py
+%%DATADIR%%/launchmanycore.pyo
+%%DATADIR%%/local.simin
+%%DATADIR%%/people.txt
+%%DATADIR%%/print_stats.py
+%%DATADIR%%/print_stats.pyo
+%%DATADIR%%/safeguiupdate.py
+%%DATADIR%%/safeguiupdate.pyo
+%%DATADIR%%/setupabc.py
+%%DATADIR%%/setupabc.pyo
+%%DATADIR%%/setupswapper.py
+%%DATADIR%%/setupswapper.pyo
+%%DATADIR%%/setupswappermac.py
+%%DATADIR%%/setupswappermac.pyo
+%%DATADIR%%/simulation.py
+%%DATADIR%%/simulation.pyo
+%%DATADIR%%/superpeer.txt
+%%DATADIR%%/swapper.ico
+%%DATADIR%%/test.py
+%%DATADIR%%/test.pyo
+%%DATADIR%%/test/TESTSUITE.txt
+%%DATADIR%%/test/__init__.py
+%%DATADIR%%/test/__init__.pyo
+%%DATADIR%%/test/bencode.py
+%%DATADIR%%/test/bencode.pyo
+%%DATADIR%%/test/btconn.py
+%%DATADIR%%/test/btconn.pyo
+%%DATADIR%%/test/buddycast_data.py
+%%DATADIR%%/test/buddycast_data.pyo
+%%DATADIR%%/test/test_all.py
+%%DATADIR%%/test/test_all.pyo
+%%DATADIR%%/test/test_as_server.py
+%%DATADIR%%/test/test_as_server.pyo
+%%DATADIR%%/test/test_buddycast.py
+%%DATADIR%%/test/test_buddycast.pyo
+%%DATADIR%%/test/test_cachedb.py
+%%DATADIR%%/test/test_cachedb.pyo
+%%DATADIR%%/test/test_cachedbhandler.py
+%%DATADIR%%/test/test_cachedbhandler.pyo
+%%DATADIR%%/test/test_friend.py
+%%DATADIR%%/test/test_friend.pyo
+%%DATADIR%%/test/test_merkle.py
+%%DATADIR%%/test/test_merkle.pyo
+%%DATADIR%%/test/test_permid.py
+%%DATADIR%%/test/test_permid.pyo
+%%DATADIR%%/test/test_permid_response1.py
+%%DATADIR%%/test/test_permid_response1.pyo
+%%DATADIR%%/test/test_sim.py
+%%DATADIR%%/test/test_sim.pyo
+%%DATADIR%%/test/test_superpeers.py
+%%DATADIR%%/test/test_superpeers.pyo
+%%DATADIR%%/test/testdata.txt
+%%DATADIR%%/test2.py
+%%DATADIR%%/test2.pyo
+%%DATADIR%%/torrenticon.ico
+%%DATADIR%%/webservice.py
+%%DATADIR%%/webservice.pyo
+%%DATADIR%%/webtest.py
+%%DATADIR%%/webtest.pyo
+%%DATADIR%%/welcome.bmp
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%/icons/mugshots
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/Utility
+@dirrm %%DATADIR%%/TorrentMaker
+@dirrm %%DATADIR%%/Swapper/toofastbt
+@dirrm %%DATADIR%%/Swapper/Worldmap
+@dirrm %%DATADIR%%/Swapper/Statistics
+@dirrm %%DATADIR%%/Swapper/Overlay
+@dirrm %%DATADIR%%/Swapper/Merkle
+@dirrm %%DATADIR%%/Swapper/Dialogs
+@dirrm %%DATADIR%%/Swapper/CacheDB
+@dirrm %%DATADIR%%/Swapper/BuddyCast
+@dirrm %%DATADIR%%/Swapper
+@dirrm %%DATADIR%%/Lang
+@dirrm %%DATADIR%%/Dialogs
+@dirrm %%DATADIR%%/BitTornado/BT1
+@dirrm %%DATADIR%%/BitTornado
+@dirrm %%DATADIR%%/ABC/Torrent
+@dirrm %%DATADIR%%/ABC/Toolbars
+@dirrm %%DATADIR%%/ABC/Scheduler
+@dirrm %%DATADIR%%/ABC/GUI
+@dirrm %%DATADIR%%/ABC/Actions
+@dirrm %%DATADIR%%/ABC
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/pixmaps