aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-02-13 02:41:27 +0800
committerswills <swills@FreeBSD.org>2014-02-13 02:41:27 +0800
commit5663bde7fba9f518b5071ea2e85a875c7ad4a6b6 (patch)
tree000f069954b6509dd0b742345d38783c5d8e8373 /net-p2p
parent1236656dcfe43d182848a9547eb7313384bb50d1 (diff)
downloadfreebsd-ports-graphics-5663bde7fba9f518b5071ea2e85a875c7ad4a6b6.tar.gz
freebsd-ports-graphics-5663bde7fba9f518b5071ea2e85a875c7ad4a6b6.tar.zst
freebsd-ports-graphics-5663bde7fba9f518b5071ea2e85a875c7ad4a6b6.zip
- Fix build after boost update
- Improve USE_QT4 dependencies
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dogecoin/Makefile8
-rw-r--r--net-p2p/dogecoin/files/extra-patch-endian47
-rw-r--r--net-p2p/dogecoin/files/patch-src__scrypt.cpp33
-rw-r--r--net-p2p/dogecoin/files/patch-src__scrypt.h22
4 files changed, 58 insertions, 52 deletions
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index b361858c6c9..6371730c412 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dogecoin
PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p finance
MAINTAINER= swills@FreeBSD.org
@@ -36,14 +36,12 @@ CXXFLAGS+= -Wno-invalid-offsetof
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-endian
-.else
+.if ${OPSYS} == FreeBSD && ${OSVERSION} <= 1000000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__leveldb__Makefile
.endif
.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
-USE_QT4= corelib gui qmake_build linguist uic moc rcc
+USE_QT4= corelib network gui qmake_build linguist_build uic_build moc_build rcc_build
BINARY= dogecoin-qt
.else
BINARY= dogecoind
diff --git a/net-p2p/dogecoin/files/extra-patch-endian b/net-p2p/dogecoin/files/extra-patch-endian
deleted file mode 100644
index 8a016d89daa..00000000000
--- a/net-p2p/dogecoin/files/extra-patch-endian
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/scrypt.cpp.orig 2013-12-09 18:10:12.046606050 +0000
-+++ src/scrypt.cpp 2013-12-09 18:10:25.898605023 +0000
-@@ -34,22 +34,6 @@
- #include <string.h>
- #include <openssl/sha.h>
-
--static inline uint32_t be32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
-- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
--}
--
--static inline void be32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[3] = x & 0xff;
-- p[2] = (x >> 8) & 0xff;
-- p[1] = (x >> 16) & 0xff;
-- p[0] = (x >> 24) & 0xff;
--}
--
- typedef struct HMAC_SHA256Context {
- SHA256_CTX ictx;
- SHA256_CTX octx;
---- src/scrypt.h.orig 2013-12-09 15:26:17.343282984 +0000
-+++ src/scrypt.h 2013-12-09 15:45:11.032205545 +0000
-@@ -17,19 +17,4 @@
- PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
- size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
-
--static inline uint32_t le32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
-- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
--}
--
--static inline void le32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[0] = x & 0xff;
-- p[1] = (x >> 8) & 0xff;
-- p[2] = (x >> 16) & 0xff;
-- p[3] = (x >> 24) & 0xff;
--}
- #endif
diff --git a/net-p2p/dogecoin/files/patch-src__scrypt.cpp b/net-p2p/dogecoin/files/patch-src__scrypt.cpp
new file mode 100644
index 00000000000..4bb49b8a7ff
--- /dev/null
+++ b/net-p2p/dogecoin/files/patch-src__scrypt.cpp
@@ -0,0 +1,33 @@
+--- ./src/scrypt.cpp.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./src/scrypt.cpp 2014-02-09 05:45:03.131006405 +0000
+@@ -33,6 +33,7 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <openssl/sha.h>
++#include <boost/lexical_cast.hpp>
+
+ #if defined(USE_SSE2) && !defined(USE_SSE2_ALWAYS)
+ #ifdef _MSC_VER
+@@ -44,22 +45,6 @@
+ #endif
+ #endif
+
+-static inline uint32_t be32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
+- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
+-}
+-
+-static inline void be32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[3] = x & 0xff;
+- p[2] = (x >> 8) & 0xff;
+- p[1] = (x >> 16) & 0xff;
+- p[0] = (x >> 24) & 0xff;
+-}
+-
+ typedef struct HMAC_SHA256Context {
+ SHA256_CTX ictx;
+ SHA256_CTX octx;
diff --git a/net-p2p/dogecoin/files/patch-src__scrypt.h b/net-p2p/dogecoin/files/patch-src__scrypt.h
new file mode 100644
index 00000000000..f66841aa288
--- /dev/null
+++ b/net-p2p/dogecoin/files/patch-src__scrypt.h
@@ -0,0 +1,22 @@
+--- ./src/scrypt.h.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./src/scrypt.h 2014-02-09 05:45:03.133009188 +0000
+@@ -27,19 +27,4 @@
+ PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
+ size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
+
+-static inline uint32_t le32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
+- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
+-}
+-
+-static inline void le32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[0] = x & 0xff;
+- p[1] = (x >> 8) & 0xff;
+- p[2] = (x >> 16) & 0xff;
+- p[3] = (x >> 24) & 0xff;
+-}
+ #endif