aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-12-03 00:16:44 +0800
committerrm <rm@FreeBSD.org>2012-12-03 00:16:44 +0800
commitcef4af21f64ab8117a38c14776ddf1c8772cef9a (patch)
tree45c4231a94d4a9bc818555794b6e05523ee3834c /net-p2p
parent0e0e1a17ba9b6f0a44ca176154f12af1107954a1 (diff)
downloadfreebsd-ports-graphics-cef4af21f64ab8117a38c14776ddf1c8772cef9a.tar.gz
freebsd-ports-graphics-cef4af21f64ab8117a38c14776ddf1c8772cef9a.tar.zst
freebsd-ports-graphics-cef4af21f64ab8117a38c14776ddf1c8772cef9a.zip
- eliminate bogus setuptools dependency
- bump PORTREVISION because of dependency change - extend python version in USE_PYTHON - fix incorrect PYDISTUTILS_PKGNAME usage Feature safe: yes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-15-python/Makefile7
-rw-r--r--net-p2p/libtorrent-rasterbar-15/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar-16-python/Makefile7
-rw-r--r--net-p2p/libtorrent-rasterbar-16/Makefile1
4 files changed, 6 insertions, 11 deletions
diff --git a/net-p2p/libtorrent-rasterbar-15-python/Makefile b/net-p2p/libtorrent-rasterbar-15-python/Makefile
index b3aa8d61ae0..e75a9a2c368 100644
--- a/net-p2p/libtorrent-rasterbar-15-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-15-python/Makefile
@@ -5,9 +5,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Python bindings for libtorrent-rasterbar-15
CATEGORIES= net-p2p python
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0.6:${PORTSDIR}/devel/py-setuptools
LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
@@ -16,7 +15,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
PLIST= ${.CURDIR}/pkg-plist
INSTALLS_EGGINFO= yes
-PYDISTUTILS_EGGINFO= python_libtorrent-${PORTVERSION}-py${PYTHON_VER}.egg-info
+PYDISTUTILS_PKGNAME= python_libtorrent
NOPORTDOCS= yes
@@ -37,5 +36,3 @@ MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-15
# insure python paths are correctly identified
CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
-# prefix PKGNAME with python- so that the egg info file is properly named.
-PYDISTUTILS_PKGNAME= python-${PORTNAME}
diff --git a/net-p2p/libtorrent-rasterbar-15/Makefile b/net-p2p/libtorrent-rasterbar-15/Makefile
index dc88564b872..77251870752 100644
--- a/net-p2p/libtorrent-rasterbar-15/Makefile
+++ b/net-p2p/libtorrent-rasterbar-15/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libtorrent-rasterbar
PORTVERSION= 0.15.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= net-p2p ipv6
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= libtorrent
diff --git a/net-p2p/libtorrent-rasterbar-16-python/Makefile b/net-p2p/libtorrent-rasterbar-16-python/Makefile
index 33efdb190eb..2f55a2791e7 100644
--- a/net-p2p/libtorrent-rasterbar-16-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-16-python/Makefile
@@ -5,9 +5,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Python bindings for libtorrent-rasterbar-16
CATEGORIES= net-p2p python
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0.6:${PORTSDIR}/devel/py-setuptools
LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16
@@ -16,7 +15,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
PLIST= ${.CURDIR}/pkg-plist
INSTALLS_EGGINFO= yes
-PYDISTUTILS_EGGINFO= python_libtorrent-${PORTVERSION}-py${PYTHON_VER}.egg-info
+PYDISTUTILS_PKGNAME= python_libtorrent
NOPORTDOCS= yes
@@ -37,5 +36,3 @@ MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-16
# insure python paths are correctly identified
CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
-# prefix PKGNAME with python- so that the egg info file is properly named.
-PYDISTUTILS_PKGNAME= python-${PORTNAME}
diff --git a/net-p2p/libtorrent-rasterbar-16/Makefile b/net-p2p/libtorrent-rasterbar-16/Makefile
index ba0c29b4f60..46ad03e2c45 100644
--- a/net-p2p/libtorrent-rasterbar-16/Makefile
+++ b/net-p2p/libtorrent-rasterbar-16/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libtorrent-rasterbar
PORTVERSION= 0.16.4
+PORTREVISION?= 1
CATEGORIES?= net-p2p ipv6
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= libtorrent