aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-02-01 22:59:39 +0800
committerflz <flz@FreeBSD.org>2007-02-01 22:59:39 +0800
commitd5cf0707ece3f10c7cae428db95183eacc327281 (patch)
treeee0f143714dd3297b9672d8356ef3833d7d8bc75 /net-p2p
parenta133cccbeb04b728e63c4a1848a1f1653642eda2 (diff)
downloadfreebsd-ports-graphics-d5cf0707ece3f10c7cae428db95183eacc327281.tar.gz
freebsd-ports-graphics-d5cf0707ece3f10c7cae428db95183eacc327281.tar.zst
freebsd-ports-graphics-d5cf0707ece3f10c7cae428db95183eacc327281.zip
Fix build with OpenSSL from base.
Reported by: kris, itetcu, ...
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 0549dda83e1..8c61b0131cf 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -32,6 +32,13 @@ EXTRA_PATCHES?= ${.CURDIR}/files/stable-*
OPTIONS= KQUEUE "Use kqueue(2) support" on
+.if defined(WITH_OPENSSL_BASE)
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
+.endif
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --disable-debug --with-openssl=${OPENSSLBASE}