aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-08-01 03:00:08 +0800
committerantoine <antoine@FreeBSD.org>2013-08-01 03:00:08 +0800
commite5b8ba7c969ae71d9c972ed0e5058892a768cb8b (patch)
tree0ccfed04851ec55bb7d838e0e7ea31583a5a4039 /net-p2p
parent30e029b4ba0aef05f9439ffd0d959a84eca8068e (diff)
downloadfreebsd-ports-graphics-e5b8ba7c969ae71d9c972ed0e5058892a768cb8b.tar.gz
freebsd-ports-graphics-e5b8ba7c969ae71d9c972ed0e5058892a768cb8b.tar.zst
freebsd-ports-graphics-e5b8ba7c969ae71d9c972ed0e5058892a768cb8b.zip
Cleanup libtorrent-rasterbar-16 and unbreak libtorrent-rasterbar-16-python
PR: 180809, 180813 Submitted by: nemysis (maintainer)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-16-python/Makefile38
-rw-r--r--net-p2p/libtorrent-rasterbar-16-python/pkg-plist1
-rw-r--r--net-p2p/libtorrent-rasterbar-16/Makefile18
3 files changed, 19 insertions, 38 deletions
diff --git a/net-p2p/libtorrent-rasterbar-16-python/Makefile b/net-p2p/libtorrent-rasterbar-16-python/Makefile
index 76de8c9fc35..c1e15b36f6f 100644
--- a/net-p2p/libtorrent-rasterbar-16-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-16-python/Makefile
@@ -1,39 +1,31 @@
+# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 2
-
+PORTREVISION= 3
+CATEGORIES= net-p2p python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Python bindings for libtorrent-rasterbar-16
-CATEGORIES= net-p2p python
-USE_PYTHON= yes
+LIB_DEPENDS= torrent-rasterbar:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16 \
+ boost_python:${PORTSDIR}/devel/boost-python-libs
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs \
- torrent-rasterbar.7:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16
+MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-16
BUILD_WRKSRC= ${WRKSRC}/bindings/python
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PLIST= ${.CURDIR}/pkg-plist
-INSTALLS_EGGINFO= yes
-PYDISTUTILS_PKGNAME= python_libtorrent
-
-NOPORTDOCS= yes
-slave-post-patch:
- @${REINPLACE_CMD} -E -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/bindings/python/setup.py.in
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python_libtorrent
-slave-post-install:
-# fix installation permissions
- @${CHMOD} ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/libtorrent.so
+PLIST= ${NONEXISTENT}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
-MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-16
-.include "${MASTERDIR}/Makefile"
+OPTIONS_EXCLUDE= DOCS EXAMPLES
-##
-# information available after <bsd.port.pre.mk>
-##
# insure python paths are correctly identified
-CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/libtorrent-rasterbar-16-python/pkg-plist b/net-p2p/libtorrent-rasterbar-16-python/pkg-plist
deleted file mode 100644
index 128a4b8d481..00000000000
--- a/net-p2p/libtorrent-rasterbar-16-python/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/libtorrent.so
diff --git a/net-p2p/libtorrent-rasterbar-16/Makefile b/net-p2p/libtorrent-rasterbar-16/Makefile
index 18bcacbd243..dcb4a66a6d0 100644
--- a/net-p2p/libtorrent-rasterbar-16/Makefile
+++ b/net-p2p/libtorrent-rasterbar-16/Makefile
@@ -19,7 +19,6 @@ USES= pathfix pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
CONFLICTS+= libtorrent-rasterbar-0.1[45789].*
NO_LATEST_LINK= yes
@@ -42,7 +41,7 @@ PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
DOC_FILES1= AUTHORS README
-DOCSRCDIR2= ${WRKSRC}/docs
+DOCSRCDIR2= ${WRKSRC}/docs
DOCSDIR2= ${DOCSDIR}/docs
DOC_FILES2= *.png *.jpg *.gif *.html *.rst *.css
@@ -50,7 +49,7 @@ PORTEXAMPLES= *.cpp
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "yes" && defined(USE_PYTHON)
CONFIGURE_ARGS+= --enable-python-binding \
@@ -59,20 +58,11 @@ CONFIGURE_ARGS+= --enable-python-binding \
CONFIGURE_ARGS+= --disable-python-binding
.endif
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "yes"
-post-patch: slave-post-patch
-.else
-
post-patch:
- @${REINPLACE_CMD} -e 's|<include>/usr/local/include|<include>${PREFIX}/include|' \
+ @${REINPLACE_CMD} -e 's|/usr/local/include|${PREFIX}/include|' \
${WRKSRC}/Jamfile
-.endif
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "yes"
-post-install: slave-post-install
-.else
post-install:
-.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
@@ -84,4 +74,4 @@ post-install:
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>