aboutsummaryrefslogtreecommitdiffstats
path: root/net/aim/Makefile
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2001-01-14 00:08:05 +0800
committerroger <roger@FreeBSD.org>2001-01-14 00:08:05 +0800
commitca241ed086c1a6e99a8813d2faba0f93b1a65e86 (patch)
tree2548e74f233e534ad3cb8c4ce74078976863a698 /net/aim/Makefile
parent0cc33236a759299a911f0d7ebdff81a98f679917 (diff)
downloadfreebsd-ports-graphics-ca241ed086c1a6e99a8813d2faba0f93b1a65e86.tar.gz
freebsd-ports-graphics-ca241ed086c1a6e99a8813d2faba0f93b1a65e86.tar.zst
freebsd-ports-graphics-ca241ed086c1a6e99a8813d2faba0f93b1a65e86.zip
Add AOL's Instant Messenger (AIM) client.
This is a X11 Linux application which runs fine with FreeBSD's Linux emulation.
Diffstat (limited to 'net/aim/Makefile')
-rw-r--r--net/aim/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/aim/Makefile b/net/aim/Makefile
new file mode 100644
index 00000000000..0bd53c77f55
--- /dev/null
+++ b/net/aim/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: aim
+# Date created: Sat Jan 13 12:40:20 GMT 2001
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aim
+PORTVERSION= 1.1.112.1
+CATEGORIES= net linux
+MASTER_SITES= ftp://ftp.newaol.com/aimgen/73010/
+DISTNAME= aim-1.1.112-1
+EXTRACT_SUFX= .i386.tgz
+
+MAINTAINER= roger@freebsd.org
+
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
+ /compat/linux/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+
+ONLY_FOR_ARCHS= i386
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_XLIB= yes
+
+# This port will only work when PREFIX is /usr/local because the aim
+# program is hard coded to look for important files in /usr/local/lib/aim
+PREFIX= /usr/local
+
+do-install:
+ ${CP} ${WRKSRC}/usr/local/bin/aim ${PREFIX}/bin
+ ${CP} ${WRKSRC}/usr/local/lib/lib* ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/lib/aim
+ ${CP} -R ${WRKSRC}/usr/local/lib/aim/* ${PREFIX}/lib/aim
+
+.include <bsd.port.mk>