aboutsummaryrefslogtreecommitdiffstats
path: root/net/angst/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-04 02:56:00 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-04 02:56:00 +0800
commit68e6faf13e6e26983969399f5c282ca47b6bed24 (patch)
tree0e2c580c54ed888a911b30dcb89cccdd300b2dcc /net/angst/Makefile
parent41956abc03052dac276d1a020b764c486dadb9f9 (diff)
downloadfreebsd-ports-graphics-68e6faf13e6e26983969399f5c282ca47b6bed24.tar.gz
freebsd-ports-graphics-68e6faf13e6e26983969399f5c282ca47b6bed24.tar.zst
freebsd-ports-graphics-68e6faf13e6e26983969399f5c282ca47b6bed24.zip
add angst
An active sniffer
Diffstat (limited to 'net/angst/Makefile')
-rw-r--r--net/angst/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/angst/Makefile b/net/angst/Makefile
new file mode 100644
index 00000000000..85994007f50
--- /dev/null
+++ b/net/angst/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: angst
+# Date created: Dec 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= angst
+PORTVERSION= 0.4b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+
+MAN8= angst.8
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g ; \
+ s,libnet-config,${LIBNET_CONFIG},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>