aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2010-12-29 20:49:10 +0800
committerflo <flo@FreeBSD.org>2010-12-29 20:49:10 +0800
commit99bdb938ede0541d94d5231781827eda6deea812 (patch)
tree1a2e6c4d485455643f6244ce803cba3bffd6436b /net/asterisk16
parent20eaf5d7056f8f872f520eb29871c84b81ffbc57 (diff)
downloadfreebsd-ports-graphics-99bdb938ede0541d94d5231781827eda6deea812.tar.gz
freebsd-ports-graphics-99bdb938ede0541d94d5231781827eda6deea812.tar.zst
freebsd-ports-graphics-99bdb938ede0541d94d5231781827eda6deea812.zip
- update to 1.6.2.15 [1]
- enable dahdi on sparc64 [2] - add support for iODBC - only use /var as localstatedir if we install to LOCALBASE - fix harmless portlint warning Submitted by: dmitry2004@yandex.ru [1] fjoe [2] Approved by: fjoe (mentor)
Diffstat (limited to 'net/asterisk16')
-rw-r--r--net/asterisk16/Makefile41
-rw-r--r--net/asterisk16/distinfo4
-rw-r--r--net/asterisk16/files/patch-configure16
-rw-r--r--net/asterisk16/pkg-plist11
4 files changed, 52 insertions, 20 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 07a7b8cb088..f4741f2b47d 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.6.2.14
+PORTVERSION= 1.6.2.15
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -25,7 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64 sparc64
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gsm=${LOCALBASE} --localstatedir=/var
+CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_GNOME= libxml2
@@ -44,7 +44,8 @@ MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8
CONFLICTS= asterisk*-1.2* asterisk*-1.4* asterisk*-1.8*
OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
- ODBC "Enable ODBC support" on \
+ IODBC "Enable iODBC support" off \
+ UODBC "Enable unixODBC support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
@@ -65,9 +66,19 @@ GROUPS= ${ASTERISK_GROUP} dahdi
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+.if ${PREFIX} == ${LOCALBASE}
+VARDIR=/var
+.else
+VARDIR=${PREFIX}/var
+.endif
+
+.if ${ARCH} == "i386" || ${ARCH} == "amd64" || ${ARCH} == "sparc64"
OPTIONS+= DAHDI "Enable DAHDI support" on
+.if defined(WITH_IODBC) && defined(WITH_UODBC)
+IGNORE= please select only one of iodbc or unixODBC
+.endif
+
# Include this since we have altered OPTIONS.
.include <bsd.port.options.mk>
.endif
@@ -75,6 +86,7 @@ OPTIONS+= DAHDI "Enable DAHDI support" on
SUB_LIST+= ASTERISK_USER=${ASTERISK_USER}
PLIST_SUB+= ASTERISK_USER=${ASTERISK_USER}
PLIST_SUB+= ASTERISK_GROUP=${ASTERISK_GROUP}
+PLIST_SUB+= VARDIR=${VARDIR}
.if !defined(WITH_H323)
PLIST_SUB+= WITH_H323="@comment "
@@ -101,14 +113,25 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/dahdi/dahdi.ko:${PORTSDIR}/misc/dahdi
#
# WITH_FREETDS, WITH_PGSQL and WITH_SQLITE can also be added to MAKE_ENV
# similarly
-.if !defined(WITH_ODBC)
-PLIST_SUB+= WITH_ODBC="@comment "
+.if !defined(WITH_UODBC)
CONFIGURE_ARGS+= --without-unixodbc
-.else
+.endif
+.if !defined(WITH_IODBC)
+CONFIGURE_ARGS+= --without-iodbc
+.endif
+.if !defined(WITH_UODBC) && !defined(WITH_IODBC)
+PLIST_SUB+= WITH_ODBC="@comment "
+.endif
+.if defined(WITH_UODBC) || defined(WITH_IODBC)
PLIST_SUB+= WITH_ODBC=""
+USE_AUTOTOOLS= libltdl
+.if defined(WITH_UODBC)
CONFIGURE_ARGS+= --with-unixodbc --with-ltdl
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-USE_AUTOTOOLS= libltdl
+.elif defined(WITH_IODBC)
+CONFIGURE_ARGS+= --with-iodbc --with-ltdl
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+.endif
.endif
.if !defined(WITH_FREETDS)
@@ -230,6 +253,6 @@ post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
post-install:
- @${CHOWN} -R ${ASTERISK_USER}:${ASTERISK_GROUP} /var/db/asterisk /var/log/asterisk /var/spool/asterisk
+ @${CHOWN} -R ${ASTERISK_USER}:${ASTERISK_GROUP} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
.include <bsd.port.post.mk>
diff --git a/net/asterisk16/distinfo b/net/asterisk16/distinfo
index 5bc92810f1a..243ed3346a5 100644
--- a/net/asterisk16/distinfo
+++ b/net/asterisk16/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.6.2.14.tar.gz) = 344fc0c4d0bb5488084aee7c2068b9efe21ec0fa183f41a4c3608e64fa38f332
-SIZE (asterisk-1.6.2.14.tar.gz) = 23715262
+SHA256 (asterisk-1.6.2.15.tar.gz) = 5be61ef362b5f6e43cc1a2c276558daf8f5a3a0a07e6e4d6384c8796b8cc58d4
+SIZE (asterisk-1.6.2.15.tar.gz) = 23717736
diff --git a/net/asterisk16/files/patch-configure b/net/asterisk16/files/patch-configure
index 7cd2e8abbb6..e95e33fded0 100644
--- a/net/asterisk16/files/patch-configure
+++ b/net/asterisk16/files/patch-configure
@@ -1,6 +1,14 @@
---- ./configure.orig 2010-07-17 23:43:50.000000000 +0600
-+++ ./configure 2010-08-24 09:37:46.000000000 +0600
-@@ -4147,9 +4147,6 @@
+--- configure.orig 2010-12-29 07:55:41.000000000 +0100
++++ configure 2010-12-29 07:56:15.000000000 +0100
+@@ -620,7 +620,6 @@
+
+ ac_default_prefix=/usr/local
+ ac_default_prefix=/usr/local
+-ac_default_prefix=/usr
+ ac_header_list=
+ ac_subst_vars='SHELL
+ PATH_SEPARATOR
+@@ -4149,9 +4148,6 @@
case "${host_os}" in
freebsd*)
@@ -10,7 +18,7 @@
;;
openbsd*)
-@@ -34755,7 +34752,7 @@
+@@ -36593,7 +36589,7 @@
fi
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index 4b097177131..439e86cf3d2 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -568,8 +568,8 @@ share/asterisk/phoneprov/000000000000-phone.cfg
share/asterisk/phoneprov/000000000000.cfg
share/asterisk/phoneprov/polycom.xml
share/asterisk/phoneprov/polycom_line.xml
-share/asterisk/sounds/.asterisk-core-sounds-en-gsm-1.4.19
-share/asterisk/sounds/en/LICENSE-asterisk-core-en-1.4.19
+share/asterisk/sounds/.asterisk-core-sounds-en-gsm-1.4.20
+share/asterisk/sounds/en/LICENSE-asterisk-core-en-1.4.20
share/asterisk/sounds/en/ascending-2tone.gsm
share/asterisk/sounds/en/conf-adminmenu-162.gsm
share/asterisk/sounds/en/conf-extended.gsm
@@ -590,8 +590,8 @@ share/asterisk/sounds/en/vm-pls-try-again.gsm
share/asterisk/sounds/en/vm-record-prepend.gsm
share/asterisk/sounds/en/vm-review-nonurgent.gsm
share/asterisk/sounds/en/vm-review-urgent.gsm
-share/asterisk/sounds/en/CHANGES-asterisk-core-en-1.4.19
-share/asterisk/sounds/en/CREDITS-asterisk-core-en-1.4.19
+share/asterisk/sounds/en/CHANGES-asterisk-core-en-1.4.20
+share/asterisk/sounds/en/CREDITS-asterisk-core-en-1.4.20
share/asterisk/sounds/en/dir-usingkeypad.gsm
share/asterisk/sounds/en/dir-welcome.gsm
share/asterisk/sounds/en/agent-alreadyon.gsm
@@ -1371,6 +1371,7 @@ share/asterisk/static-http/prototype.js
@dirrm share/asterisk/sounds/en/digits
@dirrm share/asterisk/sounds/en/dictate
@dirrm share/asterisk/sounds/en
+@dirrm share/asterisk/sounds/en_AU
@dirrm share/asterisk/sounds/es
@dirrm share/asterisk/sounds/fr
@dirrm share/asterisk/sounds
@@ -1391,7 +1392,7 @@ share/asterisk/static-http/prototype.js
@exec mkdir -p %D/share/asterisk/documentation/thirdparty
@exec mkdir -p %D/share/asterisk/sounds/es
@exec mkdir -p %D/share/asterisk/sounds/fr
-@cwd /var
+@cwd %%VARDIR%%
spool/asterisk/voicemail/default/1234/en/busy.gsm
spool/asterisk/voicemail/default/1234/en/unavail.gsm
@exec mkdir -p %D/log/asterisk/cdr-csv