aboutsummaryrefslogtreecommitdiffstats
path: root/net/beacon/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-29 04:39:16 +0800
committerkrion <krion@FreeBSD.org>2004-02-29 04:39:16 +0800
commite727319eb4684a3cbfe7e94fecf39d276303a380 (patch)
treee866e9060f668f5a9ff884d0b36121f89b027ff8 /net/beacon/Makefile
parent5e2f40af6b3be98a785856d9c644c3775b90b05f (diff)
downloadfreebsd-ports-graphics-e727319eb4684a3cbfe7e94fecf39d276303a380.tar.gz
freebsd-ports-graphics-e727319eb4684a3cbfe7e94fecf39d276303a380.tar.zst
freebsd-ports-graphics-e727319eb4684a3cbfe7e94fecf39d276303a380.zip
Add beacon 0.9.06,
The NLANR/DAST Multicast Beacon is a program written in Perl which uses the RTP protocol to provide useful statistics and diagnostic information about a given multicast group. It is used in Internet2 AccessGrid project and EU FP5 6NET project. PR: ports/63440 Submitted by: Janos.Mohacsi@bsd.hu
Diffstat (limited to 'net/beacon/Makefile')
-rw-r--r--net/beacon/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
new file mode 100644
index 00000000000..53c167fd224
--- /dev/null
+++ b/net/beacon/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: beacon
+# Date created: 26 February 2004
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= beacon
+PORTVERSION= 0.9.06
+CATEGORIES= net perl5 mbone ipv6
+MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Beacon active measurement tool to monitor multicast
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WWW_DIR?= ${PREFIX}/www/
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+do-build:
+ #Build unreleased NET::RTP perl module
+ cd ${WRKSRC}/Net-RTP-0.4/ ; \
+ ./configure --enable-ipv6 ; \
+ ${PERL} Makefile.PL ; \
+ make
+
+do-install:
+ #Install unreleased NET::RTP perl module
+ cd ${WRKSRC}/Net-RTP-0.4/ ; \
+ make install
+ #Install the Beacon itself
+ ${MKDIR} ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+ ${INSTALL_SCRIPT} ${WRKSRC}/beacon.pl ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+ ${INSTALL_DATA} ${WRKSRC}/beacon.conf ${PREFIX}/etc/beacon.conf.sample
+ @${ECHO} ""
+ @${ECHO} "Sample config installed at \
+ ${PREFIX}/etc/beacon.conf.sample"
+ @${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>