aboutsummaryrefslogtreecommitdiffstats
path: root/net/cyphesis/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-10-07 20:39:06 +0800
committeroliver <oliver@FreeBSD.org>2005-10-07 20:39:06 +0800
commitbc268b0c68f8e7e0db57b5d18ec11857d09fa088 (patch)
tree8469e249b310b75d24c59c1f4f8c1c684151fbc9 /net/cyphesis/Makefile
parentcbfd4f4ed4d48777a1ddfff1dd18ba74cea8fb12 (diff)
downloadfreebsd-ports-graphics-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.tar.gz
freebsd-ports-graphics-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.tar.zst
freebsd-ports-graphics-bc268b0c68f8e7e0db57b5d18ec11857d09fa088.zip
upgrade to 0.5.1
mark as IGNORE for FreeBSD below 5 (0.5.0 also didn't compiled on <5)
Diffstat (limited to 'net/cyphesis/Makefile')
-rw-r--r--net/cyphesis/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index 985cfab9e3b..a1ec300ccc3 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= cyphesis
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.5.1
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=worldforge
@@ -16,7 +16,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= A server for WorldForge games
LIB_DEPENDS= Atlas-0.6.0:${PORTSDIR}/devel/atlas-devel \
- varconf-1.0.4:${PORTSDIR}/devel/varconf \
+ varconf-1.0.5:${PORTSDIR}/devel/varconf \
wfmath-0.3.3:${PORTSDIR}/math/wfmath \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
skstream-0.3.3:${PORTSDIR}/net/skstream \
@@ -36,12 +36,22 @@ USE_GNOME= gnomehack
MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
@${REINPLACE_CMD} -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/server/CommMDNSPublisher.h
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -55,4 +65,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>