aboutsummaryrefslogtreecommitdiffstats
path: root/net/dictd
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-23 01:27:22 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-23 01:27:22 +0800
commitcdf91350f74f4368c9088d3975edceba9eddfb51 (patch)
tree0adfd37186213b46575b6732e5c03db8e7d75ff0 /net/dictd
parent63ed66494cf26ae81075c9470ad04c1e6b6fb41f (diff)
downloadfreebsd-ports-graphics-cdf91350f74f4368c9088d3975edceba9eddfb51.tar.gz
freebsd-ports-graphics-cdf91350f74f4368c9088d3975edceba9eddfb51.tar.zst
freebsd-ports-graphics-cdf91350f74f4368c9088d3975edceba9eddfb51.zip
use system zlib
Submitted by: obrien
Diffstat (limited to 'net/dictd')
-rw-r--r--net/dictd/Makefile3
-rw-r--r--net/dictd/files/patch-configure10
-rw-r--r--net/dictd/files/patch-zlib::Makefile11
3 files changed, 12 insertions, 12 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index 9ce5488a11f..71ac387c32d 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -18,7 +18,8 @@ MAN1= dictzip.1
MAN8= dictd.8
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}"
+CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
+ --without-local-zlib
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
USE_GMAKE= yes
diff --git a/net/dictd/files/patch-configure b/net/dictd/files/patch-configure
new file mode 100644
index 00000000000..b4ad2c19551
--- /dev/null
+++ b/net/dictd/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Aug 23 01:25:28 2001
++++ configure Thu Aug 23 01:25:46 2001
+@@ -1416,7 +1416,6 @@
+ fi
+ fi
+
+-local_zlib=1
+ if test "$local_zlib" = 0; then
+ echo $ac_n "checking for zlibVersion in -lz""... $ac_c" 1>&6
+ echo "configure:1423: checking for zlibVersion in -lz" >&5
diff --git a/net/dictd/files/patch-zlib::Makefile b/net/dictd/files/patch-zlib::Makefile
deleted file mode 100644
index ad038af444e..00000000000
--- a/net/dictd/files/patch-zlib::Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- zlib/Makefile~ Mon Jan 29 01:24:42 2001
-+++ zlib/Makefile Mon Jan 29 01:24:56 2001
-@@ -13,7 +13,7 @@
-
- CC=cc
-
--CFLAGS=-O
-+CFLAGS= %%CFLAGS%%
- #CFLAGS=-O -DMAX_WBITS=14 -DMAX_MEM_LEVEL=7
- #CFLAGS=-g -DDEBUG
- #CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \