aboutsummaryrefslogtreecommitdiffstats
path: root/net/etherboot
diff options
context:
space:
mode:
authorambrisko <ambrisko@FreeBSD.org>2003-02-04 12:24:13 +0800
committerambrisko <ambrisko@FreeBSD.org>2003-02-04 12:24:13 +0800
commitd45443bfc9e974f617a12f8b96542a75121ded30 (patch)
treec16beba3d8c6dca6ae1a3c0fa3fad875588735d7 /net/etherboot
parentcd3d35c2f027598fc38ac76f1d199781e783b0aa (diff)
downloadfreebsd-ports-graphics-d45443bfc9e974f617a12f8b96542a75121ded30.tar.gz
freebsd-ports-graphics-d45443bfc9e974f617a12f8b96542a75121ded30.tar.zst
freebsd-ports-graphics-d45443bfc9e974f617a12f8b96542a75121ded30.zip
Update from 5.0.5 to 5.0.8.
PR: 46724 Submitted by: Paulius Bulotas <paulius@kaktusas.org>
Diffstat (limited to 'net/etherboot')
-rw-r--r--net/etherboot/Makefile2
-rw-r--r--net/etherboot/distinfo2
-rw-r--r--net/etherboot/files/patch-ab42
3 files changed, 2 insertions, 44 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index 1fd97fb6a83..b08135b9249 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= etherboot
-PORTVERSION= 5.0.5
+PORTVERSION= 5.0.8
CATEGORIES= net
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
#MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/etherboot/distinfo b/net/etherboot/distinfo
index 27022036898..a8d061d453f 100644
--- a/net/etherboot/distinfo
+++ b/net/etherboot/distinfo
@@ -1 +1 @@
-MD5 (etherboot-5.0.5.tar.bz2) = 1b7bcf5544ef8729bd6ea571ef8fc365
+MD5 (etherboot-5.0.8.tar.bz2) = 150e2b96961924e3c4e83c8de90d24fb
diff --git a/net/etherboot/files/patch-ab b/net/etherboot/files/patch-ab
deleted file mode 100644
index 50a8f5ea2d0..00000000000
--- a/net/etherboot/files/patch-ab
+++ /dev/null
@@ -1,42 +0,0 @@
---- nfs.c.orig Tue Mar 12 21:44:19 2002
-+++ nfs.c Thu Mar 14 07:51:43 2002
-@@ -321,6 +321,14 @@
- int retries;
- long *p;
-
-+ static int tokens=0;
-+ /*
-+ * Try to implement something similar to a window protocol in
-+ * terms of response to losses. On successful receive, increment
-+ * the number of tokens by 1 (cap at 256). On failure, halve it.
-+ * When the number of tokens is >= 2, use a very short timeout.
-+ */
-+
- id = rpc_id++;
- buf.u.call.id = htonl(id);
- buf.u.call.type = htonl(MSG_CALL);
-@@ -336,9 +344,14 @@
- *p++ = 0; /* unused parameter */
- for (retries = 0; retries < MAX_RPC_RETRIES; retries++) {
- long timeout = rfc2131_sleep_interval(TIMEOUT, retries);
-+ if (tokens >= 2)
-+ timeout = TICKS_PER_SEC/2;
-+
- udp_transmit(arptable[server].ipaddr.s_addr, sport, port,
- (char *)p - (char *)&buf, &buf);
- if (await_reply(AWAIT_RPC, sport, &id, timeout)) {
-+ if (tokens < 256)
-+ tokens++;
- rpc = (struct rpc_t *)&nic.packet[ETH_HLEN];
- if (rpc->u.reply.rstatus || rpc->u.reply.verifier ||
- rpc->u.reply.astatus || rpc->u.reply.data[0]) {
-@@ -355,7 +368,8 @@
- } else {
- return 0;
- }
-- }
-+ } else
-+ tokens >>= 1;
- }
- return -1;
- }