aboutsummaryrefslogtreecommitdiffstats
path: root/net/ethereal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-21 10:31:37 +0800
committermarcus <marcus@FreeBSD.org>2004-07-21 10:31:37 +0800
commit13656647fe01e17df0b8e46c687d3fa1fcb05e50 (patch)
tree3e3dfea29351f3f292cbd3bab3db400b325c55f2 /net/ethereal
parente7879eae023d42d2fc8dfc43d9bff0b515ea4db2 (diff)
downloadfreebsd-ports-graphics-13656647fe01e17df0b8e46c687d3fa1fcb05e50.tar.gz
freebsd-ports-graphics-13656647fe01e17df0b8e46c687d3fa1fcb05e50.tar.zst
freebsd-ports-graphics-13656647fe01e17df0b8e46c687d3fa1fcb05e50.zip
* Update to 0.10.5 to add new features, and fix some security issues [1]
* Use the new libtool scheme * Add USE_PERL5_BUILD [2] * Make the GTK+ 2 frontend the default [2] * Fix the lockup waiting for packets to arrive while capturing when built with GTK+ 2 PR: 68819 [1] Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp> [1] billf [2] Approved by: maintainer
Diffstat (limited to 'net/ethereal')
-rw-r--r--net/ethereal/Makefile21
-rw-r--r--net/ethereal/distinfo4
-rw-r--r--net/ethereal/files/patch-configure24
-rw-r--r--net/ethereal/pkg-plist32
4 files changed, 48 insertions, 33 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index 83609e848c9..9768dc1d9fe 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ethereal
-PORTVERSION= 0.10.3
+PORTVERSION= 0.10.5
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
@@ -17,10 +17,11 @@ MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
MAINTAINER= billf@FreeBSD.org
COMMENT?= A powerful network analyzer/capture tool
+USE_PERL5_BUILD=yes
USE_BZIP2= yes
WANT_GNOME= yes
-GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --program-transform-name=""
+INSTALLS_SHLIB= yes
.for x in editcap idl2eth mergecap text2pcap
.if defined(LITE)
@@ -41,23 +42,23 @@ USE_X_PREFIX= yes
.if !defined(WITHOUT_X11)
MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
-.if defined(WITH_GTK2) || (${HAVE_GNOME:Mgtk20}!="")
-USE_GNOME= gtk20
-CONFIGURE_ARGS+= --enable-gtk2=yes
-.else
+.if defined(WITHOUT_GTK2)
USE_GNOME= gtk12
+CONFIGURE_ARGS+= --disable-gtk2
+.else
+USE_GNOME= gtk20
.endif
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
USE_GNOME= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest \
- --with-gtk-prefix=/nonexistant \
- --enable-gtk2=no
+ --with-gtk-prefix=/nonexistent \
+ --disable-gtk2
.endif
-USE_LIBTOOL_VER=13
-LIBTOOLFILES= configure epan/configure wiretap/configure doc/configure \
+USE_LIBTOOL_VER=15
+LIBTOOLFILES= configure wiretap/configure doc/configure \
plugins/gryphon/configure
PLIST_SUB+= PORTVERSION=${PORTVERSION}
diff --git a/net/ethereal/distinfo b/net/ethereal/distinfo
index 137745bd7f2..8ffbfc2becc 100644
--- a/net/ethereal/distinfo
+++ b/net/ethereal/distinfo
@@ -1,2 +1,2 @@
-MD5 (ethereal-0.10.3.tar.bz2) = 6902272eb5304f57db76bf91abe453d1
-SIZE (ethereal-0.10.3.tar.bz2) = 4840005
+MD5 (ethereal-0.10.5.tar.bz2) = 26d5672935ac8bd0793fcd2ad0b4833f
+SIZE (ethereal-0.10.5.tar.bz2) = 4984584
diff --git a/net/ethereal/files/patch-configure b/net/ethereal/files/patch-configure
new file mode 100644
index 00000000000..c9f16918006
--- /dev/null
+++ b/net/ethereal/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig Wed Jul 7 18:26:59 2004
++++ configure Tue Jul 20 19:11:24 2004
+@@ -15937,7 +15937,7 @@
+ KRB5_LIBS="-lkrb5 -lasn1 -lcrypto -lroken -lcrypt -lresolv"
+ ethereal_save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS -L$krb5_dir/lib"
+- ac_krb5_version=`grep -i heimdal $krb5_dir/include/krb5.h | head -n 1 | sed 's/^.*heimdal.*$/HEIMDAL/i'`
++ ac_krb5_version=`grep -i heimdal $krb5_dir/include/krb5.h | head -n 1 | tr "[:lower:]" "[:upper:]" sed 's/^.*heimdal.*$/HEIMDAL/'`
+ else
+ # Extract the first word of "krb5-config", so it can be a program name with args.
+ set dummy krb5-config; ac_word=$2
+@@ -15980,10 +15980,10 @@
+
+ if test -x "$KRB5_CONFIG"
+ then
+- KRB5_FLAGS=`"$KRB5_CONFIG" --cflags`
++ KRB5_FLAGS=`"$KRB5_CONFIG" --cflags | sed -e 's/@INCLUDE_des@//g'`
+ CFLAGS="$CFLAGS $KRB5_FLAGS"
+ CPPFLAGS="$CPPFLAGS $KRB5_FLAGS"
+- KRB5_LIBS=`"$KRB5_CONFIG" --libs`
++ KRB5_LIBS=`"$KRB5_CONFIG" --libs | sed -e 's/@INCLUDE_des@//g'`
+ # Looks like krb5-config is lacking -lresolv on some systems
+ echo "$as_me:$LINENO: checking whether library list looks OK" >&5
+ echo $ECHO_N "checking whether library list looks OK... $ECHO_C" >&6
diff --git a/net/ethereal/pkg-plist b/net/ethereal/pkg-plist
index aa0fbe98374..77bf9a45f52 100644
--- a/net/ethereal/pkg-plist
+++ b/net/ethereal/pkg-plist
@@ -1,58 +1,44 @@
+bin/dftest
%%EDITCAP%%
%%ETHEREAL%%
%%IDL2ETH%%
%%MERGECAP%%
bin/tethereal
%%TEXT2PCAP%%
-lib/ethereal/plugins/%%PORTVERSION%%/acn.la
lib/ethereal/plugins/%%PORTVERSION%%/acn.so
-lib/ethereal/plugins/%%PORTVERSION%%/artnet.la
lib/ethereal/plugins/%%PORTVERSION%%/artnet.so
-lib/ethereal/plugins/%%PORTVERSION%%/asn1.la
lib/ethereal/plugins/%%PORTVERSION%%/asn1.so
-lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.la
lib/ethereal/plugins/%%PORTVERSION%%/ciscosm.so
-lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.la
lib/ethereal/plugins/%%PORTVERSION%%/coseventcomm.so
-lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.la
lib/ethereal/plugins/%%PORTVERSION%%/cosnaming.so
-lib/ethereal/plugins/%%PORTVERSION%%/docsis.la
lib/ethereal/plugins/%%PORTVERSION%%/docsis.so
-lib/ethereal/plugins/%%PORTVERSION%%/enttec.la
lib/ethereal/plugins/%%PORTVERSION%%/enttec.so
-lib/ethereal/plugins/%%PORTVERSION%%/gryphon.la
lib/ethereal/plugins/%%PORTVERSION%%/gryphon.so
-lib/ethereal/plugins/%%PORTVERSION%%/irda.la
lib/ethereal/plugins/%%PORTVERSION%%/irda.so
-lib/ethereal/plugins/%%PORTVERSION%%/lwres.la
lib/ethereal/plugins/%%PORTVERSION%%/lwres.so
-lib/ethereal/plugins/%%PORTVERSION%%/megaco.la
lib/ethereal/plugins/%%PORTVERSION%%/megaco.so
-lib/ethereal/plugins/%%PORTVERSION%%/mgcp.la
lib/ethereal/plugins/%%PORTVERSION%%/mgcp.so
-lib/ethereal/plugins/%%PORTVERSION%%/pcli.la
lib/ethereal/plugins/%%PORTVERSION%%/pcli.so
-lib/ethereal/plugins/%%PORTVERSION%%/rdm.la
lib/ethereal/plugins/%%PORTVERSION%%/rdm.so
-lib/ethereal/plugins/%%PORTVERSION%%/rlm.la
lib/ethereal/plugins/%%PORTVERSION%%/rlm.so
-lib/ethereal/plugins/%%PORTVERSION%%/rtnet.la
lib/ethereal/plugins/%%PORTVERSION%%/rtnet.so
-lib/ethereal/plugins/%%PORTVERSION%%/rudp.la
lib/ethereal/plugins/%%PORTVERSION%%/rudp.so
-lib/ethereal/plugins/%%PORTVERSION%%/v5ua.la
lib/ethereal/plugins/%%PORTVERSION%%/v5ua.so
-lib/libethereal.la
+lib/libethereal.a
lib/libethereal.so
lib/libethereal.so.0
-lib/libwiretap.la
+lib/libwiretap.a
lib/libwiretap.so
lib/libwiretap.so.0
+share/ethereal/AUTHORS-SHORT
share/ethereal/diameter/dictionary.dtd
share/ethereal/diameter/dictionary.xml
share/ethereal/diameter/mobileipv4.xml
share/ethereal/diameter/nasreq.xml
share/ethereal/diameter/sunping.xml
+share/ethereal/editcap.html
+share/ethereal/ethereal-filter.html
+share/ethereal/ethereal.html
share/ethereal/help/capture_filters.txt
share/ethereal/help/capturing.txt
share/ethereal/help/display_filters.txt
@@ -61,7 +47,11 @@ share/ethereal/help/getting_started.txt
share/ethereal/help/overview.txt
share/ethereal/help/toc
share/ethereal/help/well_known.txt
+share/ethereal/idl2eth.html
share/ethereal/manuf
+share/ethereal/mergecap.html
+share/ethereal/tethereal.html
+share/ethereal/text2pcap.html
@dirrm lib/ethereal/plugins/%%PORTVERSION%%
@dirrm lib/ethereal/plugins
@dirrm lib/ethereal