aboutsummaryrefslogtreecommitdiffstats
path: root/net/isc-dhcp2/Makefile
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2001-04-21 02:31:53 +0800
committershige <shige@FreeBSD.org>2001-04-21 02:31:53 +0800
commit7bf0500224ffb83e5776a2495bb245873885477d (patch)
tree48d48eac7201a96300b74984436ad638985af98e /net/isc-dhcp2/Makefile
parentb61ecbec4be39b6113580cf435a71e28dda32927 (diff)
downloadfreebsd-ports-graphics-7bf0500224ffb83e5776a2495bb245873885477d.tar.gz
freebsd-ports-graphics-7bf0500224ffb83e5776a2495bb245873885477d.tar.zst
freebsd-ports-graphics-7bf0500224ffb83e5776a2495bb245873885477d.zip
Add a sample startup script for dhcpd.
Diffstat (limited to 'net/isc-dhcp2/Makefile')
-rw-r--r--net/isc-dhcp2/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/isc-dhcp2/Makefile b/net/isc-dhcp2/Makefile
index 8b7c0854b15..f314562620c 100644
--- a/net/isc-dhcp2/Makefile
+++ b/net/isc-dhcp2/Makefile
@@ -16,6 +16,9 @@ MAINTAINER= jseger@FreeBSD.org
HAS_CONFIGURE= yes
+STARTUP_SCRIPT= isc-dhcpd.sh.sample
+PLIST_SUB= STARTUP_SCRIPT=${STARTUP_SCRIPT}
+
MAN5= dhcp-options.5 dhcpd.conf.5 dhcpd.leases.5
MAN8= dhcpd.8 dhcrelay.8
@@ -29,5 +32,7 @@ post-install:
strip ${PREFIX}/sbin/${file}; \
fi
.endfor
+ ${INSTALL_SCRIPT} ${FILESDIR}/${STARTUP_SCRIPT} \
+ ${PREFIX}/etc/rc.d/${STARTUP_SCRIPT}
.include <bsd.port.mk>