aboutsummaryrefslogtreecommitdiffstats
path: root/net/libnatpmp
diff options
context:
space:
mode:
authoryzlin <yzlin@FreeBSD.org>2009-08-27 12:40:53 +0800
committeryzlin <yzlin@FreeBSD.org>2009-08-27 12:40:53 +0800
commite8f2d042399235d99d4b545f359af1fbd465bece (patch)
treeb5b79dcc5b64a5723fd112ba0a6eb19eae886f55 /net/libnatpmp
parentd63da65758417436e65df47309607800d584c1b5 (diff)
downloadfreebsd-ports-graphics-e8f2d042399235d99d4b545f359af1fbd465bece.tar.gz
freebsd-ports-graphics-e8f2d042399235d99d4b545f359af1fbd465bece.tar.zst
freebsd-ports-graphics-e8f2d042399235d99d4b545f359af1fbd465bece.zip
Add libnatpmp 20090713, an NAT-PMP lightweight library.
PR: ports/137676 Submitted by: Hung-Yi Chen <gaod at hychen.org> Approved by: rafan (co-mentor)
Diffstat (limited to 'net/libnatpmp')
-rw-r--r--net/libnatpmp/Makefile27
-rw-r--r--net/libnatpmp/distinfo3
-rw-r--r--net/libnatpmp/files/patch-Makefile20
-rw-r--r--net/libnatpmp/pkg-descr6
4 files changed, 56 insertions, 0 deletions
diff --git a/net/libnatpmp/Makefile b/net/libnatpmp/Makefile
new file mode 100644
index 00000000000..589b24602ae
--- /dev/null
+++ b/net/libnatpmp/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libnatpmp
+# Date created: 11 Aug 2009
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnatpmp
+PORTVERSION= 20090713
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.free.fr/files/
+
+MAINTAINER= gaod@hychen.org
+COMMENT= An NAT-PMP lightweight library
+
+USE_GMAKE= yes
+MAKE_ENV+= INSTALLPREFIX=${PREFIX}
+CFLAGS+= -fPIC
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/natpmpc \
+ include/natpmp.h \
+ lib/libnatpmp.a \
+ lib/libnatpmp.so \
+ lib/libnatpmp.so.0
+
+.include <bsd.port.mk>
diff --git a/net/libnatpmp/distinfo b/net/libnatpmp/distinfo
new file mode 100644
index 00000000000..c61f1d96d43
--- /dev/null
+++ b/net/libnatpmp/distinfo
@@ -0,0 +1,3 @@
+MD5 (libnatpmp-20090713.tar.gz) = d11d96c93117444755fc510a3011cbd1
+SHA256 (libnatpmp-20090713.tar.gz) = edd6c182f41862eeed1507895a28cb0facb516de8e2d7ca95ecb37e02c3301ff
+SIZE (libnatpmp-20090713.tar.gz) = 14262
diff --git a/net/libnatpmp/files/patch-Makefile b/net/libnatpmp/files/patch-Makefile
new file mode 100644
index 00000000000..74b6e36a16f
--- /dev/null
+++ b/net/libnatpmp/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2009-08-11 21:25:47.000000000 +0800
++++ Makefile 2009-08-11 21:28:24.000000000 +0800
+@@ -50,12 +50,12 @@
+
+ install: $(HEADERS) $(STATICLIB) $(SHAREDLIB)
+ $(INSTALL) -d $(INSTALLDIRINC)
+- $(INSTALL) --mode=644 $(HEADERS) $(INSTALLDIRINC)
++ $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
+ $(INSTALL) -d $(INSTALLDIRLIB)
+- $(INSTALL) --mode=644 $(STATICLIB) $(INSTALLDIRLIB)
+- $(INSTALL) --mode=644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
+- $(INSTALL) --mode=755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
+- ln --symbolic --force $(SONAME) $(INSTALLDIRLIB)/$(SHAREDLIB)
++ $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
++ $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
++ $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
++ ln -s -f $(SONAME) $(INSTALLDIRLIB)/$(SHAREDLIB)
+
+ cleaninstall:
+ $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
diff --git a/net/libnatpmp/pkg-descr b/net/libnatpmp/pkg-descr
new file mode 100644
index 00000000000..1b062a4e18f
--- /dev/null
+++ b/net/libnatpmp/pkg-descr
@@ -0,0 +1,6 @@
+libnatpmp is an attempt to make a portable and fully compliant implementation
+of the protocol for the client side. It is based on non blocking sockets and
+all calls of the API are asynchronous. It is therefore very easy to integrate
+the NAT-PMP code to any event driven code.
+
+WWW: http://miniupnp.free.fr/