aboutsummaryrefslogtreecommitdiffstats
path: root/net/libsocket++/files
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1997-02-08 07:54:07 +0800
committerobrien <obrien@FreeBSD.org>1997-02-08 07:54:07 +0800
commitcfe255407b428a242baf7e5bb2459a536b8e21c0 (patch)
tree9b7beffe70061141ed42018e16b3031c2e469480 /net/libsocket++/files
parent42efbb1cfe7fb5cab31928d24b8a532c31ad826f (diff)
downloadfreebsd-ports-graphics-cfe255407b428a242baf7e5bb2459a536b8e21c0.tar.gz
freebsd-ports-graphics-cfe255407b428a242baf7e5bb2459a536b8e21c0.tar.zst
freebsd-ports-graphics-cfe255407b428a242baf7e5bb2459a536b8e21c0.zip
Socket++ is a iostream like C++ class library for the UNIX and INET
domains of sockets and protocols. Submitted by: Narvi <narvi@haldjas.folklore.ee> Closes-PR: ports/2532
Diffstat (limited to 'net/libsocket++/files')
-rw-r--r--net/libsocket++/files/Makefile.lib22
-rw-r--r--net/libsocket++/files/patch-aa14
-rw-r--r--net/libsocket++/files/patch-ab12
3 files changed, 48 insertions, 0 deletions
diff --git a/net/libsocket++/files/Makefile.lib b/net/libsocket++/files/Makefile.lib
new file mode 100644
index 00000000000..c0126009099
--- /dev/null
+++ b/net/libsocket++/files/Makefile.lib
@@ -0,0 +1,22 @@
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 10
+LIB= socket++
+LIBDIR= ${PREFIX}/lib
+INCDIR= ${PREFIX}/include
+INFODIR= ${PREFIX}/info
+CFLAGS+= -I.
+
+SRCS= sockstream.C sockinet.C sockunix.C pipestream.C Fork.C \
+ echo.C smtp.C ftp.C
+
+HEADERS=Fork.h echo.h ftp.h pipestream.h protocol.h smtp.h \
+ sockinet.h sockstream.h sockunix.h
+
+afterinstall:
+ ${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
+ ${HEADERS} ${INCDIR}
+ makeinfo --no-split socket++.texi
+ ${INSTALL} ${COPY} -o ${MANOWN} -g ${MANGRP} -m ${MANMODE} \
+ socket++.info ${INFODIR}
+
+.include <bsd.lib.mk>
diff --git a/net/libsocket++/files/patch-aa b/net/libsocket++/files/patch-aa
new file mode 100644
index 00000000000..9dcf87b28b2
--- /dev/null
+++ b/net/libsocket++/files/patch-aa
@@ -0,0 +1,14 @@
+*** local.h Tue Oct 8 14:58:35 1996
+--- local.h Tue Oct 8 15:00:07 1996
+***************
+*** 75,81 ****
+--- 75,83 ----
+
+ #if !defined (__linux__)
+ extern "C" int gethostname (char* hostname, int len);
++ #if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__))
+ extern char* SYS_SIGLIST [];
++ #endif
+ #endif
+
+ #ifdef __osf__
diff --git a/net/libsocket++/files/patch-ab b/net/libsocket++/files/patch-ab
new file mode 100644
index 00000000000..9bb01973dca
--- /dev/null
+++ b/net/libsocket++/files/patch-ab
@@ -0,0 +1,12 @@
+--- sockstream.h.orig Tue Oct 17 17:07:29 1995
++++ sockstream.h Wed Feb 5 14:04:17 1997
+@@ -119,7 +119,9 @@
+ msg_peek = MSG_PEEK,
+ msg_dontroute = MSG_DONTROUTE,
+
++#if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__))
+ msg_maxiovlen = MSG_MAXIOVLEN
++#endif
+ };
+ enum shuthow {
+ shut_read,