aboutsummaryrefslogtreecommitdiffstats
path: root/net/licq
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2000-08-16 02:56:30 +0800
committergreen <green@FreeBSD.org>2000-08-16 02:56:30 +0800
commit0e7baeac34ac6e77d58d4195e3dc30891a4009ac (patch)
treecd541e2a6d5def0f4025dc24aeeba2ee5daff369 /net/licq
parent4a65e8587a0bcc76504bff5383c488436f9647f9 (diff)
downloadfreebsd-ports-graphics-0e7baeac34ac6e77d58d4195e3dc30891a4009ac.tar.gz
freebsd-ports-graphics-0e7baeac34ac6e77d58d4195e3dc30891a4009ac.tar.zst
freebsd-ports-graphics-0e7baeac34ac6e77d58d4195e3dc30891a4009ac.zip
Since it makes very... promiscuous modes in the installation, create
the ${PREFIX}/share/licq directory with no external permissions at all while doing the installation, then whack the permissions into shape later before handing it off to the world. There is no race condition, but this is under the assumption that the installation routine doesn't chmod ${PREFIX}/share/licq itself! God only knows, with this autoconfed, libtooled...
Diffstat (limited to 'net/licq')
-rw-r--r--net/licq/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 71a1439620e..4a3fe53beec 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -56,6 +56,10 @@ post-build:
${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+pre-install:
+ ${RM} -rf ${PREFIX}/share/licq
+ ${MKDIR} -m 700 ${PREFIX}/share/licq
+
post-install:
strip ${PREFIX}/bin/licq
cd ${WRKSRC}/plugins/qt-gui;\
@@ -72,5 +76,7 @@ post-install:
${MKDIR} ${PREFIX}/share/licq/qt-gui
cd ${DATADIR}/qt-gui && ${TAR} -chf - * | \
${TAR} -xf - -C ${PREFIX}/share/licq/qt-gui
+ ${CHMOD} -R a-w ${PREFIX}/share/licq
+ ${CHMOD} 555 ${PREFIX}/share/licq
.include <bsd.port.mk>