aboutsummaryrefslogtreecommitdiffstats
path: root/net/linuxigd/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2002-08-04 15:37:39 +0800
committerclive <clive@FreeBSD.org>2002-08-04 15:37:39 +0800
commit6e1e61b49ebcd5550a2a33f74949ae9fb013ccf3 (patch)
treebcb9ca8fd0dfae86038446b7a1e16e23d7411753 /net/linuxigd/Makefile
parent984dd4b6d58c7e44ceed576c9693ab7cefe1bdc3 (diff)
downloadfreebsd-ports-graphics-6e1e61b49ebcd5550a2a33f74949ae9fb013ccf3.tar.gz
freebsd-ports-graphics-6e1e61b49ebcd5550a2a33f74949ae9fb013ccf3.tar.zst
freebsd-ports-graphics-6e1e61b49ebcd5550a2a33f74949ae9fb013ccf3.zip
New port: linuxigd, Linux UPnP Internet Gateway Device.
This project is a deamon that emulates Microsoft's Internet Connection Service (ICS). It implements the UPnP Internet Gateway Device specification (IGD) and allows UPnP aware clients, such as MSN Messenger to work properly from behind a NAT firewall. PR: ports/41295 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com> Submitter sponsored by: Miss WeiWei.
Diffstat (limited to 'net/linuxigd/Makefile')
-rw-r--r--net/linuxigd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/linuxigd/Makefile b/net/linuxigd/Makefile
new file mode 100644
index 00000000000..54a45ee6a73
--- /dev/null
+++ b/net/linuxigd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: linuxigd
+# Date created: 02 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linuxigd
+PORTVERSION= 0.75
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= linux-igd
+DISTNAME= gateway-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@leeym.com
+
+LIB_DEPENDS= upnp.1:${PORTSDIR}/devel/upnp
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+
+post-extract:
+ @${CHMOD} 755 ${WRKSRC}/etc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/gateway.h
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.sh.sample ${PREFIX}/etc/rc.d
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>