aboutsummaryrefslogtreecommitdiffstats
path: root/net/mpd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-16 18:27:36 +0800
committermiwi <miwi@FreeBSD.org>2006-12-16 18:27:36 +0800
commit41dd0ae599abf3988c203af5ec7ef56f035bb1f2 (patch)
tree21fa0eb60ea3f36110012dd449879f86072ad787 /net/mpd
parent8891ee6b535a5cf5b69047697c30adc2cd63f1a8 (diff)
downloadfreebsd-ports-graphics-41dd0ae599abf3988c203af5ec7ef56f035bb1f2.tar.gz
freebsd-ports-graphics-41dd0ae599abf3988c203af5ec7ef56f035bb1f2.tar.zst
freebsd-ports-graphics-41dd0ae599abf3988c203af5ec7ef56f035bb1f2.zip
- Fix build with gcc 4.X
PR: ports/106746 Submitted by: trasz
Diffstat (limited to 'net/mpd')
-rw-r--r--net/mpd/Makefile1
-rw-r--r--net/mpd/files/patch-src::iface.h10
-rw-r--r--net/mpd/files/patch-src::radius.c20
3 files changed, 30 insertions, 1 deletions
diff --git a/net/mpd/Makefile b/net/mpd/Makefile
index 9f619eed572..6375bf4ee24 100644
--- a/net/mpd/Makefile
+++ b/net/mpd/Makefile
@@ -21,7 +21,6 @@ MAN8= mpd.8
MANCOMPRESSED= maybe
USE_OPENSSL= yes
-USE_RC_SUBR= yes
MAKE_ENV= COPTS="${COPTS} -I${OPENSSLINC}" LDADD="${LDADD} -L${OPENSSLLIB}"
.include <bsd.port.pre.mk>
diff --git a/net/mpd/files/patch-src::iface.h b/net/mpd/files/patch-src::iface.h
new file mode 100644
index 00000000000..2b23ee683bc
--- /dev/null
+++ b/net/mpd/files/patch-src::iface.h
@@ -0,0 +1,10 @@
+--- src/iface.h.orig Fri Dec 15 01:39:27 2006
++++ src/iface.h Fri Dec 15 01:40:35 2006
+@@ -21,6 +21,7 @@
+ #include "mbuf.h"
+ #include "timer.h"
+ #include "vars.h"
++#include "command.h"
+
+ /*
+ * DEFINITIONS
diff --git a/net/mpd/files/patch-src::radius.c b/net/mpd/files/patch-src::radius.c
new file mode 100644
index 00000000000..7567c2f4a64
--- /dev/null
+++ b/net/mpd/files/patch-src::radius.c
@@ -0,0 +1,20 @@
+--- src/radius.c.orig Fri Dec 15 01:42:07 2006
++++ src/radius.c Fri Dec 15 01:55:53 2006
+@@ -922,7 +922,7 @@
+ case RAD_MICROSOFT_MS_CHAP_ERROR:
+ /* there is a nullbyte on the first pos, don't know why */
+ if (((const char *)data)[0] == '\0') {
+- ((const char *)data)++;
++ data+=sizeof(const char);
+ len--;
+ }
+ free(rad->mschap_error);
+@@ -945,7 +945,7 @@
+ * Only point at the String field if we don't think the
+ * peer has misformatted the response.
+ */
+- ((const char *)data)++;
++ data+=sizeof(const char);
+ len--;
+ } else
+ Log(LG_RADIUS, ("[%s] RADIUS: %s: Warning: The MS-CHAP2-Success attribute is mis-formatted. Compensating",