aboutsummaryrefslogtreecommitdiffstats
path: root/net/netatalk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-02-24 00:10:32 +0800
committermarcus <marcus@FreeBSD.org>2008-02-24 00:10:32 +0800
commit0fd69f927eee18610b89591c2c53e276a17fc083 (patch)
tree9b2277f9af73eb15107e213575e46ab6b0db76a9 /net/netatalk
parent2ef0c8fa29402c4784397c5c2fc5d1f31c4176b3 (diff)
downloadfreebsd-ports-graphics-0fd69f927eee18610b89591c2c53e276a17fc083.tar.gz
freebsd-ports-graphics-0fd69f927eee18610b89591c2c53e276a17fc083.tar.zst
freebsd-ports-graphics-0fd69f927eee18610b89591c2c53e276a17fc083.zip
Add support for Kerberos V authentication.
Submitted by: Cian Hughes <ci@nhugh.es>
Diffstat (limited to 'net/netatalk')
-rw-r--r--net/netatalk/Makefile9
-rw-r--r--net/netatalk/pkg-plist3
2 files changed, 12 insertions, 0 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 0fb443f3f38..df5e44502c8 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -28,6 +28,14 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
--with-libiconv=${LOCALBASE}
+
+.if defined(WITH_KRB5)
+CONFIGURE_ARGS+= --enable-krbV-uam
+PLIST_SUB+= NETATALKKRB5=""
+.else
+PLIST_SUB+= NETATALKKRB5="@comment "
+.endif
+
.if defined(WITH_PAM)
CONFIGURE_ARGS+= --with-pam=/etc/pam.d
PLIST_SUB+= NETATALKPAM=""
@@ -82,6 +90,7 @@ pre-everything::
@${ECHO_MSG} " WITH_SRVLOC=yes Enable Service Location Protocol support"
@${ECHO_MSG} " WITH_PAM=yes Enable PAM support"
@${ECHO_MSG} " WITH_TIMELORD=yes Enable Timelord network time service"
+ @${ECHO_MSG} " WITH_KRB5=yes Enable Kerberos V UAM"
@${ECHO_MSG} ""
@${ECHO_MSG} "See Netatalk's Makefile for more details on some of these options."
@${ECHO_MSG} ""
diff --git a/net/netatalk/pkg-plist b/net/netatalk/pkg-plist
index 270bb8a6ea8..53f3aeb8f45 100644
--- a/net/netatalk/pkg-plist
+++ b/net/netatalk/pkg-plist
@@ -67,6 +67,9 @@ etc/uams/uams_dhx.so
etc/uams/uams_dhx_passwd.a
etc/uams/uams_dhx_passwd.la
etc/uams/uams_dhx_passwd.so
+%%NETATALKKRB5%%etc/uams/uams_gss.a
+%%NETATALKKRB5%%etc/uams/uams_gss.la
+%%NETATALKKRB5%%etc/uams/uams_gss.so
etc/uams/uams_guest.a
etc/uams/uams_guest.la
etc/uams/uams_guest.so