aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntp/files
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2006-06-24 22:33:59 +0800
committercy <cy@FreeBSD.org>2006-06-24 22:33:59 +0800
commita93aaf635460a271275e9a423e977beaedd25e9f (patch)
treee129258efd3bc237cfaa89d3469ab3774eeda3c0 /net/ntp/files
parent7f01ba6191cd8b0e73b85cee06c9e473c5cc4925 (diff)
downloadfreebsd-ports-graphics-a93aaf635460a271275e9a423e977beaedd25e9f.tar.gz
freebsd-ports-graphics-a93aaf635460a271275e9a423e977beaedd25e9f.tar.zst
freebsd-ports-graphics-a93aaf635460a271275e9a423e977beaedd25e9f.zip
Update 4.2.0 --> 4.2.2
Diffstat (limited to 'net/ntp/files')
-rw-r--r--net/ntp/files/patch-Makefile.in40
-rw-r--r--net/ntp/files/patch-aa39
-rw-r--r--net/ntp/files/patch-ntpdc::ntpdc.c14
-rw-r--r--net/ntp/files/patch-ntpq::ntpq.c14
4 files changed, 0 insertions, 107 deletions
diff --git a/net/ntp/files/patch-Makefile.in b/net/ntp/files/patch-Makefile.in
deleted file mode 100644
index 7829972e136..00000000000
--- a/net/ntp/files/patch-Makefile.in
+++ /dev/null
@@ -1,40 +0,0 @@
---- Makefile.in.orig Wed Oct 15 02:01:51 2003
-+++ Makefile.in Mon Apr 19 22:01:44 2004
-@@ -224,7 +224,7 @@
- version
-
-
--DISTCLEANFILES = .warning
-+DISTCLEANFILES = .gcc-warning
-
- #ETAGS_ARGS = $(srcdir)/Makefile.am $(srcdir)/configure.in
- ETAGS_ARGS = Makefile.am configure.in
-@@ -232,8 +232,8 @@
- # HMS: make ports be the last directory...
- # DIST_HOOK_DIRS = conf html scripts ports
-
--# HMS: Keep .warning first, as that way it gets printed first.
--BUILT_SOURCES = .warning $(srcdir)/COPYRIGHT $(srcdir)/version
-+# HMS: Keep .gcc-warning first, as that way it gets printed first.
-+BUILT_SOURCES = .gcc-warning $(srcdir)/COPYRIGHT $(srcdir)/version
-
-
- # HMS: The following seems to be a work-in-progress...
-@@ -672,7 +672,7 @@
- @for i in `find $(distdir)/ports/winnt -type f -name '*.ds*' -print`; \
- do chmod u+w $$i ; unix2dos $$i $$i; done
-
--.warning:
-+.gcc-warning:
- @echo "Compiling with GCC now generates lots of new warnings."
- @echo " "
- @echo "Don't be concerned. They're just warnings."
-@@ -682,7 +682,7 @@
- @echo "Feel free to send patches that fix these warnings, though."
- @echo " "
- @sleep 1
-- @touch .warning
-+ @touch .gcc-warning
-
- .buildcvo:
- echo "$(CVO)" > .buildcvo
diff --git a/net/ntp/files/patch-aa b/net/ntp/files/patch-aa
deleted file mode 100644
index df54ce2e249..00000000000
--- a/net/ntp/files/patch-aa
+++ /dev/null
@@ -1,39 +0,0 @@
---- ntpd/ntp_control.c.orig Mon Apr 9 13:19:56 2001
-+++ ntpd/ntp_control.c Wed Apr 11 20:53:28 2001
-@@ -1823,7 +1823,7 @@
- * Delete leading commas and white space
- */
- while (reqpt < reqend && (*reqpt == ',' ||
-- isspace((int)*reqpt)))
-+ isspace((unsigned char)*reqpt)))
- reqpt++;
- if (reqpt >= reqend)
- return (0);
-@@ -1846,7 +1846,7 @@
- tp++;
- }
- if ((*tp == '\0') || (*tp == '=')) {
-- while (cp < reqend && isspace((int)*cp))
-+ while (cp < reqend && isspace((unsigned char)*cp))
- cp++;
- if (cp == reqend || *cp == ',') {
- buf[0] = '\0';
-@@ -1859,7 +1859,7 @@
- if (*cp == '=') {
- cp++;
- tp = buf;
-- while (cp < reqend && isspace((int)*cp))
-+ while (cp < reqend && isspace((unsigned char)*cp))
- cp++;
- while (cp < reqend && *cp != ',') {
- *tp++ = *cp++;
-@@ -1904,8 +1904,8 @@
- cp++;
- *tp-- = '\0';
- while (tp >= buf) {
-- if (!isspace((int)(*tp)))
-+ if (!isspace((unsigned char)(*tp)))
- break;
- *tp-- = '\0';
- }
- reqpt = cp;
diff --git a/net/ntp/files/patch-ntpdc::ntpdc.c b/net/ntp/files/patch-ntpdc::ntpdc.c
deleted file mode 100644
index bb13b576a46..00000000000
--- a/net/ntp/files/patch-ntpdc::ntpdc.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ntpdc/ntpdc.c.orig Sat Oct 11 00:52:22 2003
-+++ ntpdc/ntpdc.c Sun Jan 25 13:29:58 2004
-@@ -449,7 +449,11 @@
- hints.ai_flags = AI_NUMERICHOST;
-
- a_info = getaddrinfo(hname, service, &hints, &ai);
-+#ifdef EAI_NODATA
- if (a_info == EAI_NONAME || a_info == EAI_NODATA) {
-+#else
-+ if (a_info == EAI_NONAME) {
-+#endif
- hints.ai_flags = AI_CANONNAME;
- #ifdef AI_ADDRCONFIG
- hints.ai_flags |= AI_ADDRCONFIG;
diff --git a/net/ntp/files/patch-ntpq::ntpq.c b/net/ntp/files/patch-ntpq::ntpq.c
deleted file mode 100644
index 0a221dd0742..00000000000
--- a/net/ntp/files/patch-ntpq::ntpq.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ntpq/ntpq.c.orig Thu Oct 9 02:27:05 2003
-+++ ntpq/ntpq.c Sun Jan 25 13:49:33 2004
-@@ -630,7 +630,11 @@
- hints.ai_flags = AI_NUMERICHOST;
-
- a_info = getaddrinfo(hname, service, &hints, &ai);
-+#ifdef EAI_NODATA
- if (a_info == EAI_NONAME || a_info == EAI_NODATA) {
-+#else
-+ if (a_info == EAI_NONAME) {
-+#endif
- hints.ai_flags = AI_CANONNAME;
- #ifdef AI_ADDRCONFIG
- hints.ai_flags |= AI_ADDRCONFIG;