aboutsummaryrefslogtreecommitdiffstats
path: root/net/openafs
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-27 16:42:19 +0800
committermiwi <miwi@FreeBSD.org>2011-11-27 16:42:19 +0800
commitbc2176668a54a0b14467ee795586a9f5c6821989 (patch)
treefc13eda6bb219764f0859fff26851c272d6944be /net/openafs
parent19186bb7bf98291c24f97e7184a49a0e6f704e80 (diff)
downloadfreebsd-ports-graphics-bc2176668a54a0b14467ee795586a9f5c6821989.tar.gz
freebsd-ports-graphics-bc2176668a54a0b14467ee795586a9f5c6821989.tar.zst
freebsd-ports-graphics-bc2176668a54a0b14467ee795586a9f5c6821989.zip
- Unbreak build on 9.0
PR: 162901 Submitted by: maintainer Feature safe: yes
Diffstat (limited to 'net/openafs')
-rw-r--r--net/openafs/Makefile2
-rw-r--r--net/openafs/files/patch-src__afs__afs_server.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/openafs/Makefile b/net/openafs/Makefile
index 906b5e8e64f..2099ff94828 100644
--- a/net/openafs/Makefile
+++ b/net/openafs/Makefile
@@ -8,7 +8,7 @@
PORTNAME= openafs
DISTVERSION= ${AFS_DISTVERSION}.${DBVERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kld
MASTER_SITES= http://dl.central.org/dl/openafs/${AFS_DISTVERSION}/:openafs \
http://dl.openafs.org/dl/openafs/${AFS_DISTVERSION}/:openafs \
diff --git a/net/openafs/files/patch-src__afs__afs_server.c b/net/openafs/files/patch-src__afs__afs_server.c
new file mode 100644
index 00000000000..ec52e26b24d
--- /dev/null
+++ b/net/openafs/files/patch-src__afs__afs_server.c
@@ -0,0 +1,13 @@
+diff --git a/src/afs/afs_server.c b/src/afs/afs_server.c
+index ad28100..cafd355 100644
+--- a/src/afs/afs_server.c
++++ b/src/afs/afs_server.c
+@@ -1032,7 +1032,7 @@ afsi_SetServerIPRank(struct srvAddr *sa, struct in_ifaddr *ifa)
+ struct sockaddr_in *sin;
+ int t;
+
+- if ((ntohl(sa->sa_ip) & ifa->ia_netmask) == ifa->ia_net) {
++ if (1) {
+ if ((ntohl(sa->sa_ip) & ifa->ia_subnetmask) == ifa->ia_subnet) {
+ sin = IA_SIN(ifa);
+ if (SA2ULONG(sin) == ntohl(sa->sa_ip)) { /* ie, ME!!! */