aboutsummaryrefslogtreecommitdiffstats
path: root/net/ostinato
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
commit612bc3c9c8698b6a8cdbb965267678a0ac829218 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /net/ostinato
parent83574ff9450fce1ff644a38992000262dfd6586b (diff)
downloadfreebsd-ports-graphics-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.gz
freebsd-ports-graphics-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.zst
freebsd-ports-graphics-612bc3c9c8698b6a8cdbb965267678a0ac829218.zip
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Diffstat (limited to 'net/ostinato')
-rw-r--r--net/ostinato/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/ostinato/Makefile b/net/ostinato/Makefile
index b73d475fec3..63270c02a1e 100644
--- a/net/ostinato/Makefile
+++ b/net/ostinato/Makefile
@@ -11,9 +11,10 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}${EXTRACTSUFFIX}
MAINTAINER= zeising@FreeBSD.org
COMMENT= Packet crafter/generator and analyzer with friendly GUI
-LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
-USE_QT4= gui moc_build qmake_build rcc_build uic_build network script \
+USES= qmake
+USE_QT4= gui moc_build rcc_build uic_build network script \
xml
PLIST_FILES= bin/drone \
@@ -21,11 +22,4 @@ PLIST_FILES= bin/drone \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-HAS_CONFIGURE= yes
-
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
-
.include <bsd.port.mk>