aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Amazon-Thumbnail
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-03-25 04:02:37 +0800
committerbeech <beech@FreeBSD.org>2008-03-25 04:02:37 +0800
commitedb9ae0eed8ac83ac526a62afd9842fff2cb6ab2 (patch)
tree37240fc37eed9f423f9ebeca26264d45ed2416fd /net/p5-Net-Amazon-Thumbnail
parent95633ec4b707ce8b6288f8424bcce2ebc3c963df (diff)
downloadfreebsd-ports-graphics-edb9ae0eed8ac83ac526a62afd9842fff2cb6ab2.tar.gz
freebsd-ports-graphics-edb9ae0eed8ac83ac526a62afd9842fff2cb6ab2.tar.zst
freebsd-ports-graphics-edb9ae0eed8ac83ac526a62afd9842fff2cb6ab2.zip
- New port p5-Net-Amazon-Thumbnail-0.06
The Alexa Site Thumbnail web service provides developers with programmatic access to thumbnail images for the home pages of web sites. It offers access to Alexa's large and growing collection of images, gathered from its comprehensive web crawl. This web service enables developers to enhance web sites, search results, web directories, blog entries, and other web real estate with Alexa thumbnail images. PR: ports/121915 Submitted by: Greg Larkin <glarkin at sourcehosting.net>
Diffstat (limited to 'net/p5-Net-Amazon-Thumbnail')
-rw-r--r--net/p5-Net-Amazon-Thumbnail/Makefile34
-rw-r--r--net/p5-Net-Amazon-Thumbnail/distinfo3
-rw-r--r--net/p5-Net-Amazon-Thumbnail/pkg-descr9
-rw-r--r--net/p5-Net-Amazon-Thumbnail/pkg-message16
-rw-r--r--net/p5-Net-Amazon-Thumbnail/pkg-plist3
5 files changed, 65 insertions, 0 deletions
diff --git a/net/p5-Net-Amazon-Thumbnail/Makefile b/net/p5-Net-Amazon-Thumbnail/Makefile
new file mode 100644
index 00000000000..2b7633caeee
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-Amazon-Thumbnail
+# Date created: 2008-03-20
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-Thumbnail
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Perl interface to Amazon Alexa Site Thumbnail web service
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/URI/QueryParam.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::Amazon::Thumbnail.3
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-Thumbnail/distinfo b/net/p5-Net-Amazon-Thumbnail/distinfo
new file mode 100644
index 00000000000..91f29ffe816
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Amazon-Thumbnail-0.06.tar.gz) = f3f86cb15076ae95b9a500bae68e5ba0
+SHA256 (Net-Amazon-Thumbnail-0.06.tar.gz) = c660fe06d659fc57e751b73666080219a27f79742b0fad69e56eb602638f87ef
+SIZE (Net-Amazon-Thumbnail-0.06.tar.gz) = 7807
diff --git a/net/p5-Net-Amazon-Thumbnail/pkg-descr b/net/p5-Net-Amazon-Thumbnail/pkg-descr
new file mode 100644
index 00000000000..72f2424a0dd
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/pkg-descr
@@ -0,0 +1,9 @@
+The Alexa Site Thumbnail web service provides developers with
+programmatic access to thumbnail images for the home pages of web
+sites. It offers access to Alexa's large and growing collection of
+images, gathered from its comprehensive web crawl. This web service
+enables developers to enhance web sites, search results, web
+directories, blog entries, and other web real estate with Alexa
+thumbnail images.
+
+WWW: http://search.cpan.org/dist/Net-Amazon-Thumbnail/
diff --git a/net/p5-Net-Amazon-Thumbnail/pkg-message b/net/p5-Net-Amazon-Thumbnail/pkg-message
new file mode 100644
index 00000000000..4cded7c9d40
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/pkg-message
@@ -0,0 +1,16 @@
+
+You need to do some things before you can use the Amazon Alexa Site
+Thumbnail service:
+
+1) Visit http://aws.amazon.com/ to create an Amazon AWS account.
+
+2) Obtain your AWS public key and secret key to use with the thumbnail
+ service.
+
+3) Visit http://aws.amazon.com/ast/ for more information and
+ resources.
+
+ DISCLAIMER: No one but you is responsible for paying Amazon to
+ use the Thumbnail service. The service does not have
+ a free sandbox area, so be aware how much money you
+ are spending to use the service.
diff --git a/net/p5-Net-Amazon-Thumbnail/pkg-plist b/net/p5-Net-Amazon-Thumbnail/pkg-plist
new file mode 100644
index 00000000000..6dcaac36127
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Net/Amazon/Thumbnail.pm
+@dirrmtry %%SITE_PERL%%/Net/Amazon
+@dirrmtry %%SITE_PERL%%/Net