aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-HL7
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-07-28 21:36:53 +0800
committergarga <garga@FreeBSD.org>2005-07-28 21:36:53 +0800
commitbc5dddc24e853445e84e3613807564f550f0ad3e (patch)
treea44e9da9648eb6f85b2c43cb826b25982435bbd0 /net/p5-Net-HL7
parent1320e2a0a3a73a9062bff3fb6a02958b79d79acb (diff)
downloadfreebsd-ports-graphics-bc5dddc24e853445e84e3613807564f550f0ad3e.tar.gz
freebsd-ports-graphics-bc5dddc24e853445e84e3613807564f550f0ad3e.tar.zst
freebsd-ports-graphics-bc5dddc24e853445e84e3613807564f550f0ad3e.zip
Add p5-Net-HL7 0.73, net::HL7 - A simple yet flexible API for non-XML
HL7 applications. PR: ports/84182 Submitted by: Brent B. Powers <bbp2006@columbia.edu>
Diffstat (limited to 'net/p5-Net-HL7')
-rw-r--r--net/p5-Net-HL7/Makefile44
-rw-r--r--net/p5-Net-HL7/distinfo2
-rw-r--r--net/p5-Net-HL7/pkg-descr5
-rw-r--r--net/p5-Net-HL7/pkg-plist15
4 files changed, 66 insertions, 0 deletions
diff --git a/net/p5-Net-HL7/Makefile b/net/p5-Net-HL7/Makefile
new file mode 100644
index 00000000000..9dfb71258ef
--- /dev/null
+++ b/net/p5-Net-HL7/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: net/p5-Net-HL7
+# Date created: 26 Jul 2005
+# Whom: Brent B. Powers <bbp2006@columbia.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-HL7
+PORTVERSION= 0.73
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= hl7toolkit
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bbp2006@columbia.edu
+COMMENT= Net::HL7 - A simple yet flexible API for non-XML HL7 applications
+
+PORTDOCS= README
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::HL7.3 \
+ Net::HL7::Request.3 \
+ Net::HL7::Connection.3 \
+ Net::HL7::Response.3 \
+ Net::HL7::Daemon.3 \
+ Net::HL7::Segment.3 \
+ Net::HL7::Message.3 \
+ Net::HL7::Segments::MSH.3 \
+ Net::HL7::Messages::ACK.3
+
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} < 500000)
+IGNORE= Doesn't build on 4.x
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-HL7/distinfo b/net/p5-Net-HL7/distinfo
new file mode 100644
index 00000000000..5f46b7631fb
--- /dev/null
+++ b/net/p5-Net-HL7/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-HL7-0.73.tar.gz) = c1d4ac9a4e70baf68760da708862f8af
+SIZE (Net-HL7-0.73.tar.gz) = 17558
diff --git a/net/p5-Net-HL7/pkg-descr b/net/p5-Net-HL7/pkg-descr
new file mode 100644
index 00000000000..6e2c1070169
--- /dev/null
+++ b/net/p5-Net-HL7/pkg-descr
@@ -0,0 +1,5 @@
+The HL7 toolkit provides a lightweight Perl API for creating,
+manipulating, sending, and receiving HL7 messages. For more
+information about HL7, see http://www.hl7.org
+
+WWW: http://hl7toolkit.sourceforge.net
diff --git a/net/p5-Net-HL7/pkg-plist b/net/p5-Net-HL7/pkg-plist
new file mode 100644
index 00000000000..9b4abda54ff
--- /dev/null
+++ b/net/p5-Net-HL7/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/Net/HL7.pm
+%%SITE_PERL%%/Net/HL7/Segment.pm
+%%SITE_PERL%%/Net/HL7/Message.pm
+%%SITE_PERL%%/Net/HL7/Request.pm
+%%SITE_PERL%%/Net/HL7/Response.pm
+%%SITE_PERL%%/Net/HL7/Connection.pm
+%%SITE_PERL%%/Net/HL7/Daemon.pm
+%%SITE_PERL%%/Net/HL7/Messages/ACK.pm
+%%SITE_PERL%%/Net/HL7/Segments/MSH.pm
+%%SITE_PERL%%/mach/auto/Net-HL7/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Net-HL7/
+@dirrm %%SITE_PERL%%/Net/HL7/Segments
+@dirrm %%SITE_PERL%%/Net/HL7/Messages
+@unexec rmdir %D/%%SITE_PERL%%/Net/HL7 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true