aboutsummaryrefslogtreecommitdiffstats
path: root/net/pear-Net_UserAgent_Detect
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-09 12:59:35 +0800
committeredwin <edwin@FreeBSD.org>2005-01-09 12:59:35 +0800
commit40ee12f14a11c4205804f7c21aa3ba7e2b681083 (patch)
tree4ad9f3950adaf15f83f33aa54db78d888b14fa99 /net/pear-Net_UserAgent_Detect
parent2080f97de87a851187b0b489853e004d2d471700 (diff)
downloadfreebsd-ports-graphics-40ee12f14a11c4205804f7c21aa3ba7e2b681083.tar.gz
freebsd-ports-graphics-40ee12f14a11c4205804f7c21aa3ba7e2b681083.tar.zst
freebsd-ports-graphics-40ee12f14a11c4205804f7c21aa3ba7e2b681083.zip
New port: net/pear-Net_UserAgent_Detect PEAR class that detects web
browser, version and platform The Net_UserAgent object does a number of tests on an HTTP user agent string. The results of these tests are available via methods of the object. This module is based upon the JavaScript browser detection code available at http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html. This module had many influences from the lib/Browser.php code in version 1.3 of Horde. PR: ports/75815 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Diffstat (limited to 'net/pear-Net_UserAgent_Detect')
-rw-r--r--net/pear-Net_UserAgent_Detect/Makefile32
-rw-r--r--net/pear-Net_UserAgent_Detect/distinfo2
-rw-r--r--net/pear-Net_UserAgent_Detect/pkg-descr10
3 files changed, 44 insertions, 0 deletions
diff --git a/net/pear-Net_UserAgent_Detect/Makefile b/net/pear-Net_UserAgent_Detect/Makefile
new file mode 100644
index 00000000000..0b4999f5c41
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pear-Net_UserAgent_Detect
+# Date created: 04 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_UserAgent_Detect
+PORTVERSION= 2.0.1
+CATEGORIES= net pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class that detects web browser, version and platform
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+CATEGORY= Net/UserAgent
+FILES= Detect.php
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 410
+IGNORE= "You need PHP 4.1.0 or later to install PEAR::Net_UserAgent_Detect"
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_UserAgent_Detect/distinfo b/net/pear-Net_UserAgent_Detect/distinfo
new file mode 100644
index 00000000000..a828c9b8796
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_UserAgent_Detect-2.0.1.tgz) = b49c6a19b220d674db4355bdab3498e5
+SIZE (PEAR/Net_UserAgent_Detect-2.0.1.tgz) = 8230
diff --git a/net/pear-Net_UserAgent_Detect/pkg-descr b/net/pear-Net_UserAgent_Detect/pkg-descr
new file mode 100644
index 00000000000..7c6a69756e7
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/pkg-descr
@@ -0,0 +1,10 @@
+The Net_UserAgent object does a number of tests on an HTTP user
+agent string. The results of these tests are available via methods of
+the object.
+
+This module is based upon the JavaScript browser detection code available
+at http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html.
+This module had many influences from the lib/Browser.php code in
+version 1.3 of Horde.
+
+WWW: http://pear.php.net/package/Net_UserAgent_Detect/