aboutsummaryrefslogtreecommitdiffstats
path: root/net/poptop
diff options
context:
space:
mode:
authornsayer <nsayer@FreeBSD.org>2001-09-09 00:28:00 +0800
committernsayer <nsayer@FreeBSD.org>2001-09-09 00:28:00 +0800
commit1684df15e1c3a04fd16037eb7ea3053f185e38ea (patch)
treeb89b867c1aab5b37e38d5ec23e83b95fd83183ee /net/poptop
parentc79eabd0e8a34d740b854b98102d7e27069defec (diff)
downloadfreebsd-ports-graphics-1684df15e1c3a04fd16037eb7ea3053f185e38ea.tar.gz
freebsd-ports-graphics-1684df15e1c3a04fd16037eb7ea3053f185e38ea.tar.zst
freebsd-ports-graphics-1684df15e1c3a04fd16037eb7ea3053f185e38ea.zip
1. Upgrade to 1.1.2. They recommend 1.0.1, but 1.1.2 has been out for a
while and appears to work better. 2. INSTALL_SCRIPT for the rc.d script rather than INSTALL_DATA. That way it actually gets run at startup.
Diffstat (limited to 'net/poptop')
-rw-r--r--net/poptop/Makefile4
-rw-r--r--net/poptop/distinfo2
-rw-r--r--net/poptop/files/patch-ae18
3 files changed, 21 insertions, 3 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index b83f209e88f..56eb839a090 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= poptop
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.2
CATEGORIES= net
MASTER_SITES= http://poptop.lineo.com/releases/
DISTNAME= pptpd-${PORTVERSION}
@@ -21,6 +21,6 @@ MAN8= pptpd.8 pptpctrl.8
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf ${PREFIX}/etc/pptpd.conf.sample
- ${INSTALL_DATA} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
+ ${INSTALL_SCRIPT} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
.include <bsd.port.mk>
diff --git a/net/poptop/distinfo b/net/poptop/distinfo
index 1e3787270e5..9cdcb50209a 100644
--- a/net/poptop/distinfo
+++ b/net/poptop/distinfo
@@ -1 +1 @@
-MD5 (pptpd-1.0.1.tar.gz) = 67fbb621e1de325012feeb105846fe7d
+MD5 (pptpd-1.1.2.tar.gz) = 03f7106c6fd7f22bd904b5c66aedbe92
diff --git a/net/poptop/files/patch-ae b/net/poptop/files/patch-ae
new file mode 100644
index 00000000000..c0ab9ecc112
--- /dev/null
+++ b/net/poptop/files/patch-ae
@@ -0,0 +1,18 @@
+--- pptpgre.c.orig Sat Sep 8 09:12:30 2001
++++ pptpgre.c Sat Sep 8 09:13:11 2001
+@@ -114,6 +114,7 @@
+ strerror (errno));
+ }
+
++#if 0
+ /* Tell kernel we do not want headers with our IP packets. I was
+ hoping this would eliminate the need to strip them from received
+ packets, but instead it appears to only affect transmission.
+@@ -131,6 +132,7 @@
+ syslog (LOG_ERR, "Couldn't set hdrincl to false");
+ }
+ }
++#endif
+
+ gre->pty_fd = pty_fd;
+ gre->call_id_pair = call_id_pair; /* network byte order */