aboutsummaryrefslogtreecommitdiffstats
path: root/net/pptpclient/Makefile
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>2001-05-13 06:29:18 +0800
committerjdp <jdp@FreeBSD.org>2001-05-13 06:29:18 +0800
commitf8f022670e3cd76f3a79ad9a20bcde71031357bc (patch)
tree23000eab4c0f2b3dd2a14b192d3f670b99b702bc /net/pptpclient/Makefile
parent4714b5567607bd982cbc0ba15702ffdfd6a3ad83 (diff)
downloadfreebsd-ports-graphics-f8f022670e3cd76f3a79ad9a20bcde71031357bc.tar.gz
freebsd-ports-graphics-f8f022670e3cd76f3a79ad9a20bcde71031357bc.tar.zst
freebsd-ports-graphics-f8f022670e3cd76f3a79ad9a20bcde71031357bc.zip
Upgrade from version 1.0.2 to 1.0.3 and welcome Thomas Quinot as
the new maintainer of this port. Submitted by: Thomas Quinot <thomas@cuivre.fr.eu.org>
Diffstat (limited to 'net/pptpclient/Makefile')
-rw-r--r--net/pptpclient/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index bcb6186c740..d494f5a8557 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -6,16 +6,33 @@
#
PORTNAME= pptpclient
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= net
-MASTER_SITES= http://www.pdos.lcs.mit.edu/~cananian/Projects/PPTP/release/ \
- ftp://ftp.kddlabs.co.jp/pub/inet/vpn/pptp-linux/ \
- ftp://ftp.iks-jena.de/pub/software/linux/net/
-DISTNAME= pptp-linux-1.0.2
+MASTER_SITES= http://www.linuxalpha.compaq.com/pptpclient/files/
+DISTNAME= pptp-linux-1.0.3
+DISTFILES= pptp-linux-1.0.3-1.tar.gz
-MAINTAINER= jdp@freebsd.org
+MAINTAINER= thomas@cuivre.fr.eu.org
-post-install:
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgnugetopt.a:${PORTSDIR}/devel/libgnugetopt
+
+MAKE_ARGS= DEBUG="" \
+ INCLUDE="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
+ pptp
+
+GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @(cd ${WRKDIR} && \
+ ${GUNZIP_CMD} ${_DISTDIR}/${DISTFILES} | tar -xf - && \
+ ${GUNZIP_CMD} `basename ${DISTFILES} .tar.gz`/${DISTNAME}.tar.gz | \
+ tar -xf -)
+
+do-install:
+ cd ${WRKSRC} ; ${INSTALL_PROGRAM} pptp ${PREFIX}/sbin
${MKDIR} ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient