aboutsummaryrefslogtreecommitdiffstats
path: root/net/ptunnel/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-04-29 01:40:33 +0800
committerleeym <leeym@FreeBSD.org>2005-04-29 01:40:33 +0800
commitfdefda448c7d743de70481e8af367be4d8c49dc2 (patch)
tree7e9953033619eaf26562f8aa551e20851413283d /net/ptunnel/Makefile
parent352b7cfa73178f237e453d9427bf2095d2ab4dc8 (diff)
downloadfreebsd-ports-graphics-fdefda448c7d743de70481e8af367be4d8c49dc2.tar.gz
freebsd-ports-graphics-fdefda448c7d743de70481e8af367be4d8c49dc2.tar.zst
freebsd-ports-graphics-fdefda448c7d743de70481e8af367be4d8c49dc2.zip
add ptunnel-0.60
Ptunnel is an application that allows you to reliably tunnel TCP connections to a remote host using ICMP echo request and reply packets, commonly known as ping requests and replies. WWW: http://www.cs.uit.no/~daniels/PingTunnel/
Diffstat (limited to 'net/ptunnel/Makefile')
-rw-r--r--net/ptunnel/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/ptunnel/Makefile b/net/ptunnel/Makefile
new file mode 100644
index 00000000000..04997918100
--- /dev/null
+++ b/net/ptunnel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ptunnel
+# Date created: 23 April 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptunnel
+PORTVERSION= 0.60
+CATEGORIES= net
+MASTER_SITES= http://www.cs.uit.no/~daniels/PingTunnel/
+DISTNAME= PingTunnel-${PORTVERSION}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Tunneling TCP connections over ICMP echo request and reply
+
+WRKSRC= ${WRKDIR}/PingTunnel
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/ptunnel
+MAN8= ptunnel.8
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/' ${WRKSRC}/${MAKEFILE}
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's/stdint.h/inttypes.h/' ${WRKSRC}/ptunnel.h
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ptunnel ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ptunnel.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.post.mk>