aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-GeoIP
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-29 05:03:52 +0800
committerkrion <krion@FreeBSD.org>2004-02-29 05:03:52 +0800
commitfd47214a35644bbcff40e79811e6d61085d8760d (patch)
tree728628dc00969e4672ed874eb22ef6df96a96326 /net/py-GeoIP
parent4ebab53eb71e2e43f47ce26809d2aaa393076c7d (diff)
downloadfreebsd-ports-graphics-fd47214a35644bbcff40e79811e6d61085d8760d.tar.gz
freebsd-ports-graphics-fd47214a35644bbcff40e79811e6d61085d8760d.tar.zst
freebsd-ports-graphics-fd47214a35644bbcff40e79811e6d61085d8760d.zip
Add py-GeoIP 1.2.0,
Python API to the GeoIP library for obtaining the country, region, city, latitude, and longitude of any IP address. PR: ports/63490 Submitted by: Stefan Walter <sw@gegenunendlich.de>
Diffstat (limited to 'net/py-GeoIP')
-rw-r--r--net/py-GeoIP/Makefile41
-rw-r--r--net/py-GeoIP/distinfo2
-rw-r--r--net/py-GeoIP/pkg-descr4
3 files changed, 47 insertions, 0 deletions
diff --git a/net/py-GeoIP/Makefile b/net/py-GeoIP/Makefile
new file mode 100644
index 00000000000..a8ebd9df309
--- /dev/null
+++ b/net/py-GeoIP/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-GeoIP
+# Date created: 27 February 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GeoIP
+PORTVERSION= 1.2.0
+CATEGORIES= net python
+MASTER_SITES= http://www.maxmind.com/download/geoip/api/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-Python-${PORTVERSION}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Mapping of IP addresses/hostnames to country names in Python
+
+LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLE_FILES= README test.py test_city.py test_org.py
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/GeoIP.so \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/README \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test.py \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test_city.py \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test_org.py
+PLIST_DIRS= %%PORTDOCS%%%%EXAMPLESDIR%%
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/py-GeoIP/distinfo b/net/py-GeoIP/distinfo
new file mode 100644
index 00000000000..b41f5b7c1be
--- /dev/null
+++ b/net/py-GeoIP/distinfo
@@ -0,0 +1,2 @@
+MD5 (GeoIP-Python-1.2.0.tar.gz) = ec40f604fb64971035b1ab72866d8fc1
+SIZE (GeoIP-Python-1.2.0.tar.gz) = 9622
diff --git a/net/py-GeoIP/pkg-descr b/net/py-GeoIP/pkg-descr
new file mode 100644
index 00000000000..d5b9ff7d0a4
--- /dev/null
+++ b/net/py-GeoIP/pkg-descr
@@ -0,0 +1,4 @@
+Python API to the GeoIP library for obtaining the country, region, city,
+latitude, and longitude of any IP address.
+
+WWW: http://www.maxmind.com/app/python