aboutsummaryrefslogtreecommitdiffstats
path: root/net/rp-pppoe/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-08-02 00:31:10 +0800
committerkrion <krion@FreeBSD.org>2004-08-02 00:31:10 +0800
commit4cb847c3f9a6cb73d37ed5fdd76abb9d9fd72a36 (patch)
treec5e1e068852e6f3e8bb301c137be7a9015ff5deb /net/rp-pppoe/Makefile
parent2dfd7a4d6c2e49d07c5cf0a439fa0ab335d58206 (diff)
downloadfreebsd-ports-graphics-4cb847c3f9a6cb73d37ed5fdd76abb9d9fd72a36.tar.gz
freebsd-ports-graphics-4cb847c3f9a6cb73d37ed5fdd76abb9d9fd72a36.tar.zst
freebsd-ports-graphics-4cb847c3f9a6cb73d37ed5fdd76abb9d9fd72a36.zip
Enable pppoe-relay
PR: ports/69868 Submitted by: maintainer
Diffstat (limited to 'net/rp-pppoe/Makefile')
-rw-r--r--net/rp-pppoe/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
index f9d6b096b1c..20e9d24408c 100644
--- a/net/rp-pppoe/Makefile
+++ b/net/rp-pppoe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rp-pppoe
PORTVERSION= 3.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.roaringpenguin.com/penguin/pppoe/
@@ -15,6 +16,7 @@ COMMENT= "The popular Roaring Penguin's PPPoE software"
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+PATCH_WRKSRC= ${WRKSRC}/src
CONFIGURE_WRKSRC= ${WRKSRC}/src
BUILD_WRKSRC= ${WRKSRC}/src
@@ -50,7 +52,7 @@ post-patch:
do-install:
# Binaries
-.for f in pppoe pppoe-server
+.for f in pppoe pppoe-server pppoe-relay
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/sbin
.endfor
# Configurations
@@ -59,10 +61,6 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/configs/${f} \
${PREFIX}/etc/ppp/${f}.sample
.endfor
-.if !exists(${PREFIX}/etc/ppp/pppoe.conf)
- ${INSTALL_SCRIPT} ${PREFIX}/etc/ppp/pppoe.conf.sample \
- ${PREFIX}/etc/ppp/pppoe.conf
-.endif
# Manual pages
@${MKDIR} ${MAN5PREFIX}/man/man5
.for f in ${MAN5}
@@ -76,6 +74,11 @@ do-install:
.for f in ${SCRIPT_FILES}
@${INSTALL_SCRIPT} ${WRKSRC}/scripts/${f} ${PREFIX}/sbin
.endfor
+# Startup scripts
+.for f in 04pppoe-relay.sh.sample 04pppoe-server.sh.sample
+ @${INSTALL_SCRIPT} ${FILESDIR}/${f} ${PREFIX}/etc/rc.d/
+.endfor
+
# Documentation
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}