aboutsummaryrefslogtreecommitdiffstats
path: root/net/tcpdump
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2003-12-11 21:49:52 +0800
committerbms <bms@FreeBSD.org>2003-12-11 21:49:52 +0800
commit49773904b6c67b4488615ea725de55e4762b30e6 (patch)
treeaf177ac9c4aa1b14d9638957c5da37bcb7d72d7f /net/tcpdump
parentf80482c0d1b98a3a3182b75b3659dbe62af17d76 (diff)
downloadfreebsd-ports-graphics-49773904b6c67b4488615ea725de55e4762b30e6.tar.gz
freebsd-ports-graphics-49773904b6c67b4488615ea725de55e4762b30e6.tar.zst
freebsd-ports-graphics-49773904b6c67b4488615ea725de55e4762b30e6.zip
Fix pcap dependency. Previously tcpdump 3.8.1 would be linked against the
system libpcap.a. Create a symlink farm in the ${WRKDIR} so that tcpdump's configure script will use the installed libpcap-0.8.1 package. Noticed by: Andrzej Tobola
Diffstat (limited to 'net/tcpdump')
-rw-r--r--net/tcpdump/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 509f8e395a3..db7bc0698ca 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -22,7 +22,6 @@ MAN1= tcpdump.1
GNU_CONFIGURE= yes
-
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -31,4 +30,20 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --without-crypto
.endif
+LOCALPCAPDIR= ${WRKDIR}/libpcap-0.8.1
+LOCALPCAPFILES= include/pcap.h include/pcap-namedb.h include/pcap-bpf.h \
+ lib/libpcap.a
+
+#
+# When building tcpdump against a particular pcap version, it expects to
+# find a built, untarred source tree in the parent of the work tree.
+# Build a symlink farm to produce the files it wants without requiring
+# pcap to be untarred.
+#
+pre-configure:
+ ${MKDIR} ${LOCALPCAPDIR}
+.for i in ${LOCALPCAPFILES}
+ ${LN} -s ${LOCALBASE}/$i ${LOCALPCAPDIR}
+.endfor
+
.include <bsd.port.mk>