aboutsummaryrefslogtreecommitdiffstats
path: root/net/tsclient/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-04 16:12:58 +0800
committermarcus <marcus@FreeBSD.org>2003-04-04 16:12:58 +0800
commit370cd526c662cc95482464f2693bd811786dd2e3 (patch)
treeda3653cebe1c6c09dd571e382618664609344cde /net/tsclient/Makefile
parent766e81addc6fc8289762e93a43f237da57f71949 (diff)
downloadfreebsd-ports-graphics-370cd526c662cc95482464f2693bd811786dd2e3.tar.gz
freebsd-ports-graphics-370cd526c662cc95482464f2693bd811786dd2e3.tar.zst
freebsd-ports-graphics-370cd526c662cc95482464f2693bd811786dd2e3.zip
Fix hardcoded /usr/libexec link in the tsclient applet.
PR: 50334 Submitted by: maintainer
Diffstat (limited to 'net/tsclient/Makefile')
-rw-r--r--net/tsclient/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 534b9bf0a34..05e63f5fea6 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tsclient
PORTVERSION= 0.104
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= http://www.gnomepro.com/tsclient/
@@ -18,12 +19,17 @@ RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
USE_X_PREFIX= yes
USE_GNOMENG= yes
+USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g;' \
+ ${WRKSRC}/applet/GNOME_TSClientApplet.server
+
post-install:
@${LN} -sf ${PREFIX}/share/gnome/pixmaps/tsclient/tsclient.png \
${PREFIX}/share/gnome/pixmaps/tsclient.png