aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2006-10-05 05:52:49 +0800
committerbms <bms@FreeBSD.org>2006-10-05 05:52:49 +0800
commit053d58e947dada86171ff70fa440061513946b6a (patch)
treec95130f2b514d537cd49e0fb830f3a836a3f700f /net
parent17aaff4cd07638c4cc339e363e8acd3b701a5d13 (diff)
downloadfreebsd-ports-graphics-053d58e947dada86171ff70fa440061513946b6a.tar.gz
freebsd-ports-graphics-053d58e947dada86171ff70fa440061513946b6a.tar.zst
freebsd-ports-graphics-053d58e947dada86171ff70fa440061513946b6a.zip
Fix ntraceroute on 64-bit systems.
PR: ports/103988 Submitted by: fenner
Diffstat (limited to 'net')
-rw-r--r--net/ntraceroute/Makefile10
-rw-r--r--net/ntraceroute/files/patch-traceroute_640.c11
2 files changed, 16 insertions, 5 deletions
diff --git a/net/ntraceroute/Makefile b/net/ntraceroute/Makefile
index 4b036709aa5..630fad491d8 100644
--- a/net/ntraceroute/Makefile
+++ b/net/ntraceroute/Makefile
@@ -19,15 +19,15 @@ COMMENT= Ubiquitous network routing analysis tool
WRKSRC= ${WRKDIR}
-NOMAN= defined
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= .
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
+NOMAN= defined
do-build:
${CC} -o ${WRKSRC}/${PORTNAME} -lm \
- ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
+ ${WRKSRC}/${DISTFILES}
do-install:
${INSTALL} ${COPY} ${STRIP} -o root -g wheel -m 04555 \
diff --git a/net/ntraceroute/files/patch-traceroute_640.c b/net/ntraceroute/files/patch-traceroute_640.c
new file mode 100644
index 00000000000..01e1b7e35d9
--- /dev/null
+++ b/net/ntraceroute/files/patch-traceroute_640.c
@@ -0,0 +1,11 @@
+--- /usr/ports/distfiles/ntraceroute/traceroute_640.c Sun Nov 6 15:43:00 2005
++++ ./traceroute_640.c Wed Oct 4 11:07:20 2006
+@@ -790,7 +790,7 @@
+ struct icmp icmp_probe;
+ } ip_payload;
+ #endif /* V6.3.0 */
+-};
++} __attribute__((packed));
+
+ #ifdef SPRAY
+ /*
003-01-061-1/+1 * Fix build on alpha (don't include the klaptop files when we are on alpha,petef2003-01-021-23/+23 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-112-33/+28 * 1. Bump PORTREVISION to 1.alane2002-10-022-10/+23 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-252-15/+2 * Update to 3.0.2 -- full log available in ports/x11/kde3/Makefile,v 1.51.will2002-07-052-2/+2 * Upgrade to KDE 3.0.1. The delay in this upgrade is mainly due to thewill2002-06-163-10/+80 * Don't build klaptopdaemon on alpha.gallatin2002-05-212-23/+34 * Update to 3.0. Sigh.will2002-04-231-0/+226 * Please welcome Qt3/KDE3 to our ports tree. This includes work since thewill2002-04-224-366/+10 * Fix the KDE ports to not use objprelink, if OSVERSION >= 500029. This iswill2002-03-301-1/+7 * Bring in a few changes to the KDE ports infrastructure, and some fixes.will2002-01-111-16/+2 * If !WANT_KDE_NDEBUG and !PARALLEL_PACKAGE_BUILDING, also addwill2002-01-081-0/+3 * Conditionalize use of objprelink based on whether we're running onwill2002-01-051-3/+8 * Fix a problem with auto{conf,make}: some build magic was introduced topetef2001-12-071-1/+1 * Upgrade KDE to 2.2.2:will2001-12-044-5/+44 * Upgrade to 2.2.1.demon2001-10-273-2/+11 * Set DIST_SUBDIR=KDEdemon2001-09-112-1/+2 * Make CATEGORIES and MAINTAINER overridable for japanese/kde*.knu2001-08-311-2/+2 * Reassign MAINTAINER to kde@FreeBSD.org, a group formed specifically towill2001-08-251-1/+1 * *sigh* They changed the path to the tarballs again. This was verifiedwill2001-08-161-1/+1 * Update to KDE 2.2:will2001-08-153-280/+97 * Overhaul QT/KDE support:will2001-04-032-13/+3 * Attempt to fix conflicts with a local getopt.h (specifically, the fix iswill2001-03-051-1/+1 * Lo and behold, welcome KDE 2.1 to our ports tree. As a direct result ofwill2001-02-273-44/+75 * Upgrade to 2.0.1kevlo2000-12-123-8/+43 * Resign as maintainer of KDE2 ports, having brought them up from inceptionwill2000-11-181-1/+1 * Add two missed shared libs.will2000-11-021-0/+2 * Oops, forgot to remove -lqt2 along with -L${X11BASE}/lib, to allow peoplewill2000-10-291-2/+2 * Implement fix for configure scripts in regards to finding X libs onwill2000-10-291-3/+3 * Update to QT 2.2.1 / KDE 2.0 final release. At last! What a long road...will2000-10-253-89/+44 * Update to KDE 1.94, the fifth and final beta release of KDE 2.0. If youwill2000-09-163-71/+41 * Finish updating to KDE2 snapshot 20000829A. Re-add kdenetwork and kdeutilswill2000-08-303-245/+163 * Mark these BROKEN, they don't compile/run properly.asami2000-07-201-0/+2 * Rename INSTALLS_SHLIBS to INSTALLS_SHLIB. (There was a typo in theasami2000-06-171-1/+1 * Fourth round of INSTALLS_SHLIBS conversion.sobomax2000-06-162-2/+1 * Update to KDEUTILS 1.90 (aka KDE2 beta).will2000-05-173-545/+553 * Convert to PORTNAME/PORTVERSION.asami2000-04-141-2/+2 * Bump shlib versions of kdelibs11 and kdesupport11.asami2000-02-241-1/+1 * Remove giflib dependence.imura2000-02-151-2/+1 * Update to KDE-1.1.2se1999-09-183-3/+50 * The version number of libgif.so has changed to 5.steve1999-09-181-1/+1 * Change Id->FreeBSD.obrien1999-08-251