aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-27 14:33:26 +0800
committerwen <wen@FreeBSD.org>2010-12-27 14:33:26 +0800
commit117eddd99bf57c5e21d7c096d6ec5d6b0b18f101 (patch)
tree4905c2c74c1035d754907edaa9be170aee1bcf60 /net
parent8d269f725eb16eaee423a17949e1680177a63ef8 (diff)
downloadfreebsd-ports-graphics-117eddd99bf57c5e21d7c096d6ec5d6b0b18f101.tar.gz
freebsd-ports-graphics-117eddd99bf57c5e21d7c096d6ec5d6b0b18f101.tar.zst
freebsd-ports-graphics-117eddd99bf57c5e21d7c096d6ec5d6b0b18f101.zip
The Web Service Addressing protocol is used to select certain service
and port on a SOAP server, just like the "Host" header in "HTTP". The basic SOAP design uses the URI and the "soapAction" header of HTTP (in case it uses HTTP, by far the most often used transport mechanism) However, when the server is hidden behind firewalls and proxies, these fields are rewritten or replaced. This means that the definitions by the WSDL for the client can differ from the configuration of the WWW: http://search.cpan.org/dist/XML-Compile-SOAP-WSA/ PR: ports/152657 Submitted by: Patrick Powell <papowell@astart.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/Makefile30
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/distinfo2
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/pkg-descr10
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/pkg-plist18
5 files changed, 61 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a9857569ad0..e258e6468aa 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -736,6 +736,7 @@
SUBDIR += p5-X500-DN
SUBDIR += p5-XML-Compile-SOAP
SUBDIR += p5-XML-Compile-SOAP-Daemon
+ SUBDIR += p5-XML-Compile-SOAP-WSA
SUBDIR += p5-XML-RPC
SUBDIR += p5-XML-RPC-Fast
SUBDIR += p5-XPC
diff --git a/net/p5-XML-Compile-SOAP-WSA/Makefile b/net/p5-XML-Compile-SOAP-WSA/Makefile
new file mode 100644
index 00000000000..82a6a9be6c5
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: net/p5-XML-Compile-SOAP-WSA
+# Date created: 23 Nov 2010
+# Whom: Patrick Powell <papowell@astart.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP-WSA
+PORTVERSION= 0.12
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= papowell@astart.com
+COMMENT= SOAP message messages with WSA fields
+
+BUILD_DEPENDS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
+ p5-libwww>=5.803:${PORTSDIR}/www/p5-libwww \
+ p5-Log-Report>=0.22:${PORTSDIR}/devel/p5-Log-Report \
+ p5-XML-Compile-SOAP>=2.10:${PORTSDIR}/net/p5-XML-Compile-SOAP \
+ p5-XML-Compile>=1.01:${PORTSDIR}/textproc/p5-XML-Compile \
+ p5-XML-Compile-Cache>=0.91:${PORTSDIR}/textproc/p5-XML-Compile-Cache
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::SOAP::WSA.3 \
+ XML::Compile::SOAP::WSA::Util.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP-WSA/distinfo b/net/p5-XML-Compile-SOAP-WSA/distinfo
new file mode 100644
index 00000000000..fa349326197
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-Compile-SOAP-WSA-0.12.tar.gz) = 288454b3293672fd78d4834b8cd07d3879ec1487f86c0cbcd6d0f91fe8e54399
+SIZE (XML-Compile-SOAP-WSA-0.12.tar.gz) = 12302
diff --git a/net/p5-XML-Compile-SOAP-WSA/pkg-descr b/net/p5-XML-Compile-SOAP-WSA/pkg-descr
new file mode 100644
index 00000000000..48b685f2fe2
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/pkg-descr
@@ -0,0 +1,10 @@
+The Web Service Addressing protocol is used to select certain service
+and port on a SOAP server, just like the "Host" header in "HTTP".
+
+The basic SOAP design uses the URI and the "soapAction" header of HTTP
+(in case it uses HTTP, by far the most often used transport mechanism)
+However, when the server is hidden behind firewalls and proxies, these
+fields are rewritten or replaced. This means that the definitions by
+the WSDL for the client can differ from the configuration of the
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP-WSA/
diff --git a/net/p5-XML-Compile-SOAP-WSA/pkg-plist b/net/p5-XML-Compile-SOAP-WSA/pkg-plist
new file mode 100644
index 00000000000..45dd934c755
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/WSA/.packlist
+%%SITE_PERL%%/XML/Compile/SOAP/WSA.pm
+%%SITE_PERL%%/XML/Compile/SOAP/WSA.pod
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/Util.pm
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/Util.pod
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20060512-wsaw.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20070131-metadata.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20070619-wsa09.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20080723-wsa10.xsd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/WSA/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP/WSA
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML