aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-01-27 01:44:55 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-01-27 01:44:55 +0800
commit24bdf60a2fa4a36f8abf349164cdd12cd8e9bf95 (patch)
treeff73b186f702d87ce2aa412008d3363cf5e32153 /net
parente305ab942a72b4975e39d3ea50d6471ffe02f350 (diff)
downloadfreebsd-ports-graphics-24bdf60a2fa4a36f8abf349164cdd12cd8e9bf95.tar.gz
freebsd-ports-graphics-24bdf60a2fa4a36f8abf349164cdd12cd8e9bf95.tar.zst
freebsd-ports-graphics-24bdf60a2fa4a36f8abf349164cdd12cd8e9bf95.zip
This module implements various functions needed for making a ZConf backed mail
cleint. It also currently includes two small utilities, listed below. zcmailcompose - Composes a mail message and sends it using the specified account. zcgetmail - A getmail replacement using ZConf::Mail. WWW: http://search.cpan.org/dist/ZConf-Mail/ PR: ports/ports/130564 Submitted by: Zane C, Bowers <vvelox at vvelox.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-ZConf-Mail/Makefile34
-rw-r--r--net/p5-ZConf-Mail/distinfo3
-rw-r--r--net/p5-ZConf-Mail/pkg-descr9
-rw-r--r--net/p5-ZConf-Mail/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1b8e2f5e610..adc993b633d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -641,6 +641,7 @@
SUBDIR += p5-XML-RPC
SUBDIR += p5-XPC
SUBDIR += p5-ZConf
+ SUBDIR += p5-ZConf-Mail
SUBDIR += p5-perl-ldap
SUBDIR += panoptis
SUBDIR += paris-traceroute
diff --git a/net/p5-ZConf-Mail/Makefile b/net/p5-ZConf-Mail/Makefile
new file mode 100644
index 00000000000..bdf53917d04
--- /dev/null
+++ b/net/p5-ZConf-Mail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-ZConf-Mail
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Mail
+PORTVERSION= 0.0.0
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Misc mail client functions backed by ZConf
+
+RUN_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/Email/Simple/Creator.pm:${PORTSDIR}/mail/p5-Email-Simple-Creator \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/POP3Client.pm:${PORTSDIR}/mail/p5-Mail-POP3Client \
+ ${SITE_PERL}/Net/SMTP_auth.pm:${PORTSDIR}/mail/p5-Net-SMTP_auth \
+ ${SITE_PERL}/Net/SMTP/TLS.pm:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
+ ${SITE_PERL}/Mail/Box.pm:${PORTSDIR}/mail/p5-Mail-Box \
+ ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ ${SITE_PERL}/IO/MultiPipe.pm:${PORTSDIR}/devel/p5-IO-MultiPipe
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Mail.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-ZConf-Mail/distinfo b/net/p5-ZConf-Mail/distinfo
new file mode 100644
index 00000000000..f3497623f70
--- /dev/null
+++ b/net/p5-ZConf-Mail/distinfo
@@ -0,0 +1,3 @@
+MD5 (ZConf-Mail-0.0.0.tar.gz) = f3ba77ee987db2dccf51d42bdbeca501
+SHA256 (ZConf-Mail-0.0.0.tar.gz) = ee2e8c151b5fe4500d00af70b1ff86bf4ebc2141ba61c1d38361d38699a9329f
+SIZE (ZConf-Mail-0.0.0.tar.gz) = 13694
diff --git a/net/p5-ZConf-Mail/pkg-descr b/net/p5-ZConf-Mail/pkg-descr
new file mode 100644
index 00000000000..1f19fcbe809
--- /dev/null
+++ b/net/p5-ZConf-Mail/pkg-descr
@@ -0,0 +1,9 @@
+This module implements various functions needed for making a ZConf backed mail
+cleint. It also currently includes two small utilities, listed below.
+
+zcmailcompose - Composes a mail message and sends it using the specified
+ account.
+zcgetmail - A getmail replacement using ZConf::Mail.
+
+
+WWW: http://search.cpan.org/dist/ZConf-Mail/
diff --git a/net/p5-ZConf-Mail/pkg-plist b/net/p5-ZConf-Mail/pkg-plist
new file mode 100644
index 00000000000..04d059cb3c7
--- /dev/null
+++ b/net/p5-ZConf-Mail/pkg-plist
@@ -0,0 +1,7 @@
+bin/zcmailcompose
+bin/zcgetmail
+%%SITE_PERL%%/ZConf/Mail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Mail/.packlist
+@dirrmtry %%SITE_PERL%%/Zconf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Mail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf