aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-10-20 21:28:22 +0800
committerijliao <ijliao@FreeBSD.org>2001-10-20 21:28:22 +0800
commit25b38615b4631fd95ec38130d52368d949be6804 (patch)
treed603b5726f79f94585ea0b5a15493a1341355a62 /net
parent82603198c6ae499482f34417a251738d6d2105d1 (diff)
downloadfreebsd-ports-graphics-25b38615b4631fd95ec38130d52368d949be6804.tar.gz
freebsd-ports-graphics-25b38615b4631fd95ec38130d52368d949be6804.tar.zst
freebsd-ports-graphics-25b38615b4631fd95ec38130d52368d949be6804.zip
add p5-RPC-XML
XML-RPC client and server library for Perl PR: 30368 Submitted by: Dominic Mitchell <dom@happygiraffe.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-RPC-XML/Makefile31
-rw-r--r--net/p5-RPC-XML/distinfo1
-rw-r--r--net/p5-RPC-XML/pkg-comment1
-rw-r--r--net/p5-RPC-XML/pkg-descr6
-rw-r--r--net/p5-RPC-XML/pkg-plist35
6 files changed, 75 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bf525e0af3e..e71b1659a73 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -294,6 +294,7 @@
SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-NetPacket
SUBDIR += p5-PlRPC
+ SUBDIR += p5-RPC-XML
SUBDIR += p5-SNMP
SUBDIR += p5-SNMP-Util
SUBDIR += p5-SNMP_Session
diff --git a/net/p5-RPC-XML/Makefile b/net/p5-RPC-XML/Makefile
new file mode 100644
index 00000000000..d7a201b62b3
--- /dev/null
+++ b/net/p5-RPC-XML/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-XML-RPC
+# Date created: 6 Sep 2001
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RPC-XML
+PORTVERSION= 0.27
+CATEGORIES= net www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::RPC::Server.3 \
+ RPC::XML.3 \
+ RPC::XML::Client.3 \
+ RPC::XML::Parser.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-RPC-XML/distinfo b/net/p5-RPC-XML/distinfo
new file mode 100644
index 00000000000..c638909e11e
--- /dev/null
+++ b/net/p5-RPC-XML/distinfo
@@ -0,0 +1 @@
+MD5 (RPC-XML-0.27.tar.gz) = cac1ab883cb6d9e51065e23208baf9d4
diff --git a/net/p5-RPC-XML/pkg-comment b/net/p5-RPC-XML/pkg-comment
new file mode 100644
index 00000000000..bf10fd6bd83
--- /dev/null
+++ b/net/p5-RPC-XML/pkg-comment
@@ -0,0 +1 @@
+XML-RPC client and server library for Perl
diff --git a/net/p5-RPC-XML/pkg-descr b/net/p5-RPC-XML/pkg-descr
new file mode 100644
index 00000000000..82f1dcffb71
--- /dev/null
+++ b/net/p5-RPC-XML/pkg-descr
@@ -0,0 +1,6 @@
+WHAT IS IT
+
+The RPC::XML package is an implementation of XML-RPC. The module
+provides classes for sample client and server implementations, a
+server designed as an Apache location-handler, and a suite of
+data-manipulation classes that are used by them.
diff --git a/net/p5-RPC-XML/pkg-plist b/net/p5-RPC-XML/pkg-plist
new file mode 100644
index 00000000000..e0a5ec209a6
--- /dev/null
+++ b/net/p5-RPC-XML/pkg-plist
@@ -0,0 +1,35 @@
+bin/make_method
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RPC/XML/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Apache/RPC/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/RPC/status.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML.pm
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/identity.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/introspection.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/listMethods.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/methodHelp.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/methodSignature.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/multicall.xpl
+lib/perl5/site_perl/%%PERL_VER%%/RPC/XML/status.xpl
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/add_default_methods.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/add_methods_in_dir.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/call.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/dispatch.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/get_method.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/load_XPL_file.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/method_to_ref.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/post_configure_hook.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/pre_loop_hook.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/process_request.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server/server_loop.al
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache/RPC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/RPC/XML
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML/Server
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/RPC/XML
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RPC/XML
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/RPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/RPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/RPC 2>/dev/null || true