aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2000-07-29 14:26:00 +0800
committersada <sada@FreeBSD.org>2000-07-29 14:26:00 +0800
commit3060a54e5f4f5bac2121cb115fdb43d45232659d (patch)
treea6fa938adcc24f03313fee65d1b95cd5cb08bff2 /net
parent962970e6adf9361d8197e1b80feacd93cc1ec74d (diff)
downloadfreebsd-ports-graphics-3060a54e5f4f5bac2121cb115fdb43d45232659d.tar.gz
freebsd-ports-graphics-3060a54e5f4f5bac2121cb115fdb43d45232659d.tar.zst
freebsd-ports-graphics-3060a54e5f4f5bac2121cb115fdb43d45232659d.zip
New port Tcpillust - A graphical TCP connection analysis tool
Tcpillust takes tcpdump file(s) specified on the command line and draw pictures like figures in the ``TCP/IP Illustrated'' series. PR: ports/18130 Submitted by: Yoshifumi Nishida <nishida@csl.sony.co.jp>
Diffstat (limited to 'net')
-rw-r--r--net/tcpillust/Makefile41
-rw-r--r--net/tcpillust/distinfo1
-rw-r--r--net/tcpillust/pkg-comment1
-rw-r--r--net/tcpillust/pkg-descr4
-rw-r--r--net/tcpillust/pkg-plist12
5 files changed, 59 insertions, 0 deletions
diff --git a/net/tcpillust/Makefile b/net/tcpillust/Makefile
new file mode 100644
index 00000000000..c79706ffe21
--- /dev/null
+++ b/net/tcpillust/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: tcpillust
+# Date created: 14 April 2000
+# Whom: nishida@csl.sony.co.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpillust
+PORTVERSION= 1.0a
+CATEGORIES= net tk82 tcl82
+MASTER_SITES= ftp://ftp.csl.sony.co.jp/CSL/nishida/
+
+MAINTAINER= nishida@csl.sony.co.jp
+
+LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
+ tcl82.1:${PORTSDIR}/lang/tcl82
+
+USE_IMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS=
+REQUIRES_MOTIF= yes
+
+MAN1= tcpillust.1
+
+DOCS= README
+
+SAMPLES= tcpclient.log tcpserver.log
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/tcpillust
+ for i in $(DOCS); do \
+ ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/tcpillust; \
+ done
+ ${MKDIR} ${PREFIX}/share/doc/tcpillust/sample
+ for i in $(SAMPLES); do \
+ ${INSTALL_DATA} ${WRKSRC}/sample/$$i ${PREFIX}/share/doc/tcpillust/sample; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcpillust/distinfo b/net/tcpillust/distinfo
new file mode 100644
index 00000000000..99f8fe97026
--- /dev/null
+++ b/net/tcpillust/distinfo
@@ -0,0 +1 @@
+MD5 (tcpillust-1.0a.tar.gz) = 9c5cfc176a28fe83e0c647230ca497ec
diff --git a/net/tcpillust/pkg-comment b/net/tcpillust/pkg-comment
new file mode 100644
index 00000000000..5e65d2b2695
--- /dev/null
+++ b/net/tcpillust/pkg-comment
@@ -0,0 +1 @@
+A graphical TCP connection analysis tool
diff --git a/net/tcpillust/pkg-descr b/net/tcpillust/pkg-descr
new file mode 100644
index 00000000000..e478c9109a3
--- /dev/null
+++ b/net/tcpillust/pkg-descr
@@ -0,0 +1,4 @@
+Tcpillust - A graphical TCP connection analysis tool
+
+Tcpillust takes tcpdump file(s) specified on the command line and draw
+pictures like figures in the ``TCP/IP Illustrated'' series.
diff --git a/net/tcpillust/pkg-plist b/net/tcpillust/pkg-plist
new file mode 100644
index 00000000000..d5b26a098c9
--- /dev/null
+++ b/net/tcpillust/pkg-plist
@@ -0,0 +1,12 @@
+bin/tcpillust
+lib/X11/tcpillust/tcpillust.tcl
+lib/X11/tcpillust/back.xbm
+lib/X11/tcpillust/forward.xbm
+lib/X11/tcpillust/zoomin.xbm
+lib/X11/tcpillust/zoomout.xbm
+share/doc/tcpillust/sample/tcpclient.log
+share/doc/tcpillust/sample/tcpserver.log
+share/doc/tcpillust/README
+@dirrm lib/X11/tcpillust
+@dirrm share/doc/tcpillust/sample
+@dirrm share/doc/tcpillust