aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-11-01 19:26:03 +0800
committerbeech <beech@FreeBSD.org>2007-11-01 19:26:03 +0800
commit38c3995c0356b890a377d08b226000ebe59a9cf3 (patch)
treee0e62d80a55430e8e84fa063731db6b3c02a4902 /net
parent636439af657356907da0c8e89af474b72d62060b (diff)
downloadfreebsd-ports-graphics-38c3995c0356b890a377d08b226000ebe59a9cf3.tar.gz
freebsd-ports-graphics-38c3995c0356b890a377d08b226000ebe59a9cf3.tar.zst
freebsd-ports-graphics-38c3995c0356b890a377d08b226000ebe59a9cf3.zip
- Drag from attic
Approved by: portmgr (linimon, kris), sat (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/skype-devel/Makefile49
-rw-r--r--net/skype-devel/distinfo3
-rw-r--r--net/skype-devel/pkg-descr5
-rw-r--r--net/skype-devel/pkg-plist31
5 files changed, 89 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2c6637ade51..aec453c677a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -813,6 +813,7 @@
SUBDIR += sixxs-aiccu
SUBDIR += skstream
SUBDIR += skype
+ SUBDIR += skype-devel
SUBDIR += sl2tps
SUBDIR += slbd
SUBDIR += slirp
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
new file mode 100644
index 00000000000..f16c85dfce3
--- /dev/null
+++ b/net/skype-devel/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: skype
+# Date created: Jun 21. 2004
+# Whom: netchild@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= skype
+PORTVERSION= 1.4.0.99
+CATEGORIES= net
+MASTER_SITES= http://download.skype.com/linux/
+PKGNAMESUFFIX= -devel
+DISTNAME= skype_static-${DISTVERSION}
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= P2P VoIP software
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
+
+.ifdef WITH_NVIDIA_GL
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+USE_GL= linux
+.endif
+
+BROKEN= alsa sound not working
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386 amd64
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}
+DATADIR= ${PREFIX}/share/${PKGBASE}
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/skype
+
+do-install:
+ @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype-devel_bin
+ @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype-devel_bin \"\$$@\" 2>&1 | ${GREP} -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype-devel
+ @${CHMOD} a+rx ${PREFIX}/bin/skype-devel
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>
diff --git a/net/skype-devel/distinfo b/net/skype-devel/distinfo
new file mode 100644
index 00000000000..e7e83da924f
--- /dev/null
+++ b/net/skype-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (skype_static-1.4.0.99.tar.bz2) = 879418eb6a64cd5ff561465a41bb78ab
+SHA256 (skype_static-1.4.0.99.tar.bz2) = bfa236e74b00222360d8e4a83fac7560e6043d264d29911645bcdea8be5fe14c
+SIZE (skype_static-1.4.0.99.tar.bz2) = 17543204
diff --git a/net/skype-devel/pkg-descr b/net/skype-devel/pkg-descr
new file mode 100644
index 00000000000..5d92fde2ea4
--- /dev/null
+++ b/net/skype-devel/pkg-descr
@@ -0,0 +1,5 @@
+Skype is a free program that uses the latest P2P technology to bring
+affordable and high-quality voice communications to people all over
+the world.
+
+WWW: http://www.skype.net/
diff --git a/net/skype-devel/pkg-plist b/net/skype-devel/pkg-plist
new file mode 100644
index 00000000000..350acf4c74d
--- /dev/null
+++ b/net/skype-devel/pkg-plist
@@ -0,0 +1,31 @@
+bin/skype-devel
+bin/skype-devel_bin
+%%DATADIR%%/LICENSE
+%%DATADIR%%/README
+%%DATADIR%%/icons/SkypeBlue_16x16.png
+%%DATADIR%%/icons/SkypeBlue_32x32.png
+%%DATADIR%%/icons/SkypeBlue_48x48.png
+%%DATADIR%%/sounds/CallBusy.wav
+%%DATADIR%%/sounds/CallConnecting.wav
+%%DATADIR%%/sounds/CallHangup.wav
+%%DATADIR%%/sounds/CallHold.wav
+%%DATADIR%%/sounds/CallRemoteHangup.wav
+%%DATADIR%%/sounds/CallResume.wav
+%%DATADIR%%/sounds/CallRingingIn.wav
+%%DATADIR%%/sounds/CallRingingOut.wav
+%%DATADIR%%/sounds/ChatIncoming.wav
+%%DATADIR%%/sounds/ChatIncomingInitial.wav
+%%DATADIR%%/sounds/ChatOutgoing.wav
+%%DATADIR%%/sounds/ContactAdded.wav
+%%DATADIR%%/sounds/ContactAuthRequest.wav
+%%DATADIR%%/sounds/ContactOffline.wav
+%%DATADIR%%/sounds/ContactOnline.wav
+%%DATADIR%%/sounds/SkypeLogin.wav
+%%DATADIR%%/sounds/SkypeLogout.wav
+%%DATADIR%%/sounds/TransferComplete.wav
+%%DATADIR%%/sounds/TransferFailed.wav
+%%DATADIR%%/sounds/TransferRequest.wav
+%%DATADIR%%/sounds/VoicemailReceived.wav
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%