aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-01-15 14:13:25 +0800
committerclsung <clsung@FreeBSD.org>2007-01-15 14:13:25 +0800
commit3dfbdda49dec2a06d03bd746d52cc1c0550a49f3 (patch)
tree1d8835529239a08c7ff6804beb61d86439f46c67 /net
parent4b39d027c66f5b3749863fa6bf38eb29995b58a5 (diff)
downloadfreebsd-ports-graphics-3dfbdda49dec2a06d03bd746d52cc1c0550a49f3.tar.gz
freebsd-ports-graphics-3dfbdda49dec2a06d03bd746d52cc1c0550a49f3.tar.zst
freebsd-ports-graphics-3dfbdda49dec2a06d03bd746d52cc1c0550a49f3.zip
Net::Frame::Dump is the base class for all dump modules. With them,
you can open a device for live capture, for offline analysis, or for creating a pcap file. WWW: http://search.cpan.org/dist/Net-Frame-Dump/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Frame-Dump/Makefile41
-rw-r--r--net/p5-Net-Frame-Dump/distinfo3
-rw-r--r--net/p5-Net-Frame-Dump/pkg-descr5
-rw-r--r--net/p5-Net-Frame-Dump/pkg-plist11
5 files changed, 61 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 414088b14cc..2c9cab2ff44 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -448,6 +448,7 @@
SUBDIR += p5-Net-FTP-File
SUBDIR += p5-Net-Finger
SUBDIR += p5-Net-Frame
+ SUBDIR += p5-Net-Frame-Dump
SUBDIR += p5-Net-Gnats
SUBDIR += p5-Net-Google
SUBDIR += p5-Net-Google-Calendar
diff --git a/net/p5-Net-Frame-Dump/Makefile b/net/p5-Net-Frame-Dump/Makefile
new file mode 100644
index 00000000000..c7d755fa2c4
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Net-Frame-Dump
+# Date created: 08 Jan 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Frame-Dump
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Tcpdump like perl implementation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector \
+ ${SITE_PERL}/Net/Frame.pm:${PORTSDIR}/net/p5-Net-Frame \
+ p5-Net-Pcap>=0.12:${PORTSDIR}/net/p5-Net-Pcap \
+ p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Frame::Dump.3 \
+ Net::Frame::Dump::Offline.3 \
+ Net::Frame::Dump::Online.3 \
+ Net::Frame::Dump::Writer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Frame-Dump/distinfo b/net/p5-Net-Frame-Dump/distinfo
new file mode 100644
index 00000000000..f0e2e1b5714
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Frame-Dump-1.00.tar.gz) = 85764c650b9b7871c85fea4c2ec4e2a0
+SHA256 (Net-Frame-Dump-1.00.tar.gz) = 7dcc324e9f8b2a1a72250104367e30468e4584035f8d884d26343e31e781b8c5
+SIZE (Net-Frame-Dump-1.00.tar.gz) = 11327
diff --git a/net/p5-Net-Frame-Dump/pkg-descr b/net/p5-Net-Frame-Dump/pkg-descr
new file mode 100644
index 00000000000..dc69cd4a682
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/pkg-descr
@@ -0,0 +1,5 @@
+Net::Frame::Dump is the base class for all dump modules. With them,
+you can open a device for live capture, for offline analysis, or
+for creating a pcap file.
+
+WWW: http://search.cpan.org/dist/Net-Frame-Dump/
diff --git a/net/p5-Net-Frame-Dump/pkg-plist b/net/p5-Net-Frame-Dump/pkg-plist
new file mode 100644
index 00000000000..3aced19caec
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Net/Frame/Dump.pm
+%%SITE_PERL%%/Net/Frame/Dump/Offline.pm
+%%SITE_PERL%%/Net/Frame/Dump/Online.pm
+%%SITE_PERL%%/Net/Frame/Dump/Writer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame/Dump/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame/Dump
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Frame/Dump
+@dirrmtry %%SITE_PERL%%/Net/Frame
+@dirrmtry %%SITE_PERL%%/Net