aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2008-07-25 16:46:16 +0800
committerbsam <bsam@FreeBSD.org>2008-07-25 16:46:16 +0800
commit42c98ca4cafda5af2256f26d511d96335a1d6fda (patch)
treed1d5d42ff572990e19ff44b646471b6e91ae42a2 /net
parent86d30ecc1f9c92138c8f9981ec12aa29de50d740 (diff)
downloadfreebsd-ports-graphics-42c98ca4cafda5af2256f26d511d96335a1d6fda.tar.gz
freebsd-ports-graphics-42c98ca4cafda5af2256f26d511d96335a1d6fda.tar.zst
freebsd-ports-graphics-42c98ca4cafda5af2256f26d511d96335a1d6fda.zip
Skyfish saves the information being sent via the HTTP protocol to disk.
Allow filtering by type, file size and simultaneously listening several network interfaces. It's possible to grab sattelite internet traffic. WWW: http://www.lissyara.su/?id=1677 - Surkov Andrey nsand@sura.ru PR: ports/124218 Submitted by: Nsand <nsand at sura.ru>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/skyfish/Makefile31
-rw-r--r--net/skyfish/distinfo3
-rw-r--r--net/skyfish/pkg-descr7
-rw-r--r--net/skyfish/pkg-plist12
5 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 28b24273232..589fe5d3397 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -860,6 +860,7 @@
SUBDIR += sipxvxml
SUBDIR += sixxs-aiccu
SUBDIR += skstream
+ SUBDIR += skyfish
SUBDIR += skype
SUBDIR += skype-devel
SUBDIR += skype12
diff --git a/net/skyfish/Makefile b/net/skyfish/Makefile
new file mode 100644
index 00000000000..cb6679c0c10
--- /dev/null
+++ b/net/skyfish/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: skyfish
+# Date created: 23 May 2008
+# Whom: Nsand <nsand@sura.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skyfish
+PORTVERSION= 0.83
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.lissyara.su/users/nsand/skyfish/
+
+MAINTAINER= nsand@sura.ru
+COMMENT= Grabbing TCP streams from network interface (SAT internet)
+
+SYSDIR?= ${SRC_BASE}/sys
+KMODDIR= /boot/modules
+PLIST_SUB+= KMODDIR=${KMODDIR}
+
+MAN1= skyfish.1
+MANCOMPRESSED= yes
+
+pre-fetch:
+.if !exists(${SYSDIR}/Makefile)
+ @${ECHO} "*************************************************"; \
+ ${ECHO} "This port requires the kernel source be available"; \
+ ${ECHO} "*************************************************"; \
+ exit 1
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/skyfish/distinfo b/net/skyfish/distinfo
new file mode 100644
index 00000000000..35a0dd3a16d
--- /dev/null
+++ b/net/skyfish/distinfo
@@ -0,0 +1,3 @@
+MD5 (skyfish-0.83.tar.gz) = dda4e72ed72de48c823513dd773d4fbb
+SHA256 (skyfish-0.83.tar.gz) = f1040e363f070a40f23f2990f6a20a6a5c136731c5b2b4c2f5add74151a02bc0
+SIZE (skyfish-0.83.tar.gz) = 31150
diff --git a/net/skyfish/pkg-descr b/net/skyfish/pkg-descr
new file mode 100644
index 00000000000..122828a77a0
--- /dev/null
+++ b/net/skyfish/pkg-descr
@@ -0,0 +1,7 @@
+Skyfish saves the information being sent via the HTTP protocol to disk.
+Allow filtering by type, file size and simultaneously listening several
+network interfaces. It's possible to grab sattelite internet traffic.
+
+WWW: http://www.lissyara.su/?id=1677
+- Surkov Andrey
+nsand@sura.ru
diff --git a/net/skyfish/pkg-plist b/net/skyfish/pkg-plist
new file mode 100644
index 00000000000..84b97af151c
--- /dev/null
+++ b/net/skyfish/pkg-plist
@@ -0,0 +1,12 @@
+bin/skyfish
+etc/skyfish.conf.dist
+share/doc/skyfish/README
+share/doc/skyfish/README.rus
+share/doc/skyfish/CHANGES
+share/doc/skyfish/COPYRIGHT
+share/doc/skyfish/CREDITS
+@dirrm share/doc/skyfish
+@cwd %%KMODDIR%%
+ng_skyfish.ko
+@unexec /bin/rm %D/skyfish2.ko.symbols 2>/dev/null || /usr/bin/true
+@unexec kldxref %D