aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-22 20:40:04 +0800
committermat <mat@FreeBSD.org>2016-04-22 20:40:04 +0800
commit42e898d217fbdd36ab4d89ec0ce35514007e4985 (patch)
tree368b672d684456fd3d707cabe51d0c42518857db /net
parent5113c511dc0aee522032d69f0f95edfae18ceea7 (diff)
downloadfreebsd-ports-graphics-42e898d217fbdd36ab4d89ec0ce35514007e4985.tar.gz
freebsd-ports-graphics-42e898d217fbdd36ab4d89ec0ce35514007e4985.tar.zst
freebsd-ports-graphics-42e898d217fbdd36ab4d89ec0ce35514007e4985.zip
Move lang/go/files/bsd.go.mk to USES=go.
Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6057
Diffstat (limited to 'net')
-rw-r--r--net/go-amqp/Makefile5
-rw-r--r--net/go-geoip/Makefile5
-rw-r--r--net/go.net/Makefile5
3 files changed, 7 insertions, 8 deletions
diff --git a/net/go-amqp/Makefile b/net/go-amqp/Makefile
index 776684fa276..1a345a1a27b 100644
--- a/net/go-amqp/Makefile
+++ b/net/go-amqp/Makefile
@@ -10,12 +10,11 @@ COMMENT= Go library for AMQP client with RabbitMQ extensions
LICENSE= BSD2CLAUSE
+USES= go
USE_GITHUB= yes
GH_ACCOUNT= streadway
GH_TAGNAME= 7d6d180
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/go-geoip/Makefile b/net/go-geoip/Makefile
index 179ba3cef58..bdd65bca996 100644
--- a/net/go-geoip/Makefile
+++ b/net/go-geoip/Makefile
@@ -13,7 +13,7 @@ LICENSE= MIT
LIB_DEPENDS= libGeoIP.so:net/GeoIP
-USES= compiler
+USES= compiler go
USE_GITHUB= yes
GH_ACCOUNT= abh
GH_TAGNAME= da13074
@@ -21,8 +21,9 @@ GH_TAGNAME= da13074
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+
.if ${COMPILER_TYPE} == clang && ${CC} == cc
CC= clang
.endif
+
.include <bsd.port.post.mk>
diff --git a/net/go.net/Makefile b/net/go.net/Makefile
index b126dc79711..5ad7c4fc98b 100644
--- a/net/go.net/Makefile
+++ b/net/go.net/Makefile
@@ -13,6 +13,7 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/go.text:textproc/go.text
+USES= go
GO_PKGNAME= code.google.com/p/go.net
GO_TARGET= ${GO_PKGNAME}/dict \
${GO_PKGNAME}/html \
@@ -27,6 +28,4 @@ GO_TARGET= ${GO_PKGNAME}/dict \
${GO_PKGNAME}/spdy \
${GO_PKGNAME}/websocket
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>