aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2010-12-09 08:44:50 +0800
committerflo <flo@FreeBSD.org>2010-12-09 08:44:50 +0800
commit4758a516e8af3531af9fa9b4b7c14919a4b3fddd (patch)
tree65d4c9ecf717d1319220d18a2ccaf18e716a0be4 /net
parent931c78de1295aaa701b5fdb0eb2f0f09cbd1f848 (diff)
downloadfreebsd-ports-graphics-4758a516e8af3531af9fa9b4b7c14919a4b3fddd.tar.gz
freebsd-ports-graphics-4758a516e8af3531af9fa9b4b7c14919a4b3fddd.tar.zst
freebsd-ports-graphics-4758a516e8af3531af9fa9b4b7c14919a4b3fddd.zip
- add support for iodbc [1]
- expilitly disable iodbc and unixodbc if they are not selected - tweak pkg-plist Requested by: fjoe [1] Approved by: fjoe (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile26
-rw-r--r--net/asterisk/pkg-plist2
-rw-r--r--net/asterisk10/Makefile26
-rw-r--r--net/asterisk10/pkg-plist2
4 files changed, 44 insertions, 12 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 7864467f660..f473758dd04 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -45,7 +45,8 @@ MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8
CONFLICTS= asterisk*-1.2* asterisk*-1.4* asterisk*-1.6*
OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
- ODBC "Enable ODBC support" on \
+ IODBC "Enable iODBC support" off \
+ UODBC "Enable unixODBC support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
@@ -70,6 +71,10 @@ GROUPS= ${ASTERISK_GROUP} dahdi
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
OPTIONS+= DAHDI "Enable DAHDI support" on
+.if defined(WITH_IODBC) && defined(WITH_UODBC)
+IGNORE= please select only one of iodbc or unixODBC
+.endif
+
# Include this since we have altered OPTIONS.
.include <bsd.port.options.mk>
.endif
@@ -103,14 +108,25 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/dahdi/dahdi.ko:${PORTSDIR}/misc/dahdi
#
# WITH_FREETDS, WITH_PGSQL and WITH_SQLITE can also be added to MAKE_ENV
# similarly
-.if !defined(WITH_ODBC)
-PLIST_SUB+= WITH_ODBC="@comment "
+.if !defined(WITH_UODBC)
CONFIGURE_ARGS+= --without-unixodbc
-.else
+.endif
+.if !defined(WITH_IODBC)
+CONFIGURE_ARGS+= --without-iodbc
+.endif
+.if !defined(WITH_UODBC) && !defined(WITH_IODBC)
+PLIST_SUB+= WITH_ODBC="@comment "
+.endif
+.if defined(WITH_UODBC) || defined(WITH_IODBC)
PLIST_SUB+= WITH_ODBC=""
+USE_AUTOTOOLS= libltdl
+.if defined(WITH_UODBC)
CONFIGURE_ARGS+= --with-unixodbc --with-ltdl
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-USE_AUTOTOOLS= libltdl
+.elif defined(WITH_IODBC)
+CONFIGURE_ARGS+= --with-iodbc --with-ltdl
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+.endif
.endif
.if !defined(WITH_FREETDS)
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index be894e5b785..2ce3f7839b9 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -540,7 +540,7 @@ lib/asterisk/modules/cdr_manager.so
lib/asterisk/modules/cdr_syslog.so
lib/asterisk/modules/cel_custom.so
lib/asterisk/modules/cel_manager.so
-lib/asterisk/modules/cel_odbc.so
+%%WITH_ODBC%%lib/asterisk/modules/cel_odbc.so
lib/asterisk/modules/cel_pgsql.so
lib/asterisk/modules/cel_radius.so
lib/asterisk/modules/cel_sqlite3_custom.so
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 7864467f660..f473758dd04 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -45,7 +45,8 @@ MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8
CONFLICTS= asterisk*-1.2* asterisk*-1.4* asterisk*-1.6*
OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
- ODBC "Enable ODBC support" on \
+ IODBC "Enable iODBC support" off \
+ UODBC "Enable unixODBC support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
@@ -70,6 +71,10 @@ GROUPS= ${ASTERISK_GROUP} dahdi
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
OPTIONS+= DAHDI "Enable DAHDI support" on
+.if defined(WITH_IODBC) && defined(WITH_UODBC)
+IGNORE= please select only one of iodbc or unixODBC
+.endif
+
# Include this since we have altered OPTIONS.
.include <bsd.port.options.mk>
.endif
@@ -103,14 +108,25 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/dahdi/dahdi.ko:${PORTSDIR}/misc/dahdi
#
# WITH_FREETDS, WITH_PGSQL and WITH_SQLITE can also be added to MAKE_ENV
# similarly
-.if !defined(WITH_ODBC)
-PLIST_SUB+= WITH_ODBC="@comment "
+.if !defined(WITH_UODBC)
CONFIGURE_ARGS+= --without-unixodbc
-.else
+.endif
+.if !defined(WITH_IODBC)
+CONFIGURE_ARGS+= --without-iodbc
+.endif
+.if !defined(WITH_UODBC) && !defined(WITH_IODBC)
+PLIST_SUB+= WITH_ODBC="@comment "
+.endif
+.if defined(WITH_UODBC) || defined(WITH_IODBC)
PLIST_SUB+= WITH_ODBC=""
+USE_AUTOTOOLS= libltdl
+.if defined(WITH_UODBC)
CONFIGURE_ARGS+= --with-unixodbc --with-ltdl
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-USE_AUTOTOOLS= libltdl
+.elif defined(WITH_IODBC)
+CONFIGURE_ARGS+= --with-iodbc --with-ltdl
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+.endif
.endif
.if !defined(WITH_FREETDS)
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index be894e5b785..2ce3f7839b9 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -540,7 +540,7 @@ lib/asterisk/modules/cdr_manager.so
lib/asterisk/modules/cdr_syslog.so
lib/asterisk/modules/cel_custom.so
lib/asterisk/modules/cel_manager.so
-lib/asterisk/modules/cel_odbc.so
+%%WITH_ODBC%%lib/asterisk/modules/cel_odbc.so
lib/asterisk/modules/cel_pgsql.so
lib/asterisk/modules/cel_radius.so
lib/asterisk/modules/cel_sqlite3_custom.so